Bug 82275 - Windows crashes after install
Summary: Windows crashes after install
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: needsWindows
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-07 04:16 UTC by Graham Blaikie
Modified: 2015-05-25 12:17 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
attachment-9450-0.html (2.46 KB, text/html)
2014-08-08 07:41 UTC, Graham Blaikie
Details
attachment-9450-1.dat (1 bytes, multipart/alternative)
2014-08-08 07:41 UTC, Graham Blaikie
Details
FontList.txt (14.20 KB, text/plain)
2014-08-08 07:41 UTC, Graham Blaikie
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Graham Blaikie 2014-08-07 04:16:31 UTC
XP Pro 32 SP3.  After updating LibreOffice 4.2.5 to 4.3.004 first Windows Explorer crashed then Dr Watson Debugger crashed bringing Windows to a total halt.  Rebooting didn't fix anything and windows explorer and Dr Watson crashed again quickly without trying to open LibreOffice.  After rebooting I managed to uninstall LibreOffice, Windows totally stable, and tried a fresh installation but the same again.  I did a total clean-out of all LibreOffice and went back to 4.2.5.  Windows has been totally stable since.

As I did a complete clean-out, including temporary files, I have nothing to attach.

Regards

G Blaikie
Comment 1 Julien Nabet 2014-08-07 11:54:40 UTC
Just for information, did you test with a brand new LO profile (see https://wiki.documentfoundation.org/UserProfile#Windows)?

Did you install any specific fonts? (I mean fonts not included out-of-the-box in Windows). If yes, which ones?
Indeed, some fonts may trigger some problems.
Comment 2 Graham Blaikie 2014-08-08 02:56:40 UTC
First install was over 4.2.5.  After multiple attempts I totally removed 
all LibreOffice files and cleaned the registry of LibreOffice entries 
(using CCleaner and JV16 PowerTools and a manual search) then did a 
completely fresh install which would have used a brand new profile but 
that still caused Windows Explorer and Dr Watson Debugger to crash.  
Other fonts may have been added with other program installations, none 
added independently.  I also have AbiWord 2.8 and WordPerfect 12 installed.

As noted, I have completely removed 4.3 and reverted back to 4.2.5 and 
everything is totally stable.

On 7/08/2014 11:54 p.m., bugzilla-daemon@freedesktop.org wrote:
> Julien Nabet <mailto:serval2412@yahoo.fr> changed bug 82275 
> <https://bugs.freedesktop.org/show_bug.cgi?id=82275>
> What 	Removed 	Added
> Status 	UNCONFIRMED 	NEEDINFO
> CC 		serval2412@yahoo.fr
> Ever confirmed 		1
>
> *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=82275#c1> 
> on bug 82275 <https://bugs.freedesktop.org/show_bug.cgi?id=82275> from 
> Julien Nabet <mailto:serval2412@yahoo.fr> *
> Just for information, did you test with a brand new LO profile (see
> https://wiki.documentfoundation.org/UserProfile#Windows)?
>
> Did you install any specific fonts? (I mean fonts not included out-of-the-box
> in Windows). If yes, which ones?
> Indeed, some fonts may trigger some problems.
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>



---
This email is free from viruses and malware because avast! Antivirus protection is active.
http://www.avast.com
Comment 3 Julien Nabet 2014-08-08 05:49:31 UTC
Thank you for your feedback.
Would it be possible you attach the list of the fonts you've got? (windows\fonts)

(please don't answer directly from your emailer but from this link: https://bugs.freedesktop.org/show_bug.cgi?id=82275#)
Comment 4 Julien Nabet 2014-08-08 06:01:18 UTC
Also:
- do you use any accessibility option/tool?
- what's your precise Java version? (1.6/1.7/1.8), 32 or 64 bits? Indeed LO Windows version works only with Java 32 bits since LO can only be built in 32 bits.


For the test, would it be possible you give a try to 4.3 daily build? (see http://dev-builds.libreoffice.org/daily/libreoffice-4-3/Win-x86@42/current/)

If you still reproduce the problem with this version, it would be very helpful you retrieve a backtrace by following this link, see https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg
Comment 5 Graham Blaikie 2014-08-08 07:41:32 UTC
Created attachment 104260 [details]
attachment-9450-0.html

On 8/08/2014 5:49 p.m., bugzilla-daemon@freedesktop.org wrote:
>
> *Comment # 3 <https://bugs.freedesktop.org/show_bug.cgi?id=82275#c3> 
> on bug 82275 <https://bugs.freedesktop.org/show_bug.cgi?id=82275> from 
> Julien Nabet <mailto:serval2412@yahoo.fr> *
> Thank you for your feedback.
> Would it be possible you attach the list of the fonts you've got?
> (windows\fonts)
>
> (please don't answer directly from your emailer but from this link:
> https://bugs.freedesktop.org/show_bug.cgi?id=82275  <show_bug.cgi?id=82275>#)
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>



---
This email is free from viruses and malware because avast! Antivirus protection is active.
http://www.avast.com
Comment 6 Graham Blaikie 2014-08-08 07:41:32 UTC
Created attachment 104261 [details]
attachment-9450-1.dat
Comment 7 Graham Blaikie 2014-08-08 07:41:32 UTC
Created attachment 104262 [details]
FontList.txt
Comment 8 Graham Blaikie 2014-08-08 07:43:21 UTC
Java 7 release 67 32bit



On 8/08/2014 6:01 p.m., bugzilla-daemon@freedesktop.org wrote:
>
> *Comment # 4 <https://bugs.freedesktop.org/show_bug.cgi?id=82275#c4> 
> on bug 82275 <https://bugs.freedesktop.org/show_bug.cgi?id=82275> from 
> Julien Nabet <mailto:serval2412@yahoo.fr> *
> Also:
> - do you use any accessibility option/tool?
> - what's your precise Java version? (1.6/1.7/1.8), 32 or 64 bits? Indeed LO
> Windows version works only with Java 32 bits since LO can only be built in 32
> bits.
>
>
> For the test, would it be possible you give a try to 4.3 daily build? (see
> http://dev-builds.libreoffice.org/daily/libreoffice-4-3/Win-x86@42/current/)
>
> If you still reproduce the problem with this version, it would be very helpful
> you retrieve a backtrace by following this link, see
> https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>



---
This email is free from viruses and malware because avast! Antivirus protection is active.
http://www.avast.com
Comment 9 Julien Nabet 2014-08-09 05:41:50 UTC
Thank you for your feedback, I put it back to UNCONFIRMED since I don't have more questions to ask.
(PLEASE: if you want to let a new comment, don't answer directly from your emailer!)
Comment 10 Buovjaga 2014-11-26 12:27:28 UTC
Julien forgot to change status to UNCONFIRMED.
Comment 11 tommy27 2014-12-06 14:09:15 UTC
@Graham Blaikie
are you still experiencing this issue with current LibO 4.3.4.1 ?
have you tried to upgrade again from 4.2.5?
Comment 12 Robinson Tryon (qubit) 2015-01-03 16:59:27 UTC
(In reply to tommy27 from comment #11)
> @Graham Blaikie
> are you still experiencing this issue with current LibO 4.3.4.1 ?
> have you tried to upgrade again from 4.2.5?

Status -> NEEDINFO

(please change back to UNCONFIRMED if you can repro with modern builds:
https://www.libreoffice.org/download/
)
Comment 13 Timur 2015-05-25 12:17:12 UTC
More than 6 months without response, I close as Invalid.