Download it now!
Bug 82302 - Base: Grid ListBox and Number SelectedValue / Value not updating in Form
Summary: Base: Grid ListBox and Number SelectedValue / Value not updating in Form
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-07 15:38 UTC by Doug
Modified: 2015-06-09 13:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Doug 2014-08-07 15:38:01 UTC
This is the subject of question in LibreOffice forum.

http://ask.libreoffice.org/en/question/38003/base-how-to-change-listbox-selectedvalue-via-lo-basic/

Trying to use LO Basic macro to change value of List Box in LO Base form. The ListBox is on a grid control on the form.

The following operation
  
  oGridControl.GetByName("list1").SelectedValue = new_val

updates the value in the grid column, but the grid does not display or save the value, it is a phanotom and ignored value that only is confirmed by printing the .currentvalue.  This operation performs as expected on field that is not on grid.

Expected result:  Should have the same result on list or number field on grid, which it does on normal off-grid number or list field.

Actual result:  List and number field values not updateable on grid by means used in LO Basic for normal form fields.
Comment 1 Buovjaga 2014-11-09 18:53:26 UTC
Changing to UNCONFIRMED, we need someone to reproduce this.
Comment 2 raal 2014-11-27 20:02:10 UTC
Hello Doug,

Thank you for filing the bug. Please send us a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO', so please do change it back to 'UNCONFIRMED' once you have attached a document.
(Please note that the attachment will be public, remove any sensitive information before attaching it.)
How can I eliminate confidential data from a sample document?
https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F
Thank you
Comment 3 QA Administrators 2015-06-08 14:28:54 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!

This NEEDINFO Message was generated on: 2015-06-08

Warm Regards,
QA Team
Comment 4 Doug 2015-06-09 13:48:25 UTC
The source of the report was that the command listed did not perform exactly the same action on a Grid/Table field as it did on a normal ListBox.  That appeared to be adverse functionality, because the command visually appeared to be successful on the normal ListBox and visually did not succeed on the Grid/Table ListBox.

However, on further testing it is clear that a second command is necessary to make this work correctly in both situations, the `.commit` method.  Using the `.commit` method, this works as expected in all situations, and so I am marking the report as NOTABUG.  It is not totally intuitive that the `commit` method would be required to merge a change in the field data down to whatever the Form is made up of, whatever java component, but this clearly was a design decision by the developers and on further investigation, not a bug.