Download it now!
Bug 82373 - Base: query builder columns not fully repainted on screen when moved
Summary: Base: query builder columns not fully repainted on screen when moved
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-08 23:02 UTC by Doug
Modified: 2015-07-17 03:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screen shot showing artifacts from not repainting after moving columns (11.20 KB, image/png)
2014-08-08 23:02 UTC, Doug
Details
repaint problem (8.16 KB, image/png)
2015-01-02 07:33 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Doug 2014-08-08 23:02:33 UTC
Created attachment 104323 [details]
screen shot showing artifacts from not repainting after moving columns

1.  Open query in design view.
2.  Click on a column, drag to new location (to the left)
3.  After move, the gray tab area in the top of the grid is not completely repainted, there are artifacts left over from move, misplaced shading and lines.  See screen shot.  The screenshot shows left over shading and left over dividing line.
4.  If resize window, artifacts disappear.

Expected behavior:  the area clicked and dragged should be completely repainted on screen.

By the way, it would be great if when clicking and dragging the column from a location scrolled to the right, the screen would automatically scroll back to the left while dragging.
Comment 1 Doug 2014-08-17 19:17:48 UTC
In addition to the repainting bug, dragging columns to right side does not actually move columns.  Arrow animation appears as if this is intended functionality (and it would make sense) but only click and drag to left succeeds in moving columns on query builder grid.  Nothing happens when column dragged to right.  Problem encountered OpenSuse13.1/LO Base 4.1.6.2 and Windows7/LO Base 4.3.0.4.
Comment 2 Buovjaga 2014-11-12 10:58:11 UTC
I could not reproduce the repaint problem. Dragging and dropping to right is broken, though.

Win 7 64-bit Version: 4.4.0.0.alpha2+
Build ID: b021b5983c62e266b82d9f0c5c6d8d8900553827
TinderBox: Win-x86@42, Branch:master, Time: 2014-11-12_00:19:18

Ubuntu 14.10 64-bit Version: 4.4.0.0.alpha2+
Build ID: 1c526c9ddda5d52f7a4db5655a4ec60b8c62835c
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2014-11-11_23:20:41
Comment 3 raal 2015-01-02 07:32:24 UTC
(In reply to Doug from comment #1)
> In addition to the repainting bug, dragging columns to right side does not
> actually move columns.  Arrow animation appears as if this is intended
> functionality (and it would make sense) but only click and drag to left
> succeeds in moving columns on query builder grid.  Nothing happens when
> column dragged to right.  Problem encountered OpenSuse13.1/LO Base 4.1.6.2
> and Windows7/LO Base 4.3.0.4.

Please create new bug for this issue. I can confirm drag&drop problem in right direction wit LO 4.3.5.2, Win7.
Comment 4 raal 2015-01-02 07:33:55 UTC
Created attachment 111640 [details]
repaint problem

I can confirm repaint problem after move columns, see attachment. LO 4.3.5.2, win7.
Comment 5 Alex Thurgood 2015-01-03 17:40:33 UTC
Adding self to CC if not already on
Comment 6 Doug 2015-07-17 03:25:58 UTC
The functionality of the query design columns is changed by 5.0.0.3 Windows 7 and I no longer reproduce this problem.  On the other hand, the arrow animation that cued drag and drop also is gone most of the time.

I am not sure when the fix was effectuated, but appears fixed so WORKSFORME.