Bug 82435 - Preference Dialog too big
Summary: Preference Dialog too big
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-10 23:41 UTC by Daniel Espinosa
Modified: 2014-08-17 01:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Preference Dialog screeshot (118.35 KB, image/png)
2014-08-11 14:36 UTC, Daniel Espinosa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Espinosa 2014-08-10 23:41:10 UTC
Using AppMenu->Preferences open a dialog, but is too big in a 1440x900 resolution.

Bottom action buttons are outside screen at 50%. If I move the dialog window upper they can appear again.
Comment 1 Adolfo Jayme Barrientos 2014-08-11 01:35:37 UTC
A screenshot would be helpful, thanks.
Comment 2 Jean-Baptiste Faure 2014-08-11 04:43:59 UTC
Set status to NEEDINFO. Please set it back to UNCONFIRMED once you have provided requested informations. Thank you for your understanding.

Best regards. JBF
Comment 3 Daniel Espinosa 2014-08-11 14:36:44 UTC
Created attachment 104442 [details]
Preference Dialog screeshot

This screen shot shows my desktop with Preferences Dialog opened. You can see how bottom buttons shows partially, even usable, it is a GUI regression.
Comment 4 retired 2014-08-11 15:12:00 UTC
Linux, def not OS X so, platform Linux.
Comment 5 Adolfo Jayme Barrientos 2014-08-15 09:36:56 UTC
I don’t think it’s necessarily a “bug”. It is proportionally sized according to your UI font setting, which is pretty big by itself.

The dialogs were rewritten in an XML-based format to allow for proper redimensioning, that wasn’t possible before. Maybe that’s what you mean by “regression”?

Also, the window still seems to fit into the screen. If your window manager (GNOME Shell/Mutter) isn’t positioning the windows so that they fit by default, then that’s their bug.
Comment 6 Daniel Espinosa 2014-08-15 13:19:29 UTC
You're right about text size. I'm using big size setting from GNOME control panel, because my screen in physically small and makes me more comfortable to work with that size setting on.

I'll investigate about the Matter's window possitioning in order to file a bug if that is the case.

One thing I notice is that LibreOffice don't honor size setting, but just after it is restarted. May be this is a limitation on GUI tool kit used.
Comment 7 Robinson Tryon (qubit) 2014-08-17 01:49:41 UTC
(In reply to comment #6)
> You're right about text size. I'm using big size setting from GNOME control
> panel, because my screen in physically small and makes me more comfortable
> to work with that size setting on.
> 
> I'll investigate about the Matter's window possitioning in order to file a
> bug if that is the case.

I agree that this sounds like a GNOME/window manager issue: marking as RESOLVED NOTOURBUG
(Feel free to change the status back to UNCONFIRMED if it appears that the bug is in LibreOffice.)

> One thing I notice is that LibreOffice don't honor size setting, but just
> after it is restarted. May be this is a limitation on GUI tool kit used.

That's possible. It might also have to do with how LibreOffice accesses defaults from the window manager: Once LibreOffice has started, it may not actively poll or receive notifications to determine if it should resize fonts, etc.