Bug 82467 - PRINTING: Writer Crashes on copy phonenumer from adress-field or any where else and paste in phone number field Brother PC-Fax v.2.2
Summary: PRINTING: Writer Crashes on copy phonenumer from adress-field or any where el...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: possibleRegression
: 82559 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-11 13:47 UTC by birquito
Modified: 2016-04-18 10:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description birquito 2014-08-11 13:47:58 UTC
Now I could reproduct the crash mentioned an Bug 80806.
To reproduct:
1. add a textfield or open an template with one.
2. write a phone number into the field
3. select and copy the number (strg+c/ ctrl+c or via context menu) - which is not so easy because of bug 80806
4. choose the printer from the menu - Brother PC-Fax v.2.2
5. paste the number in the field (strg+v/ crtl+v or via context menu
nothing is pasted. writer, quickstart and brother PC-Fax v2.2 chrash - windows is collecting date and sends them (appeared once). 
I discovered, that the same behavoir appears with any text copied from anywhere in the document.

If I put in the number manually all works correct.
Comment 1 birquito 2014-08-11 14:18:59 UTC
It seems to be solved in 4.2.6.2 sorry for not trying first the newer version.
Comment 2 birquito 2014-08-13 12:15:29 UTC
Sorry for the confusion: Still existing the behaviour I wrote about yesterday and thougt that solved in 4.2.6.2. Here again the description:

Now I could reproduct the crash mentioned an Bug 80806.
To reproduct:
1. add a textfield or open an template with one.
2. write a phone number into the field
3. select and copy the number (strg+c/ ctrl+c or via context menu) - which is not so easy because of bug 80806
4. choose the printer from the menu - Brother PC-Fax v.2.2
5. paste the number in the field (strg+v/ crtl+v or via context menu
nothing is pasted. writer, quickstart and brother PC-Fax v2.2 chrash - windows is collecting date and sends them (appeared once). 
I discovered, that the same behavoir appears with any text copied from anywhere in the document.

If I put in the number manually all works correct.
 
The first attempt after rebooting the computer works to copy + paste the phone number. (Thath's why I posted the  withdraw of the bug report yesterday.)
First I thougt, that the error came from KeyScrambler, because I had the same behaviour with other Software. After updateing KeyScrambler only LO shows this bug.
Comment 3 birquito 2014-09-01 14:02:22 UTC
Still existing Problem with LO 4.3.1.2.
Comment 4 birquito 2014-09-01 14:10:31 UTC
I read my post again and found that now it's not possible to copy&paste text even once after restarting the computer. It doesn't matter whether copied from a field or from normal text nor if it's text or numbers.
Comment 5 birquito 2014-09-04 09:57:56 UTC
*** Bug 82559 has been marked as a duplicate of this bug. ***
Comment 6 birquito 2014-10-13 09:59:32 UTC
Seems to be solved in LO 4.3.2.2.
Comment 7 birquito 2014-12-29 12:50:18 UTC
Same behavior again with LO 4.3.5.2. 
It's a bit frustrating when working process gets interrupted this way.
Comment 8 Robinson Tryon (qubit) 2014-12-30 22:17:41 UTC
Does not meet the criteria for Status 'REOPENED' (was never marked as RESOLVED FIXED)
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/REOPENED#Criteria
Status -> UNCONFIRMED
Comment 9 Robinson Tryon (qubit) 2014-12-30 22:19:13 UTC
(In reply to birquito from comment #6)
> Seems to be solved in LO 4.3.2.2.

(In reply to birquito from comment #7)
> Same behavior again with LO 4.3.5.2. 
> It's a bit frustrating when working process gets interrupted this way.

So is it currently working in 4.3.2.2 but broken in 4.3.5.2? That should make it much easier to track down what went wrong.

Whiteboard -> possibleRegression
Status -> NEEDINFO
Comment 10 birquito 2015-04-02 12:11:33 UTC
Sorry for the Delay. 
I don't even tryed to copy paste the phonenumbers to the Brother-PC-Fax window. 
Lately I updated to LO 4.4.1.2 - and still crashing. 
I don't remember wich was the last working version. It's to long ago now. 
Sorry. I think it was not solved in version 4.3.2.2. The behavior was a bit odd:
all working good after restart but not further or after the crash (see 2014-08-13)
Now crashing instantly ... 
Time went on - rememberance was lost. ;)
Comment 11 m.a.riosv 2015-04-02 14:02:02 UTC
To be certain the reported issue is not related to corruption in the user profile, could you rename this LibreOffice user directory ( see https://wiki.documentfoundation.org/UserProfile#Default_location or http://ask.libreoffice.org/en/question/903/where-are-the-libreoffice-data-profile-files/ ) and re-test?
Comment 12 Buovjaga 2015-04-10 13:03:33 UTC
NEEDINFO per comment 11.

Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 13 birquito 2015-04-14 10:53:16 UTC
The test with a new user profile did NOT solve the problem. 
Both LO 4.4.1.2 and Brother-PC-Fax 2.2 still crash if I try to paste the copied phone number to the input field of the PC-fax-software. So I switched back to my old profile.
Comment 14 tommy27 2015-08-24 13:01:53 UTC
consider that for some reasons I do not know, Brother machines have multiple issues with LibreOffice... If you do a query in Bugzilla you'll find many bug reports about this specific brand
Comment 15 Robinson Tryon (qubit) 2015-12-09 18:27:11 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
Comment 16 Buovjaga 2016-03-02 20:54:36 UTC
Please test with 5.1.1, which will be released soon. You can try it out by installing with this: https://wiki.documentfoundation.org/SI-GUI

You could try getting a backtrace of the crash: https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 17 birquito 2016-03-22 09:14:44 UTC
Still the same with LO 5.1.1.3. (32bit) on Win 8.1 Pro 64bit. If I can find the the time I wil try out, whether one of my extensions/ add-ons is interacting with the Brother-Fax-Printer.
Comment 18 birquito 2016-04-18 10:55:23 UTC
Update to LO 5.1.2.2 (32bit) seems to solve the Problem. Two tests no crash.