Download it now!
Bug 82788 - FILEOPEN, FORMATTING: header/footer styles are corrupted; picture alignment is changed
Summary: FILEOPEN, FORMATTING: header/footer styles are corrupted; picture alignment i...
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-18 23:47 UTC by Neal Murphy
Modified: 2018-08-08 16:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test doc (1.30 MB, application/vnd.oasis.opendocument.text)
2014-08-19 20:58 UTC, Neal Murphy
Details
test pdf (173.01 KB, application/pdf)
2014-08-19 20:59 UTC, Neal Murphy
Details
bad doc (1.30 MB, application/vnd.oasis.opendocument.text)
2014-08-19 21:00 UTC, Neal Murphy
Details
bad PDF (173.02 KB, application/pdf)
2014-08-19 21:01 UTC, Neal Murphy
Details
shows random BOLD words in both footers (78.70 KB, application/vnd.oasis.opendocument.text)
2014-08-26 04:25 UTC, John E Wulff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Neal Murphy 2014-08-18 23:47:55 UTC
I editted a doc, made sure the formatting was correct, and created a proper-looking PDF. Saved and closed the doc. Exited loffice. Restarted and opened the doc. The header and footer paragraph margins/spacings/indents/tabstops are altered. I can select the paragraphs and change the style to something else and back using the Style and Formatting window to correct it. Left and right pages must be fixed separately. It seems to make the same alterations every time.

Also, picture alignment type changes. The position itself remains correct. The type of alignment changes from 'centered' to 'left from' with a measurement.

I am running v4.3.0.4 DLed from the LO site on 64-bit Debian Wheezy (16GiB RAM, several TB of disk).

I'll make the doc and PDF available if desired. I imagine it might be helpful if I save a version with the altered settings. If it isn't a save problem, it should illuminate what is being changed.

An associate says he's never seen these problems on his Windows version; I don't know which version he runs.

Other notes/comments
--------------------
Is there a possibility there is leftover cruft in the doc? I created it using an older version of LO or OO but had so many problems with RTF import that I created a fresh doc and copy/pasted the plain text from the RTF.

I updated to 4.3.0.4 due to problems with another doc; Draw integration and on-screen rendering in writer was problematic in the last version I ran. It's much better now, but there's still room for improvement.
Comment 1 Regina Henschel 2014-08-19 18:51:10 UTC
Yes, please attach a test document and the resulting pdf-file and if possible a screenshot with multiple pages (see status bar) after reopening the document.

You do not describe, in which file format you have saved. But it is essential, whether you use ODF or an alien format.
Comment 2 Neal Murphy 2014-08-19 20:58:04 UTC
Created attachment 104917 [details]
test doc

Test doc saved with the correct settings.
Comment 3 Neal Murphy 2014-08-19 20:59:09 UTC
Created attachment 104918 [details]
test pdf

PDF that shows the correct layout of the headers and footers.
Comment 4 Neal Murphy 2014-08-19 21:00:39 UTC
Created attachment 104919 [details]
bad doc

Doc saved just after opening; has munged headers and footers
Comment 5 Neal Murphy 2014-08-19 21:01:31 UTC
Created attachment 104920 [details]
bad PDF

PDF that shows munged headers and footers
Comment 6 Neal Murphy 2014-08-19 21:03:40 UTC
Oops. I saved the doc using native .odt format. Attachments added.
Comment 7 John E Wulff 2014-08-26 04:25:43 UTC
Created attachment 105261 [details]
shows random BOLD words in both footers

Every time I open the ODT file different words in the footers go bold
Comment 8 John E Wulff 2014-08-26 04:40:46 UTC
I regularly write a 20 page newsletter with LO Writer with pages which have headers and footers. The footer looks as follows:

10     Bowen Mountain Association Newsletter – September 2014

Every time I save and then re-open one of the the ODT files, one or more of the words in the footer have turned to BOLD - always different words. Other times the page number which is meant to be BOLD has gone non-BOLD. When I mark the whole of one of these words, the BOLD button does not show it is bold. I have to put just the cursor in the middle of one of these bold words which then brings up the BOLD button, which I can press, which unboldens just the one word. Other bold words in the line are not changed. Every time I open one of the files I have to check all the footers and unbolden all bold words which have reappeared before I finally export the file to a PDF for printing. Never seem to have this problem with the headers. I am running:

LibreOffice Version: 4.1.6.2 Build ID: 410m0(Build:2)distributed with 
OS: Linux 3.11.10-17-desktop openSUSE 13.1 (Bottle) (x86_64)
Processor: Intel(R) Pentium(R) CPU B940 @ 2.00GHz - dual CPU
Memory: 1 GiByte
Drive: TOSHIBA MK3276GSX - 298.1 GiB

Related attachment:  shows random BOLD words in both footers

Last time I opened the attached file the word "Bowen" and "Association" were BOLD in the first (left odd) footer and the word "Association" and "Newsletter" were BOLD in the second (right even) footer. But this varies.
Comment 9 Neal Murphy 2014-08-26 06:00:54 UTC
I opened John's doc three times and it displayed the footers differently each time: random words bold, random normal.
Comment 10 John E Wulff 2014-08-26 09:56:18 UTC
Thanks Neal for confirming that this bolding and unbolding in the footers really happens. Were you using LO 4.3.0.4 release? That is a newer Version than my 4.1.6.2. I am surprised nobody else has picked this up - it is so annoying.

Should I make this a separate Bug Report. I would like to have it in the main Index. How do I do that. I am a newbie on Bugzilla and I would appreciate help.
Comment 11 Neal Murphy 2014-08-26 14:25:20 UTC
(In reply to comment #10)
> Thanks Neal for confirming that this bolding and unbolding in the footers
> really happens. Were you using LO 4.3.0.4 release? That is a newer Version
> than my 4.1.6.2. I am surprised nobody else has picked this up - it is so
> annoying.
> 
> Should I make this a separate Bug Report. I would like to have it in the
> main Index. How do I do that. I am a newbie on Bugzilla and I would
> appreciate help.

Yes, using v4.3.0.4.

Looked at your effect again. It doesn't just change normal/bold. Click in the middle of a word and type some characters. They might or might not be bold, but LO thinks they're of different size (that is, 10 != 10).

I'd leave it here for now. It shows that more than one user is affected, and that it's existed for a while. Leave it to an LO developer to split the report.
Comment 12 tommy27 2016-04-16 07:29:14 UTC Comment hidden (obsolete)
Comment 13 Neal Murphy 2016-04-17 23:24:05 UTC
The problem is minimally better with version 5.1.1.3 (.deb on Debian Jessie, from jessie-backports). When I have time to try again, I'll install the latest .deb from libreoffice. I did try v3.3, but it gave me a SIGSEV.

Pictures seem to remain centered now. Footers seem to behave now.

Alas, the header problem is worse. It ... wait. Oh, I see. When saving the doc, the program sets the 'before text' and 'first line' to 1.2" and -1.2", respectively, in each individual paragraph in the header even though I applied a central style to each; the central styles do not have the 1.2" offsets. I just fixed them, saved, exited and restarted. And the 1.2" offsets are back.

... Oh, great. Now when I page up quickly, loffice thinks there are 10 or more headers on each page.

There's *definitely* something screwy in page header operations. Is it possible I just have a badly munged doc that needs to be cleaned out by hand?
Comment 14 QA Administrators 2017-05-22 13:27:57 UTC Comment hidden (obsolete)
Comment 15 Neal Murphy 2017-05-22 21:21:16 UTC
The header and footer problems re: mishandling tabs stops, etc., when opening/reading the file remain in version 5.2.6.2 (Debian Jessie).
Comment 16 Xisco Faulí 2017-07-13 10:01:49 UTC Comment hidden (obsolete)
Comment 17 QA Administrators 2018-07-14 02:46:47 UTC Comment hidden (obsolete)
Comment 18 Neal Murphy 2018-07-14 20:33:27 UTC
Comment 13 is still valid with respect to the 1.2" problems: the header and footer paragraph styles are still altered when the doc is opened after being saved with the correct settings/appearance. And it still draws lots of the blue-ish footer 'tabs' when paging up and down.

So this issue still exists and is unchanged.

From the help window:
Version: 6.0.5.2
Build ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 19 Neal Murphy 2018-07-14 20:37:57 UTC
(In reply to Neal Murphy from comment #18)
> And it still draws lots of the
> blue-ish footer 'tabs' when paging up and down.

Sorry. It happens to footers *and* headers.
Comment 20 Timur 2018-08-07 13:34:28 UTC
This is not correct bug report. It wasn't triaged properly. 
Bugzilla is "issue based", so a single issue must be pointed at, after a search for not being a duplicate. Bugzilla is not "document based", like "this document doesn't display nice". 
Each issue (section break, paragraph break, text box size, picture position...) should be analyzed and first checked for already reported bugs.
If bugs don't exist, they should be reported separately, even if they happen with the same file. 
Example file should be reduced to minimal test case for a specific problem (no excess pages or text) with clear file history or steps to reproduce from scratch.

You need to write exact verifiable facts for s single issue. Otherwise, it's more unlikely bug will be dealt with. 

Reproducible steps:
1. open attachment... (minimal test case)
2. set...
3. save and reopen
...
Actual Results:
Expected Results:

In this case, if it's header, you didn't explain how you fix it. "offsets" were directly formatted, not via style. Please note that attachment 104917 [details] and attachment 104919 [details] look same.
If you directly correct all paragraph indents to 0 in attachment 104917 [details], header looks OK after save and reopen. Tested with LO 6.0.6.

"blue-ish footer 'tabs' when paging up and down" Another issue, I guess Bug 46988.

I'll close. Feel free to write reproducible steps if you think there's bug to be resolved here.
Comment 21 Neal Murphy 2018-08-07 18:26:58 UTC
Bug 46988 has to do with jumpy scrolling. There is nothing in that report about LO creating tens of the blue-ish tabs that identify headers and footers, so many tabs that it can take LO a second or three to render all of the tabs it generates for a *single* header or footer on a 4.4GHz CPU with 16GiB of 2.1GHz RAM).

"If you directly correct all paragraph indents to 0..." *That* is the exact problem; you deftly sidled right past it. That you had to 'directly correct the indents' proves that the problem exists. In version 6.0.5 and previous versions going back at *least* four years, LO/OOo silently *changes* those indents, either when they write the file or when they read the file. I should not have to fix the indents every time I open the file. File 'test doc' was saved immediately afer I set the correct indents. File 'bad doc' came directly from 'test.doc'; I opened 'test.doc' and immediately saved it as 'bad.doc', making no changes.

  - Did you look at the PDFs that clearly show the differences?
  - Did you compare the XML of the two ODT files to see how they differ?
  - Did you test on any older version to verify the problem?
  - Did you test on Linux?
  - Did you report the change that fixed the problem (if it was, indeed, fixed)?
  - Did you report any other bugs that correctly report the issues I see with headers and footers?
  - Did you attempt to help us (the complainers) identify and clarify the issues, potentially
    creating other reports?

The only request I've seen in this report in the four years since I opened it was Regina's request for example docs and PDFs and for me to identify the file type I used. I did so. And outside of Regina's and John's comments, the integrated circuit asking me to verify the continued existence of the problem, and my updates, I've heard only crickets. Until today when you 'resolved' the problem by declaring the way I reported the problem to be 'invalid'.

Bug 46988 has to do with jumpy scrolling. There is nothing in the report about LO creating tens of the blue-ish tabs that identify headers and footers, so many tabs that it can take LO a second or three to render all of them.

On my project, I work with users and developers to triage and identify problems. I give them methods to reduce and reproduce the problem. I examine the source code. If the problem was already fixed, I tell them what the error was and which version has the fix. I tell them if the problem was inherited from the version before I took over or if it was my own mistake (be it due to oversight, stupidity, or ignorance). And, yes, I do install and test old versions of my project when necessary because developers and users earn that much respect just for taking the time to report a problem.

I submit that your response action are invalid. I submit that the problem should remain open until changes can be identified that actually fix the problem.

Lest I seem ingrateful, thank you for reproducing the problem. At least I know it's not something weird on *my* computer.
Comment 22 Timur 2018-08-08 16:52:24 UTC
If bug is not reproducible (steps) and clear (actual and expected), it's unlikely to be resolved, ever. 
Moreover, you confirmed the bug yourself, without repro steps, which is not permissible. 

Header indents in "test doc" ODT attachment 104917 [details] are already wrong on fileopen.
Moreover, header paragraphs are level 10 Outline. 
Question is where this outline-level="10" comes from. 
As written, if paragraph indents are directly corrected to 0 or outline removed and than document saved, documents opens fine. Test with reported 4.3.0.3 and master 6.2+. Issue never confirmed. 

Bug report is invalid, mostly due to not proper and timely triage. I hope it's better nowadays. But we have to do some cleanup. 
Still if you can provide requested steps and results with minimal test case, you're welcome to submit another bug report. 


Note: I see another issue with attachment 104917 [details]. It used to be 4 pages up to LO 5.2 and from 5.3 up to now it's 5. Reason is "Note" section on page 4. 
Here we have 2 differences that probably have different causes:
1. tab length before "Please note"
2. increased text spacing 
Issue 1. I find not important enough to pursue. 
For issue 2. I cannot grasp the reason. It would be interesting to determine.