Bug 82789 - EDITING: Bug on copy columns
Summary: EDITING: Bug on copy columns
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected) release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
Whiteboard: BSA
Depends on:
Reported: 2014-08-18 23:56 UTC by brainstuff
Modified: 2015-05-06 14:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:

the calc file where I expect the bug .. (13.82 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-08-18 23:56 UTC, brainstuff

Note You need to log in before you can comment on or make changes to this bug.
Description brainstuff 2014-08-18 23:56:20 UTC
Created attachment 104847 [details]
the calc file where I expect the bug ..

Problem description: 

Steps to reproduce:
1.you find a calc file in the attachment
2.when I mark the columns A-F and try to copy these columns to G1 (and all other cells) Libre office crashs.  

Please look to the cell format of the colums d and e ... I think this comes from this format ... the format is 0#  ... i want to have all numbers as 01 or 20 not as 1 or 20     

Current behavior:
It is not possible to copy the 4 columns 

Expected behavior:

Operating System: Windows 7
Version: release
Comment 1 raal 2014-08-20 20:47:24 UTC
I can not reproduce with version:
ID build: 62ad5818884a2fc2e5780dd45466868d41009ec0
Win 7
Copy,paste columns A-F without crash.
Comment 2 brainstuff 2014-08-20 22:07:09 UTC
@ raal 

do you have tried to copy two times? The first copy works on my computer, but when I try a second copy, libre office crashes     I have still the problem ... I have tried what is happens when I use open office .. and in Open office the copy works fine.

Perhaps this is a low memory problem? ... my computer is a i5 Notebook with only 4 Gb Ram and Win 7 prof.

Comment 3 raal 2014-09-03 05:48:50 UTC
Tested again with LO, win 7 , 4GB RAM
select A:F, CTRL+C, select G1, CTRL+v
select M1, CTRL+v
No crash

select A:F, CTRL+C, select G1, CTRL+v
select A:F, CTRL+C,select M1, CTRL+v
No crash

Format of cell D2 shows me 0  (number)
Please provide exact steps to reproduce. Thank you.
Comment 4 brainstuff 2014-09-03 18:08:20 UTC

I mark the columns A-F , then ctrl-C,  I go to G1, then CTRL-V and libre office crashes.

When I do the same in open office ... no crash. 

Pherhaps this is a memory management problem? (The used computer is a i5 Notebook with only 4 Gb of RAM...and w7) 

Comment 5 Jacques Guilleron 2014-09-03 19:47:02 UTC
Hi brainstuff,

I don't reproduce with LO and Windows 7 Home Premium.
Did you try a new profile?
Sometimes, this solve such an issue.


Comment 6 ign_christian 2014-09-06 10:30:41 UTC
NEEDINFO per comment 5

Please change status to RESOLVED WORKSFORME if it resolved, otherwise UNCONFIRMED
Comment 7 Jacques Guilleron 2014-09-06 15:46:49 UTC
Sorry. I changed too quickly status.

@brainstuff: Did you try a new profile? Did it give a better copy?

Comment 8 brainstuff 2014-09-13 17:32:50 UTC
@ Jacques Guilleron  

what do you mean wit new profile? I do not know that Libre offeice calc has a profile???


Comment 9 raal 2014-09-13 17:36:50 UTC
(In reply to comment #8)
> @ Jacques Guilleron  
> what do you mean wit new profile? I do not know that Libre offeice calc has
> a profile???

look here
Comment 10 QA Administrators 2015-04-01 14:47:04 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team
Comment 11 QA Administrators 2015-05-06 14:21:23 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

-- The LibreOffice QA Team 

This INVALID Message was generated on: 2015-05-06

Warm Regards,
QA Team