Download it now!
Bug 82790 - FORMATTING: Date formating does not work for newly entered dates
Summary: FORMATTING: Date formating does not work for newly entered dates
Status: CLOSED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: Other All
: high critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-08-18 23:58 UTC by bugquestcontri
Modified: 2016-05-26 11:01 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugquestcontri 2014-08-18 23:58:15 UTC
My test shows that we have a bug.    
Machine XP Pro/SP3  
LibO Version: 4.2.6.2  
Build ID: 185f2ce4dcc34af9bd97dec29e6d42c39557298f  
Opened Calc file
Formated cell DDMMYYYY and entered a date (stroke sequence:2014/09/03) and the displayed date was in the correct format.
Saved file. 

Started LibO Portable, Version: 4.3.0.4  
Build ID: 62ad5818884a2fc2e5780dd45466868d41009ec0  
Open saved file  
Date entered in LibO 4.2.6.2 displays correctly. Newly added dates  (stroke sequence:2014/09/03)  do not show the correct format. Re-entering does of the same format (DDMMMYYYY) does not correct the format. Selection of other formats does not change the way the date is displayed.   

Operating System: Windows XP
Version: 4.3.0.4 release
Last worked in: 4.2.6.2 release
Comment 1 Owen Genat (retired) 2014-08-19 01:01:46 UTC
(In reply to comment #0)
> Formated cell DDMMYYYY and entered a date (stroke sequence:2014/09/03) and
> the displayed date was in the correct format.

I am unable to reproduce this under GNU/Linux using v4.2.6.2. Entered date displays as 2014/09/03. The entered date appears to override the pre-set cell format, which would appear to be a separate bug.

> Date entered in LibO 4.2.6.2 displays correctly. 

Displays the same as originally entered, yes, but not according to cell format.

> Newly added dates (stroke sequence:2014/09/03) do not show the correct format.

Unable to confirm under v4.4.0.0.alpha0+ Build ID: aa0e3701aad1a8a955773e869d9a6b59eac51e72 TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-08-10_07:00:01. Original date displays the same and behaviour when formatting a cell as DDMMYYYY (no slashes) and then entering 2014/09/03 is the same i.e., date is displayed as 2014/09/03 rather than 03092014.
Comment 2 bugquestcontri 2014-08-19 02:22:55 UTC
When I use my 4.2.6.2 version than there is NO format problem. It only pops up when I change to 4.3.0.6 (portable).
Comment 3 jaimes 2014-10-26 18:49:56 UTC
Reproduced bug on LibreOffice 4.4.0.0.alpha1 on Mac OSX 10.9.5

(In reply to bugquestcontri from comment #0)
REPRO STEPS: 
> Opened Calc file
> Formated cell DDMMYYYY and entered a date (stroke sequence:2014/09/03) and
> the displayed date was in the correct format.

Confirmed in 4.3.2.2 (not portable)

> Saved file. 
 
> Open saved file  
> Date entered in LibO 4.2.6.2 displays correctly. Newly added dates  (stroke
> sequence:2014/09/03)  do not show the correct format. Re-entering does of
> the same format (DDMMMYYYY) does not correct the format. Selection of other
> formats does not change the way the date is displayed.   

Opened in LibreOffice 4.4.0.0.alpha1 on Mac OSX 10.9.5, date format does not change to format of cell (date remains in 2014/09/03 format as typed)
Comment 4 bugquestcontri 2014-11-04 02:19:50 UTC
I made a test in newer versions:

4.2.7.2 normal => NO problem

Version: 4.3.2.2 (portable)
Build ID: edfb5295ba211bd31ad47d0bad0118690f76407d
The same problem as described in my first post.
Comment 5 Robinson Tryon (qubit) 2015-12-09 16:59:46 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
Comment 6 raal 2016-01-10 08:30:54 UTC
Still reproducible in Version: 5.2.0.0.alpha0+
Build ID: c1258abe50f1508ea0f628ff963bc1914ab86b67
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-01-02_01:43:32
Comment 7 Eike Rathke 2016-04-15 14:35:02 UTC
Can't reproduce. Which locale is this in anyway?
Comment 8 Eike Rathke 2016-05-06 11:00:16 UTC
Deducing from the submitter's email addres it would be a de-DE locale, but that doesn't make sense with a date input of 2014/09/03 and a format code of DDMMYYYY (de-DE would still use TTMMJJJJ).

I tried with en-ZA locale as that has a date input format of YYYY/MM/DD but no problem.

Without further information about the exact circumstances I'm closing this.
Comment 9 tkx701l 2016-05-26 11:01:01 UTC
The insert 'date(fixed)' does not work.  It inserts a date in the selected format quite correctly, but updates that date every time the record is viewed or printed.  This makes the release worse than useless for my purposes.
My version shows Version 5.0.6.3, which is not available in your drop-down.