Bug Hunting Session
Bug 82855 - MAILMERGE: Mail Merge Wizard not working anymore (freezes) when a data source exists
Summary: MAILMERGE: Mail Merge Wizard not working anymore (freezes) when a data source...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-20 10:02 UTC by Marcus
Modified: 2016-05-19 07:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Ods and Odt file to reproduce the problem (39.55 KB, application/x-zip-compressed)
2014-11-13 08:54 UTC, Marcus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus 2014-08-20 10:02:49 UTC
This bug occurs in LibreOffice 4.3.0.4. I have tested a fresh and an upgraded installation (upgraded from 3.x (I think .6) and from 4.0), each on two PCs (so I had four test environments).

The problem is a freezing Mail Merge Wizard.

This is how I could reproduce the problem:

- Running the Mail Merge Wizard and adding a new data source (in my case an "ods" file with 15 columns and 72 rows (including the headline)).

- Close everything after finishing

- Repen document and run Mail Merge Wizard again to print the documents again => Window freezes (CPU and RAM show no activity). So no chance to ever running the Mail Merge Wizard again.

This happens every time, EXCEPT(!) when I first delete all data sources, which are registered within LibreOffice (in the options menu under (translated from the German texts) Tools - Options - LibreOffice Base - Data bases.

So I always have to delete the sources, then import them again, to print my letters again.
Operating System: Windows 7
Version: 4.3.0.4 release
Comment 1 Marcus 2014-08-20 10:05:30 UTC
Windows 7 x64
Comment 2 Buovjaga 2014-11-06 10:57:17 UTC
Could not reproduce.

Win 7 64-bit Version: 4.4.0.0.alpha1+
Build ID: 8b21b5cbe78945b27525b4ce78ae3d981f90590f
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-06_03:55:51
Comment 3 Marcus 2014-11-06 13:05:47 UTC
Then I have to wait for the final release of 4.4 and test it again.
Comment 4 Buovjaga 2014-11-07 06:03:22 UTC
(In reply to Marcus from comment #3)
> Then I have to wait for the final release of 4.4 and test it again.

You can try right now by installing a dev version. It will install separately of your stable version and you can uninstall it when you are done.
Here is the latest current build:
http://dev-builds.libreoffice.org/daily/master/Win-x86@42/2014-11-06_22.54.57/
Here is the parent directory:
http://dev-builds.libreoffice.org/daily/master/

The @numbers at the end of the Win directories refer to the build machines.
Comment 5 Marcus 2014-11-12 07:55:37 UTC
I tested it some minutes ago with the linked dev version. That version has exactly the same behaviour. The mail merge wizard freezes.

Did you delete ALL data sources before trying to reproduce the problem?
Comment 6 Buovjaga 2014-11-12 08:13:23 UTC
(In reply to Marcus from comment #5)
> I tested it some minutes ago with the linked dev version. That version has
> exactly the same behaviour. The mail merge wizard freezes.
> 
> Did you delete ALL data sources before trying to reproduce the problem?

No, I specifically did not delete my existing data sources, like your instructions said. Could it be that the problem is with your .ods file? Does it happen with other sources? Maybe you could attach the problematic file here for testing. You can use this to strip out content: https://wiki.documentfoundation.org/QA/BugReport/Attachments#Confidential_Attachments
Comment 7 Marcus 2014-11-13 08:54:50 UTC
Created attachment 109392 [details]
Ods and Odt file to reproduce the problem

Letter.odt is the letter with the address fields and Addresses.ods contains the records for the mail merge wizard.
Comment 8 Buovjaga 2014-11-13 10:03:11 UTC
(In reply to Marcus from comment #7)
> Created attachment 109392 [details]
> Ods and Odt file to reproduce the problem
> 
> Letter.odt is the letter with the address fields and Addresses.ods contains
> the records for the mail merge wizard.

Sorry, I can't reproduce even with these.

Win 7 64-bit Version: 4.4.0.0.alpha2+
Build ID: b021b5983c62e266b82d9f0c5c6d8d8900553827
TinderBox: Win-x86@42, Branch:master, Time: 2014-11-12_00:19:18

Ubuntu 14.10 64-bit Version: 4.4.0.0.alpha2+
Build ID: 5bff4b016c4b44f4123e0e6a4fd4c0c4dc0cfa2d
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2014-11-13_00:14:29
Comment 9 Marcus 2014-11-14 07:33:20 UTC
Maybe I have to live with this bug then, as it seems to be not reproducible. As I said, I could reproduce it in several test environments every time.

If there are any additional tests I can run or is any additional information I can give, please tell me.
Comment 10 Jacques Guilleron 2014-11-14 16:00:08 UTC
Hi Marcus, Beluga,

I could not reproduce with 
LO 4.3.0.0.beta1 Build ID: b7cfa1eab1cb1e94f71d6df6612b73f231d0bf92
LO 4.3.2.1 Build ID: f9b3ad49d92181b0a1fe7e76f785a2c2cd0847d3
LO 4.3.3.1 Build ID: 7d55112667c8fcddb67bc3803796b46c93aa56b0
& Windows 7 Home Premium.

I also could not find another related report. Perhaps is it a profile issue.
Can you Marcus try to rename your profile?
https://wiki.documentfoundation.org/Documentation/UserProfile#Resetting_the_User-Profile

Thank you,

Jacques
Comment 11 Marcus 2014-11-17 07:54:59 UTC
I renamed my profile folder and restartet LO. A new profile folder has been created.

But I still have the freezing mail merge wizard.
Comment 12 Claudio Negri 2015-03-05 15:10:05 UTC
I have exactly the same problem.
LibreOffice version: 4.4.1.2
Operating system: Windows XP Professional SP3 Italian
Comment 13 ildflue 2015-03-10 12:50:02 UTC
The same issue here.

* Upgraded to 4.4, worked sometimes, not in other times.
* Upgraded to 4.4.1, not worked anymore
* Remove user profile data, reinstall and so on, no lucky
* Back to 4.3.6, works again

Win 7 Pro, EN, 64 bit.  

Address book is a Calc file.
Comment 14 ildflue 2015-03-11 11:07:47 UTC
It is very interesting. 

This morning Win 7 indicated there were more than 30 updates. Mail Merge of my LO 4.3.6.2 did not work any more after the Windows updates installed.

Removed LO 4.3.6.2 and removed the profile folders.

Install LO 4.4.1, Mail Merge worked!
Comment 15 Buovjaga 2015-03-11 11:16:20 UTC
ildflue: thanks for testing.

Marcus: what is your experience with 4.4.1?

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 16 ildflue 2015-03-11 11:26:31 UTC
I was too eager of reporting it worked. It does NOT: When I tried to save the merged document, it crashed. 

Tried many times, always crash while saving the merged document.
Comment 17 Buovjaga 2015-03-11 16:30:00 UTC
(In reply to ildflue from comment #16)
> I was too eager of reporting it worked. It does NOT: When I tried to save
> the merged document, it crashed. 
> 
> Tried many times, always crash while saving the merged document.

You could try getting a backtrace and attaching it here.
Instructions for Win: https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg
Comment 18 Marcus 2015-03-12 14:25:22 UTC
> Marcus: what is your experience with 4.4.1?

I tested it with 4.4.1.2 and the problem still exists. I used my test files I recently attached to this bug report.

By the way: I have a fresh Windows installation because of a new PC.
Comment 19 ildflue 2015-03-13 11:57:03 UTC
I know the reason why it does not work, at least for my case.

Spent a couple hours, tried piece by piece. 

It does not work when there is bullet items or numbering items using the format of "bullet" or "numbering".

No matter if there is merged field or not in the bullet / numbering items.

It works without these formatted items. 

It works with table, including merged fields in the table. I have a very complicate table with lots of merged fields. 

Sounds not reasonable? I agree!
Comment 20 ildflue 2015-03-13 11:59:39 UTC
If it is necessary, I can make a video to show you guys how it happens.
Comment 21 Jan-Marek Glogowski 2015-03-20 13:23:32 UTC
(In reply to ildflue from comment #16)
> I was too eager of reporting it worked. It does NOT: When I tried to save
> the merged document, it crashed. 
> 
> Tried many times, always crash while saving the merged document.

Please don't hijack a bug report. The original report was a freezing mail merge wizard, while you talk about mail merge wizard crashes.

Also it's not clear, if you tested with the provided documents from the original reporter Marcus or have your own documents.

(In reply to Marcus from comment #5)
> Did you delete ALL data sources before trying to reproduce the problem?

So I'm testing this on Linux, my dbgutil master build from 5623a63b9b6bd084060a88c701babe82eb0c4fb5 - as of 2015-03-20

 * Fresh profile: soffice -env:UserInstallation=file:///tmp/test ~/Documents/tdf#82855/Letter.odt
 * data sources (F4)
   * Registered databases...
   * Remove both existing
 * Close LO

 * soffice -env:UserInstallation=file:///tmp/test ~/Documents/tdf#82855/Letter.odt
 * mail merge wizard...
   * next => next => Select address list .. => add your ods => ok
   * cancel wizard
 * Close LO

 * soffice -env:UserInstallation=file:///tmp/test ~/Documents/tdf#82855/Letter.odt
 * mail merge wizard...
   * next => next => next => next => next => next
   * Save a single file
   * Finish

No freezing for me.

If you did something different, please add this information.

(In reply to Claudio Negri from comment #12)
> I have exactly the same problem.
> LibreOffice version: 4.4.1.2
> Operating system: Windows XP Professional SP3 Italian

Does this problem occur with the documents provided by Marcus?
Can you please test current development build?

=================

Probably this is really a Windows specific problem, eventually even running the 32bit binary on a 64bit Windows. As I don't have Windows, I can't debug this.
Comment 22 Jan-Marek Glogowski 2015-03-20 13:24:13 UTC
Development builds: http://dev-builds.libreoffice.org/daily/master/
Comment 23 Marcus 2015-03-20 13:42:50 UTC
> If you did something different, please add this information.
That's exactly what I did (but under Windows).
Comment 24 Claudio Negri 2015-03-23 08:45:44 UTC
(In reply to Jan-Marek Glogowski from comment #21)
> Does this problem occur with the documents provided by Marcus?

Yes

> Can you please test current development build?

I re-tested with this installer:

master~2015-03-23_01.50.30_LibreOfficeDev_4.5.0.0.alpha0_Win_x86_en-US_de_ar_ja_ru_qtz.msi

Program version:

Version: 4.5.0.0.alpha0+
Build ID: ea59d42d2098e8be8b3ab9667922e8427ee4b714
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-03-23_01:50:30
Locale: it_IT

(installed after deleting the configuration folder and "Addresses0.odb")
and the problem persists.
Comment 25 ildflue 2015-03-25 07:56:20 UTC
(In reply to Jan-Marek Glogowski from comment #21)
> Please don't hijack a bug report. The original report was a freezing mail
> merge wizard, while you talk about mail merge wizard crashes

The fact is, sometimes it freezes at the start step, sometimes it crashes at later stage. Should I start a new thread for the latter?  Or it would be better to report / discuss it here?

> 
> Also it's not clear, if you tested with the provided documents from the
> original reporter Marcus or have your own documents.
> 

Yes, sure. I tested with the simple document from Marcus. 

> > Did you delete ALL data sources before trying to reproduce the problem?

You should read the posts carefully before you reply.

> 
> No freezing for me.

Your tests were almost meaningless. The OS talked is Win. You tested with Linux.  

We are only trying to help. I have MS Office 2013 Pro for my daily work. I just want to show my support to keep this and test it. I have supported it from OpenOffice 1.0.
Comment 26 ildflue 2015-03-25 08:03:03 UTC
(In reply to Jan-Marek Glogowski from comment #22)
> Development builds: http://dev-builds.libreoffice.org/daily/master/

I have tested it with 
***********
Version: 4.4.2.1
Build ID: 93fc8832889bf050a10ec6d0171dae213adc9b55
Locale: en_GB
***********

* Fresh installation
* Fresh profile
* Completely new Writer document
* Completely new Calc document as DB

Not work!

If everything is fresh, it does not work, you do not need to test it with any other documents.
Comment 27 ildflue 2015-05-05 10:34:02 UTC
Seems no one takes care of this issue. But the issue does not go by itself.

New findings: seems the behavior is related to Fireforx!

* The merge can be done without problem if Firefox is not open with certain web pages.

* The merge frozen if Firefor is open with certain webpages.

This may indicate that some conflicts of some components between these two.
Comment 28 Buovjaga 2015-05-05 11:02:30 UTC
(In reply to ildflue from comment #27)
> Seems no one takes care of this issue. But the issue does not go by itself.
> 
> New findings: seems the behavior is related to Fireforx!
> 
> * The merge can be done without problem if Firefox is not open with certain
> web pages.
> 
> * The merge frozen if Firefor is open with certain webpages.
> 
> This may indicate that some conflicts of some components between these two.

Please create a new bug report, get a backtrace of the freeze and attach it to the report.
Windows backtrace instructions: https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg
Comment 29 Gordo 2015-05-28 17:46:50 UTC
I can reproduce.

1. Open Letter.odt.
2. Tools → Mail Merge Wizard.
3. In Steps, click on “3. Insert address block”.
4. Click on button “Select Address List”.
5. Click on Add button.
6. Select Addresses.ods and Open.
7. OK Select Address List.
8. In Steps, click on “8. Save, print or send”.
9. Click on “Save starting document” button.
10. Click Finish button.
11. Close document (I didn't save).
12. Exit application.
13. Open Letter.odt.
14. Tools → Mail Merge Wizard.
Result:
Hang.

Windows Vista 64
Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16

Version: 5.1.0.0.alpha1+
Build ID: bf9c96238e33f63922af35c0c77ceb83ff447d3e
TinderBox: Win-x86@39, Branch:master, Time: 2015-05-27_07:04:47
Comment 30 Buovjaga 2015-05-28 18:44:01 UTC
Let's set to NEW then.
Comment 31 Buovjaga 2015-05-28 18:45:11 UTC
Severity needs to be higher.
Comment 32 Claudio Negri 2015-07-28 08:18:54 UTC
I can reproduce with LibreOffice version: 4.4.4.3
Operating system: Windows XP Professional SP3 Italian
Comment 33 Claudio Negri 2016-05-18 16:10:50 UTC
In my PC, with the same operating system and LibreOffice version 5.1.3.2, the bug is fixed.
Comment 34 Buovjaga 2016-05-18 16:28:11 UTC
Thanks. Let's set to WFM. If someone else still repros with 5.1.3, we can change back to NEW.
Comment 35 Marcus 2016-05-19 07:14:21 UTC
It also works for me now, version 5.0.5.2.