Bug 82961 - EDITING: Crash when trying to drag and drop a table
Summary: EDITING: Crash when trying to drag and drop a table
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-22 17:13 UTC by cedric
Modified: 2015-06-08 15:19 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample ODS File, that crashes when you perform the described action (44.70 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-08-22 17:13 UTC, cedric
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cedric 2014-08-22 17:13:01 UTC
Created attachment 105116 [details]
Sample ODS File, that crashes when you perform the described action

LibreOffice crashes when you select I1:J7 and drag'n'drop it exactly one coulmn to the right (column J and K) in the file I've attached.

I weren't able to reproduce this effect in any other similar situation than in this specific table. The crash is reproducable though if you paste and copy it to an empty new table and try to do the above described action again.

Also the crash doesn't appear when you drag I1:J7 to the left or down or TWO columns to the right. It only crashes when you drag it ONE column to the right.

The formulas in the cells are in German. I'm not sure if this makes any difference.

This is the output of gdb:

$ gdb ./soffice.bin 
GNU gdb (Ubuntu 7.7-0ubuntu3.1) 7.7
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from ./soffice.bin...Reading symbols from /usr/lib/debug//usr/lib/libreoffice/program/soffice.bin...done.
done.
(gdb) run
Starting program: /usr/lib/libreoffice/program/soffice.bin 
warning: File "/usr/lib/libreoffice/program/libmergedlo.so-gdb.py" auto-loading has been declined by your `auto-load safe-path' set to "$debugdir:$datadir/auto-load".
To enable execution of this file add
	add-auto-load-safe-path /usr/lib/libreoffice/program/libmergedlo.so-gdb.py
line to your configuration file "/home/<censored>/.gdbinit".
To completely disable this security protection add
	set auto-load safe-path /
line to your configuration file "/home/<censored>/.gdbinit".
For more information about this security protection see the
"Auto-loading safe path" section in the GDB manual.  E.g., run from the shell:
	info "(gdb)Auto-loading safe path"
warning: File "/usr/lib/ure/lib/libuno_sal.so.3-gdb.py" auto-loading has been declined by your `auto-load safe-path' set to "$debugdir:$datadir/auto-load".
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
warning: File "/usr/lib/ure/lib/libuno_cppu.so.3-gdb.py" auto-loading has been declined by your `auto-load safe-path' set to "$debugdir:$datadir/auto-load".
warning: File "/usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.20-gdb.py" auto-loading has been declined by your `auto-load safe-path' set to "$debugdir:$datadir/auto-load".
[New Thread 0x7fffe04f0700 (LWP 18214)]
[New Thread 0x7fffded7d700 (LWP 18215)]
[New Thread 0x7fffde57c700 (LWP 18216)]
[Thread 0x7fffded7d700 (LWP 18215) exited]
[New Thread 0x7fffded7d700 (LWP 18217)]
[New Thread 0x7fffd6cd0700 (LWP 18218)]
[New Thread 0x7fffd5b7a700 (LWP 18219)]
[New Thread 0x7fffd5379700 (LWP 18220)]
[New Thread 0x7fffd4b78700 (LWP 18221)]
[New Thread 0x7fffc3fff700 (LWP 18223)]
[Thread 0x7fffd5379700 (LWP 18220) exited]
[New Thread 0x7fffd5379700 (LWP 18224)]
[New Thread 0x7fffc31d3700 (LWP 18227)]
[Thread 0x7fffc31d3700 (LWP 18227) exited]
[Thread 0x7fffd5379700 (LWP 18224) exited]
[New Thread 0x7fffd5379700 (LWP 18229)]
[Thread 0x7fffd5379700 (LWP 18229) exited]
[Thread 0x7fffd4b78700 (LWP 18221) exited]
[New Thread 0x7fffd4b78700 (LWP 18233)]
[Thread 0x7fffd4b78700 (LWP 18233) exited]
[New Thread 0x7fffd4b78700 (LWP 18234)]
[Thread 0x7fffd4b78700 (LWP 18234) exited]
[New Thread 0x7fffd4b78700 (LWP 18235)]
[New Thread 0x7fffd5379700 (LWP 18236)]
[Thread 0x7fffd5379700 (LWP 18236) exited]
[New Thread 0x7fffd5379700 (LWP 18237)]
[Thread 0x7fffd5379700 (LWP 18237) exited]
[New Thread 0x7fffd5379700 (LWP 18238)]
[Thread 0x7fffd5379700 (LWP 18238) exited]
[New Thread 0x7fffd5379700 (LWP 18240)]
[New Thread 0x7fffc31d3700 (LWP 18241)]
[Thread 0x7fffc31d3700 (LWP 18241) exited]
[Thread 0x7fffd5379700 (LWP 18240) exited]
[New Thread 0x7fffd5379700 (LWP 18242)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffc3fff700 (LWP 18223)]
update_node (this=0x7fffc3ffcb60)
    at /usr/include/mdds/multi_type_vector_itr.hpp:171
171	/usr/include/mdds/multi_type_vector_itr.hpp: Datei oder Verzeichnis nicht gefunden. 

Operating System: Ubuntu
Version: 4.2.4.2 release
Comment 1 m.a.riosv 2014-08-23 20:38:18 UTC
Reproducible
Opensuse 13.1 (VM)
Ver 4.1.2.3 Build ID: 410m0(Build:3)

Works for me with
Win7x64
Ver 4.2.4.2 Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8
Ver 4.2.6.1 Build ID: 5fdddf655fba363e34f755715238d0943a44857e
Comment 2 ign_christian 2014-08-24 02:14:05 UTC
(In reply to comment #0)
> Created attachment 105116 [details]
> Sample ODS File, that crashes when you perform the described action
> 
> LibreOffice crashes when you select I1:J7 and drag'n'drop it exactly one
> coulmn to the right (column J and K) in the file I've attached.

Not reproducible with LO 4.2.6.2 and 4.3.1.1 under Ubuntu 12.04 x86

@Cedric, please try latest release & reset user profile
Comment 3 penttila 2014-08-25 16:03:02 UTC
I can confirm this bug.

LinuxMint 17 Cinnamon (based on Ubuntu 14.04)
LO   4.2.4.2 Build id.: 420m0(Build:2)
Comment 4 Caolán McNamara 2014-08-27 15:49:31 UTC
I can't reproduce that immediately, but if I ctrl-z after moving the cells then it definitely crashes in a dbgutil master build
Comment 5 Buovjaga 2014-11-27 06:56:30 UTC
No repro here, not even with undo.

Win 7 64-bit Version: 4.5.0.0.alpha0+
Build ID: b144f0ac8695dd62a2053b4e88212d0b109c9a41
TinderBox: Win-x86@51-TDF, Branch:MASTER, Time: 2014-11-25_00:14:54

Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
Build ID: 6b219f012edbe069c461f4e0746898e33fa1dd49
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2014-11-25_21:56:46
Comment 6 QA Administrators 2015-06-08 14:28:59 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!

This NEEDINFO Message was generated on: 2015-06-08

Warm Regards,
QA Team
Comment 7 cedric 2015-06-08 15:02:09 UTC
Didn't know this still existed.
I tested the file again and it seems that the bug only occurs in older versions of LibreOffice, but at least not anymore since 4.2.8.2 (which I tested).
Comment 8 Buovjaga 2015-06-08 15:19:13 UTC
Thank you for following up with this. I'll set to WFM as we don't know what commit fixed it.