Download it now!
Bug 83169 - CRASH after copying a cell with URL then deleting whole row
Summary: CRASH after copying a cell with URL then deleting whole row
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.6.1 rc
Hardware: Other Linux (All)
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: BSA target:4.3.6
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-28 00:59 UTC by nomnex
Modified: 2015-02-16 16:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
firefox-password-sample (5.23 KB, text/csv)
2014-08-28 15:03 UTC, nomnex
Details
gdbtrace.log from 4.2.6.3 (11.26 KB, text/plain)
2014-08-28 15:57 UTC, ign_christian
Details
stack trace from 4.3.5.2 (15.31 KB, text/plain)
2015-02-13 23:05 UTC, Ryan Tandy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nomnex 2014-08-28 00:59:34 UTC
This is a strange bug. Tested with the same file in two formats (.csv) and (.ods).

"I have a csv file of my Firefox passwords (I use the extension "password exporter"). The first column display the URL's of the website, the second column the Log-in ID, the third column the password, etc.

I want to copy & past the URLs, from Calc to the address bar of my web browser, to check their validity"

How to reproduce the bug:

1. Open the file in Calc
2. Click on a cell containing an URL (Column A)
3. [Important] Select & copy the URL displayed in the "input bar" or "formula bar"
4. Past the URL in the address bar of the web browser (let's say the URL is not valid and I want to delete the cells content in Calc.)
5. Return to Calc.
6. Select the complete row or only the cells (URL, id, password, etc.)
7. Press "Del" or press "Backspace" key.
8. Calc crashes randomly after a few deletions (points 2 to 7).

On my system at least: selecting a cell + copying its content on the address bar + deleting the cell (or deleting the full row) crashes the application.

How to avoid the bug:

3. Copy and past the cell content (vs. copy and past the "input bar" content).
Comment 1 ign_christian 2014-08-28 02:18:09 UTC
Please try latest prerelease 4.2.6.3 or 4.3.1.2 : http://dev-builds.libreoffice.org/pre-releases/ , reset user profile, & remove the extension. Still reproduce crash?

Then please change status back to UNCONFIRMED
Comment 2 nomnex 2014-08-28 15:03:35 UTC
Created attachment 105387 [details]
firefox-password-sample

For information, I have just installed 4.3.0 release. New profile and not add-on.

I will install 4.3.1 release in a few days and post the result.

In the meantime, could you try to reproduce the crash by selecting a cell containing an URL, copying the URL on the Input bar (Ctrl+A > Ctrl+C), then deleting the row (either using the "Del" or "Backspace" key)?

I experience a crash about every 4 or 8 times, when I delete a row content. I enclose an edited version of my firefox password csv file. In fact, now that I try again, just selecting the content on the input bar (the background becomes black) and clicking on the row a few times (the background become blue) crashes the application. It could be a problem of Graphic card? This notebook uses an old ATI Radeon 900.
Comment 3 ign_christian 2014-08-28 15:33:58 UTC
Yeah..I can reproduce crash with 4.2.6.3 and 4.3.1.2 under Ubuntu 12.04 x86

Simplified procedure to repro the crash:
1. Open attached file
2. Double-click cell A1 to select/highlight the content (URL)
3. Copy (Ctrl+C)
4. Select row 1
5. Hit "Del" 

Also reproduced from scratch with only filling cell A1 with an URL.
Comment 4 ign_christian 2014-08-28 15:47:34 UTC
Also reproduced in LO 4.2.6.1.

Not reproduced in LO 4.2.4.2, but there is a bug in that previous version: URL in cell A1 still exist after row deletion.

Since I don't know if it's a regression, adding PossibleRegression to whiteboard.
Comment 5 ign_christian 2014-08-28 15:57:55 UTC
Created attachment 105388 [details]
gdbtrace.log from 4.2.6.3

I don't have debugging package, perhaps it helps a bit: result from $ soffice --backtrace
Comment 6 Jean-Baptiste Faure 2014-09-19 19:56:35 UTC
Reproducible for me with version 4.3.3.0.0+ built at home under Ubuntu 14.04 x86-64.
Weird scenario; indeed steps 2-3 copy nothing. Selecting the row 1 and hitting the Del key delete row 1 content. LO crashes only when I move the mouse pointer away from the row 1 header. If I do not move the mouse pointer, LO does not crash.

Best regards. JBF
Comment 7 Ryan Tandy 2015-02-13 23:05:00 UTC
Created attachment 113373 [details]
stack trace from 4.3.5.2

Hi,

I can reproduce this bug under in versions 4.2.6.3, 4.2.8.2, 4.3.5.2, and 4.3.6.2 on Ubuntu 14.04.

I cannot reproduce it in versions 4.2.4.2, 4.4.0.3, and 4.4.1.1.

I'm attaching a stack trace from version 4.3.5.2.

The copying does not seem to be a key part of this. I can also reproduce the same crash (identical stack trace) with these steps:

1. Open Calc.
2. Type www.google.com into cell A1.
3. Right-click cell A1, and press Escape to dismiss the menu.
4. Click row 1 and press Delete to delete the row.
5. Move the mouse away from row 1 to trigger the crash.

Hope this helps.
Comment 8 Caolán McNamara 2015-02-16 16:27:39 UTC
The EditView is NULL so this was fixed by
http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-4-3&id=2962addb8bdc6207302283407b5de0d65fa7445f

commit 2962addb8bdc6207302283407b5de0d65fa7445f
Author: Caolán McNamara <caolanm@redhat.com>
Date:   Wed Nov 19 16:39:55 2014 +0000

    Resolves: rhbz#1165444 abrt crash with NULL pView
    
    Change-Id: I37f02f16209f274cf0358defba6bfa109948990f
    (cherry picked from commit 755209d88073fd497b884b8de1348ec75c2df7eb)
    Reviewed-on: https://gerrit.libreoffice.org/13156
    Reviewed-by: Andras Timar <andras.timar@collabora.com>
    Tested-by: Andras Timar <andras.timar@collabora.com>

where we now check for that NULL