Download it now!
Bug 83199 - VIEWING: Clicking footnote number in web view causes crash
Summary: VIEWING: Clicking footnote number in web view causes crash
Status: RESOLVED DUPLICATE of bug 86493
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: All All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace, notBibisectable, regression
Depends on:
Blocks:
 
Reported: 2014-08-28 14:44 UTC by agpmailnospam@yahoo.com
Modified: 2015-12-17 10:57 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document - this is the document that it crashes on (141.10 KB, application/msword)
2014-08-28 14:44 UTC, agpmailnospam@yahoo.com
Details
windows backtrace (3.05 KB, text/plain)
2014-08-31 19:18 UTC, Yousuf Philips (jay) (retired)
Details
linux backtrace (26.48 KB, text/plain)
2015-01-06 12:55 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description agpmailnospam@yahoo.com 2014-08-28 14:44:03 UTC
Created attachment 105386 [details]
Sample document - this is the document that it crashes on

I opened a docx file created in Word 2010 using Writer ver. 4.3.1.2.  The document has nearly 500 footnotes, over 17,000 words, and tracked changes.  When I change the Writer view to web view, then click on one of the footnotes in the text to jump to the footnote, Writer crashes (first the screen jumps around for a while then it crashes).  The only explanation of the crash is "Due to an unexpected error...."  This does not seem to happen in Print view and it does not happen with the same document but with most of the pages deleted (tried shortening it to submit sample file but the problem only happens with a long doc).
Comment 1 Yousuf Philips (jay) (retired) 2014-08-31 19:14:17 UTC
Hello agpmailnospam,

Thank you for submitting the bug. I can confirm that in Linux and Windows on master (2014-08-30), that the document crashes in Web Layout, but the crash will happen even without clicking a footnote. It crashes during the documents repagination process when it reaches 23 pages. This is a regression as it doesnt happen in 3.3.0, 3.6.7 and 4.2.5. Crash also happens in 4.3.1.2.

I found the behaviour of footnotes quite weird in this document, as when i clicked a footnote in Web Layout, that it jumps to the footnote area and then the area starts moving down through the pages due to the repagination.
Comment 2 Yousuf Philips (jay) (retired) 2014-08-31 19:18:34 UTC
Created attachment 105502 [details]
windows backtrace
Comment 3 Jacques Guilleron 2014-08-31 21:16:24 UTC
I confirm too with LO 4.4.0.0.alpha0+
Build ID: 37b9ea92ba81d74764a2345a9c75c65bfd272d2b
TinderBox: Win-x86@42, Branch:master, Time: 2014-08-26_09:37:01
and 
LO 4.3.0.4 Build ID: 62ad5818884a2fc2e5780dd45466868d41009ec0
under Windows 7 Home Premium.

This doesn't happen with LO 3.6.7.2 Build ID: e183d5b.

Two observations:
With LO 4.4.0.0.alpha0+ and LO 4.3.0.4, in menu Edit > Changes, if you uncheck Record and Show before asking Web Layout,
you will have no crash and a document of 4 pages.
Now, if you reduce Zoom to 60%, you will get 1 page.

Regards,

Jacques
Comment 4 Xisco Faulí 2014-10-22 09:06:17 UTC
I can't reproduce this issue with Version: 4.4.0.0.alpha1+
Build ID: fd92dffe05f6bf5c849df65c03de56ea0b3e7df0 under Ubuntu 14.04.1
Comment 5 Yousuf Philips (jay) (retired) 2014-10-22 10:44:08 UTC
Still crashes for me on master.

Version: 4.4.0.0.alpha0+
Build ID: c68642d535f2ebb7f1cd866ad19b1fd018e7cd6d
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-10-18_23:03:32

@Xisco: when your in Web Layout (View > Web Layout), let LibO repaginate, which can take a few minutes, and once you see 'Page 1 of 23' in the status bar, it should crash.
Comment 6 Xisco Faulí 2014-10-22 10:45:49 UTC
I waited until it got down to 'Page 1 of 2' and still no crash
Comment 7 Yousuf Philips (jay) (retired) 2014-10-23 21:22:55 UTC
Weird that it didnt happen for you Xisco. I guess we'll just have to leave it to the devs to look through the backtrace. :D
Comment 8 Matthew Francis 2014-12-09 07:13:34 UTC
I also couldn't reproduce this on Linux, even around the mentioned dates/commits.

I wonder if this is a 32-bit only issue. If it can still be reproduced on 32-bit then it's a real bug but not bibisectable
Comment 9 Yousuf Philips (jay) (retired) 2015-01-06 12:54:27 UTC
Tested it on Linux Mint 17 64-bit on 4.5 (2014-12-31) and no crash.

Tested it on Linux Mint 13 32-bit on 4.4 (2014-12-29) and crash.

Will attach linux backtrace.
Comment 10 Yousuf Philips (jay) (retired) 2015-01-06 12:55:05 UTC
Created attachment 111847 [details]
linux backtrace
Comment 11 Björn Michaelsen 2015-02-03 12:05:15 UTC
32-Bit only crasher in vcl -> component graphics stack
Comment 12 Michael Stahl (CIB) 2015-04-16 21:31:21 UTC
according to stacktrace it's a duplicate of bug 86493

master on Windows doesn't crash here, don't have other 32-bit builds to test

(removing "dataloss" from whiteboard since it's a crash, not a import/export bug)

*** This bug has been marked as a duplicate of bug 86493 ***
Comment 13 Yousuf Philips (jay) (retired) 2015-04-17 14:48:32 UTC
Didnt crash for me.

Version: 4.5.0.0.alpha0+
Build ID: 25c25f855169c98c30f3f7868fd1ad430e159ddc
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-04-14_08:59:23
Comment 14 Robinson Tryon (qubit) 2015-12-17 10:57:54 UTC
Migrating Whiteboard tags to Keywords: (notBibisectable)
[NinjaEdit]