Bug 83206 - Other: The included Portuguese spell checker doesn't use the orthographic agreement
Summary: Other: The included Portuguese spell checker doesn't use the orthographic agr...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-28 18:27 UTC by JP
Modified: 2014-08-28 21:09 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
The current behavior. (86.95 KB, image/png)
2014-08-28 18:27 UTC, JP
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JP 2014-08-28 18:27:18 UTC
Created attachment 105393 [details]
The current behavior.

Problem description: 
The European Portuguese spell checker which comes included in the installation doesn't use the orthographic agreement of 1990 (the most recent). It's necessary to change this because this is what Portugal officially adopted between 2010 and 2012. The best option would be to include both dictionaries but use the orthographic agreement as default.
Currently it's necessary to download and install the orthographic agreement dictionary manually from https://pt.libreoffice.org/dicionarios-extensoes-e-modelos/ (Dicionário em versão Acordo Ortográfico).
The UI itself uses the agreement (try writing "atualizações" too, just like in the help section).

Steps to reproduce:
1. Install a fresh copy in Portuguese (Portugal) of Ubuntu 14.04 LTS (for LO 4.2) or Debian Testing (for LO 4.3) [a live session doesn't work] [amd64];
2. Open LibreOffice Writer;
3. Write "actividade" and "atividade".

Current behavior:
Marks "atividade" as wrong, but not "actividade".

Expected behavior:
Marks "actividade" as wrong, but not "atividade".
Operating System: Ubuntu
Version: 4.2.4.2 release
Comment 1 Urmas 2014-08-28 21:09:31 UTC
In Linux LO uses the system-provided spellchecker. Complain to its maintainers.