Download it now!
Bug 83316 - insert (exif-)rotated picture as link
Summary: insert (exif-)rotated picture as link
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-31 22:14 UTC by Juang Dse
Modified: 2018-05-23 07:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
example picture (1.02 MB, image/jpeg)
2014-08-31 22:14 UTC, Juang Dse
Details
Resulting Good File with Picture (1.03 MB, application/vnd.oasis.opendocument.text)
2014-09-03 08:21 UTC, Joel Madero
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juang Dse 2014-08-31 22:14:34 UTC
Created attachment 105513 [details]
example picture

When inserting a rotated picture (with corresponding exif orientation flag, example attached) as a link I am asked to rotate it into standard orientation, to which I respond 'yes'.

The picture looks correct. But if the file is saved and reopened the picture is no longer rotated (and distorted).
Comment 1 Juang Dse 2014-09-01 15:57:34 UTC
and vice versa:

if one rotates an exif-rotated linked picture, the link disappears and the picture gets embedded.
Comment 2 Joel Madero 2014-09-03 08:21:27 UTC
Cannot reproduce:
Bodhi 2.x
LibreOffice 4.3.1.2

Attached is my saved copy of the file:
1. Downloaded image
2. Inserted image
3. Replied "yes" to prompt
4. Saved as odt
5. Closed
6. Opened

I see the image right with no distortion and right orientation.
Comment 3 Joel Madero 2014-09-03 08:21:47 UTC
Created attachment 105668 [details]
Resulting Good File with Picture
Comment 4 Juang Dse 2014-09-03 08:30:37 UTC
(In reply to comment #2)
> Cannot reproduce:
> Bodhi 2.x
> LibreOffice 4.3.1.2
> 
> Attached is my saved copy of the file:
> 1. Downloaded image
> 2. Inserted image
> 3. Replied "yes" to prompt
> 4. Saved as odt
> 5. Closed
> 6. Opened
> 
> I see the image right with no distortion and right orientation.

It seems your picture is not linked (Edit -> Links). When inserting the picture you need to activate "Insert as link" in the lower left corner.
Comment 5 Joel Madero 2014-09-03 20:34:19 UTC
Bodhi 2.4x
LibreOffice 4.3.1.2 release

Confirmed:
New
Major - I suppose that this is technically a loss of data
High - default seems appropriate

@Juang - thanks for the explanation! If you're ever interested in getting more involved with helping us confirm bugs feel free to email me - we could surely use the assistance :)
Comment 6 tommy27 2016-04-16 07:25:58 UTC Comment hidden (obsolete)
Comment 7 Juang Dse 2016-04-18 08:27:25 UTC
bug still present.

LibreOffice version 5.1.2.2
Linux 3.16.0-38-generic x86_64 GNU/Linux
Comment 8 QA Administrators 2017-05-22 13:21:32 UTC Comment hidden (obsolete)
Comment 9 Juang Dse 2017-05-22 17:59:07 UTC
bug still present.

LibreOffice version 5.3.3 / Linux
Comment 10 QA Administrators 2018-05-23 02:38:07 UTC Comment hidden (obsolete)
Comment 11 Juang Dse 2018-05-23 07:22:18 UTC
Version: 6.0.4.2
Build ID: 6.0.4-1
CPU threads: 4; OS: Linux 4.16; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group