Download it now!
Bug 83456 - Image in master slide is tripled
Summary: Image in master slide is tripled
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2014-09-03 20:28 UTC by Matthias Stuermer
Modified: 2015-12-15 11:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
example (238.02 KB, application/vnd.oasis.opendocument.presentation)
2014-09-03 20:28 UTC, Matthias Stuermer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Stuermer 2014-09-03 20:28:49 UTC
Created attachment 105705 [details]
example

In LibreOffice 4.2.x the master slide worked correctly by showing a single image in the header and no line. When opening the slide in the current 4.3.1.2 LibreOffice version we get the image (logo of University of Bern) tripled and a blue line is added on the top.
Comment 1 Joel Madero 2014-09-03 20:54:30 UTC
Confirmed:
Bodhi 2.x
LibreOffice bibisect (confirmed regression) existing still on 4.3.1.2 release also exists on 4.4 built just a couple days ago: Version: 4.4.0.0.alpha0+
Build ID: 880c18f23068a1faf34f36a67161e3b85fffdea7

New
Normal - can prevent high quality/professional work
High - regression

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Unfortunately it isn't bibisectable.
Comment 2 Cor Nouws 2014-09-03 22:35:24 UTC
I see the same problem in master; 4.3.1.; 4.2.6.2; 4.2.0.4; 4.1.3.5.
Latest version on my side that doesn't have the problem in 4.0.6.2.

Is it possible for you to check that, Matthias?
Comment 3 Andras Timar 2014-11-04 09:22:41 UTC
The university logo image is tripled in the file, too.

1.
<draw:frame draw:style-name="Mgr3" draw:text-style-name="MP3" draw:layer="backgroundobjects" svg:width="4.099cm" svg:height="3.151cm" svg:x="23.601cm" svg:y="0.349cm"><draw:image xlink:href="Pictures/2000000800000E2A00000AE39510764A.svm" xlink:type="simple" xlink:show="embed" xlink:actuate="onLoad"><text:p/></draw:image></draw:frame>
2.
<draw:frame draw:style-name="Mgr3" draw:text-style-name="MP3" draw:layer="backgroundobjects" svg:width="3.625cm" svg:height="2.786cm" svg:x="24.075cm" svg:y="0.349cm"><draw:image xlink:href="Pictures/2000000800000E2A00000AE3867AE6AA.svm" xlink:type="simple" xlink:show="embed" xlink:actuate="onLoad"><text:p/></draw:image></draw:frame>
3.
<draw:frame draw:style-name="Mgr3" draw:text-style-name="MP3" draw:layer="backgroundobjects" svg:width="3.285cm" svg:height="2.535cm" svg:x="24.115cm" svg:y="0.6cm"><draw:image xlink:href="Pictures/10000000000004300000033BC55427E6.png" xlink:type="simple" xlink:show="embed" xlink:actuate="onLoad"><text:p/></draw:image></draw:frame>

If you check the coordinates, you can see that they do not overlap exactly. The blue line also can be found in the file:

<draw:frame draw:style-name="Mgr3" draw:text-style-name="MP3" draw:layer="backgroundobjects" svg:width="27cm" svg:height="0.081cm" svg:x="0.5cm" svg:y="4.6cm"><draw:image xlink:href="Pictures/200000080000611A0000006687ED557D.svm" xlink:type="simple" xlink:show="embed" xlink:actuate="onLoad"><text:p/></draw:image></draw:frame>

I cannot tell, if older versions were buggy, because they didn't show these elements, or the newer versions are buggy, because they show them. But there is a workaround: remove them from master slide.
Comment 4 Matthew Francis 2015-02-13 14:46:23 UTC
Looks fine to me in current 4.5 master

-> RESOLVED WORKSFORME


For reference the bug was introduced somewhere in the following region

# possible first bad commit: [835ce851abe657bb5a8238693ea924287e6890c0] source-hash-1e53784811458563b36fd4cbaa15c2f526a7161b
# possible first bad commit: [518c9b83800dfc9c791d592245d7e467bfec82c5] source-hash-4ec8c63b5d41ca9ad7dd9ed10dda6b40927d859c
# possible first bad commit: [92abe3d8366d452263401a2a61d6d7fa894cbfbd] source-hash-9c2a085a45f9acb305fb85367bede360982e71cb

And seems to have been fixed by

commit d53103dd83bf20ac63485e229069f145e35b3009
Author: Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>
Date:   Sun Jan 18 23:51:14 2015 +0900

    fdo#74124 bilinear scaling with blending for some formats
    
    The DrawDeviceAlphaBitmapSlowPath used fast/ugly scaling with
    blending. With this a bilinear scaling is used which should
    improve quality for downscaling (less than 50% should start to
    degrade in quality as only 2 samples are always used) and
    upscaling.
    
    Change-Id: I56cdf2b5761687be891387343a773b6fefac03e2
Comment 5 Robinson Tryon (qubit) 2015-12-15 11:03:45 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]