Bug Hunting Session
Bug 83602 - While printing A4 page Size is passed on to cups even if A4.duplex paper size is selected in LO print dialog
Summary: While printing A4 page Size is passed on to cups even if A4.duplex paper size...
Status: RESOLVED DUPLICATE of bug 60428
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: All Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-08 06:38 UTC by Sanjay Kumar
Modified: 2015-04-09 11:19 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
PPD used for creating print queue (4.62 KB, application/gzip)
2014-09-08 06:38 UTC, Sanjay Kumar
Details
IPP request file passed on to Cups while printing (817 bytes, application/octet-stream)
2014-09-08 06:41 UTC, Sanjay Kumar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sanjay Kumar 2014-09-08 06:38:49 UTC
Created attachment 105881 [details]
PPD used for creating print queue

Libreoffice sends A4 even though A4.duplex is selected in the Libreoffice print dialog. Since there is a constraint between A4 and Duplex=Long or Short Edge and looks like because of that Libreoffice changes Duplex option from Long/short Edge to OFF as well. Just to prove what I said, I captured the application output file (d00009-001.pdf) and its corresponding control file(c00009), I can see that below options are passed on to cups in c00009 file.
Duplex: None
PageSize: A4

Please find c00009, d00009-001.pdf files in below bug report.
https://bugs.launchpad.net/hplip/+bug/1352316
https://answers.launchpad.net/hplip/+question/252277


The ppd used for creating the print queue is attached in this Bug report.
Comment 1 Sanjay Kumar 2014-09-08 06:41:48 UTC
Created attachment 105882 [details]
IPP request file passed on to Cups while printing
Comment 2 Argyris 2015-02-11 02:04:08 UTC
I believe this is a duplicate of bug #60428.

*** This bug has been marked as a duplicate of bug 60428 ***