Bug 83663 - Writer adds unwanted indents to document on save as .docx
Summary: Writer adds unwanted indents to document on save as .docx
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.6.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-09 11:45 UTC by Peter A.
Modified: 2015-09-30 14:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example of LibreOffice Bug (4.96 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-09-09 11:45 UTC, Peter A.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter A. 2014-09-09 11:45:13 UTC
Created attachment 105973 [details]
Example of LibreOffice Bug

When I create a document on LibreOffice Writer all looks as it should, but when I save the document in docx format, then reopen it, unwanted indents have been added to a specific style. This bug has only been evident since I upgraded to Version: 4.2.6.3 Build ID: 420m0(Build:3).

Steps to reproduce:

1. Open Document
2. Create style as follows:

Western text: Times New Roman + 14pt + Not Italic + bold + Align left + 2 + Indent left 0.0cm, Indent right 0.0cm + From top 0.0cm, from bottom 0.4cm

3. Create text using this style and others
4. Save document in docx format
5. Open document
6. All test using the style specified is now indented

If the doc is edited and then saved again, the indents do not reappear. It is only on the first save that his happens.

Documents created with previous version and opened in this version do not have this issue

Please see attached example
Comment 1 A (Andy) 2014-10-24 21:03:49 UTC
for me not reproducible with LO 4.3.2.2 (Win 8.1)
Comment 2 Alex Jordan 2014-10-26 20:34:25 UTC
I'm not sure I follow the styling steps. Can you attach an example of an ODF document that has the correct styling, and exhibits the issue when exported as a DOCX? Thanks!
Comment 3 Peter A. 2014-10-26 21:47:57 UTC
Unfortunately - or not! - I can no longer reproduce the error.

The styles were saved as my default template, and whenever a document was created from this template and saved as a docx, the indents would be added. If they were then removed, and the document saved for a second time, the indents would disappear.

Eventually, I had the bright idea of creating a document from the default template, saving it, opening it, removing the indents, saving it again, opening it again, removing all the text and then saving THAT as a new default template.

This works, so I no longer have the indenting issue, and I don't want to mess about with settings to try and recreate it, especially as I am a writer by trade and use Writer for at least eight hours, each and every day!
Comment 4 Andras Timar 2015-09-30 14:32:47 UTC
No longer reproducible by the reporter, let's close.