Bug Hunting Session
Bug 83676 - SVG with patterns crashes LO
Summary: SVG with patterns crashes LO
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-09 15:01 UTC by tomaskeb
Modified: 2015-12-05 14:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
SVG containing a pattern as a fill (2.33 KB, image/svg+xml)
2014-09-09 15:01 UTC, tomaskeb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tomaskeb 2014-09-09 15:01:54 UTC
Created attachment 105988 [details]
SVG containing a pattern as a fill

After inserting an SVG that contains a pattern, LO crashes (I tried it in Writer, Draw and Impress). Simple test SVG made with Inkscape is attached.
Comment 1 Regina Henschel 2014-09-10 14:57:47 UTC
I can confirm the crash with Version: 4.4.0.0.alpha0+
Build ID: 5aeb852efcabdd51545d5d41c92f4bf3cef1d663
TinderBox: Win-x86@39, Branch:master, Time: 2014-09-08_07:01:57

It crashes, when there is a need for redraw, e.g. when you move the image or when you hide the slide pane.

After the crash, sometimes the view of other applications and of the Windows desktop is not refreshed automatically.

It does not crash in Version: 4.2.5.2
Build ID: 6ff819b65674ae6c83f3cbab9e4a4c2b292a7a94

It crashes too in Version: 4.3.0.0.alpha1+
Build ID: 145f2e970f46a3a3e5456b122d71f17c3abe878f
TinderBox: Win-x86@42, Branch:master, Time: 2014-04-26_23:32:36
Comment 2 Julien Nabet 2014-11-01 23:23:30 UTC
On pc Debian x86-64 with master sources updated yesterday, I used Insert image to insert the SVG, I don't reproduce this.

Windows only bug?
Any chance to have a bt?
Comment 3 Julien Nabet 2014-11-01 23:23:44 UTC
Oups, forgot to provide the link:
https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Windows:_How_to_get_a_backtrace
Comment 4 tomaskeb 2015-03-10 12:44:17 UTC
In 4.4.1 the problem is gone.
Comment 5 Julien Nabet 2015-03-10 12:55:01 UTC
Just nitpicking, since there's no specific fix, let's put this to WFM instead.
Comment 6 Julien Nabet 2015-12-05 14:44:25 UTC
cleanup keywords