Bug Hunting Session
Bug 83710 - Insert Movie dialog appears and disappears [Hard to repro]
Summary: Insert Movie dialog appears and disappears [Hard to repro]
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-10 12:15 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-11-04 14:58 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
screencast (802.32 KB, video/webm)
2014-11-15 19:06 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-09-10 12:15:41 UTC
Steps:
1) Open impress
2) Select 'Title, Content' layout
3) Select the content part so that the blue line is blinking
4) Click the insert movie button
5) dialog will appear for a second and then disappear

Tested in 4.2.6 and master.
Comment 1 Julien Nabet 2014-09-10 21:02:57 UTC
On pc Debian x86-64 with master sources updated today, I didn't reproduce this but noticed these logs:
warn:vcl.layout:27854:1:vcl/source/window/toolbox.cxx:4722: only tabitems with window supported at the moment
warn:vcl.layout:27854:1:vcl/source/window/toolbox.cxx:4088: only tabitems with window supported at the moment
warn:vcl.layout:27854:1:vcl/source/window/toolbox.cxx:4722: only tabitems with window supported at the moment
warn:vcl.layout:27854:1:vcl/source/window/toolbox.cxx:4722: only tabitems with window supported at the moment
warn:vcl.layout:27854:1:vcl/source/window/toolbox.cxx:4088: only tabitems with window supported at the moment
warn:vcl.layout:27854:1:vcl/source/window/toolbox.cxx:4088: only tabitems with window supported at the moment
warn:legacy.tools:27854:1:sfx2/source/control/statcach.cxx:404: setting state of dirty message

Chris: thought you might be interested in this one since it concerns vcl. Any idea?
Comment 2 Yousuf Philips (jay) (retired) 2014-09-10 22:20:51 UTC
So i was going back through the versions to test how far back it went, so i tested 3.6.7, 4.0.6, 4.1.6, and once i got to 4.2.6 it happen again. Then i went back through the versions and then it started happening in all the versions it wasnt happening in.

I tested and this doesnt happen in Windows 7 (master) or Linux Mint 17 (4.3.1), so it might likely be only reproducible on Ubuntu 12.04 type releases.
Comment 3 sophie 2014-10-09 14:33:00 UTC
Hi Jay, tested it with 4.3.2.1 and master (today) with Ubuntu 14.04 and can't reproduce - Sophie
Comment 4 Yousuf Philips (jay) (retired) 2014-10-09 17:27:41 UTC
Retested it just now and it still happens on my Linux Mint 13 (Mate 1.6.1) desktop.

Version: 4.4.0.0.alpha0+
Build ID: ced24ffba2fa1754c466b7944b0ee06d21292706
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-10-04_21:36:54
Comment 5 Julien Nabet 2014-10-09 21:06:49 UTC
Jay: what about if you disable hardware acceleration and perhaps too anti-aliasing (Tools/Options/LibreOffice/View)
Also, did you notice specific console logs?
Comment 6 Yousuf Philips (jay) (retired) 2014-10-10 05:37:29 UTC
(In reply to Julien Nabet from comment #5)
> Jay: what about if you disable hardware acceleration and perhaps too
> anti-aliasing (Tools/Options/LibreOffice/View)
> Also, did you notice specific console logs?

Julien: hardware acceleration and anti-aliasing didnt make a difference and didnt understand what it would as the open dialog is generated by the OS. I ran it from the console but didnt see any output. Do i need to run a particular version of the daily build in order to see the errors that you showed.
Comment 7 Julien Nabet 2014-10-13 18:41:34 UTC
Jay: I build from master sources with enable-dbgutil (to have the max of information). You may use a daily build with dbg too (see http://dev-builds.libreoffice.org/daily/master/)
For the rest, thinking again about it, you must be right about hardware acceleration, it must be unrelated, sorry for the noise.
Comment 8 Yousuf Philips (jay) (retired) 2014-10-14 15:28:04 UTC
Julien: tried to grab one of the dbg builds but cant get them to run due to an error (bug 85006).
Comment 9 Yousuf Philips (jay) (retired) 2014-11-15 19:00:50 UTC
Well now that the dbg version is working again for me, i checked it out.

When i did step 3 (Select the content part so that the blue line is blinking) it outputted :-

warn:vcl.layout:25701:1:vcl/source/window/toolbox.cxx:4724: only tabitems with window supported at the moment
warn:vcl.layout:25701:1:vcl/source/window/toolbox.cxx:4090: only tabitems with window supported at the moment
warn:vcl.layout:25701:1:vcl/source/window/toolbox.cxx:4724: only tabitems with window supported at the moment
warn:vcl.layout:25701:1:vcl/source/window/toolbox.cxx:4724: only tabitems with window supported at the moment
warn:vcl.layout:25701:1:vcl/source/window/toolbox.cxx:4090: only tabitems with window supported at the moment
warn:vcl.layout:25701:1:vcl/source/window/toolbox.cxx:4090: only tabitems with window supported at the moment
warn:legacy.tools:25701:1:sfx2/source/control/statcach.cxx:404: setting state of dirty message

But when i did step 4 (Click the insert movie button) there was no dbg output for it.
Comment 10 Yousuf Philips (jay) (retired) 2014-11-15 19:06:10 UTC
Created attachment 109532 [details]
screencast

screencast of what happens when the text area is not selected and when it is selected.
Comment 11 raal 2014-12-30 20:20:44 UTC
I can not confirm on Ubuntu 14.10 with Version: 4.3.3.2 and 4.5.0.0.alpha0+
Build ID: 7f476fea47f06a7f8cc961dd4f6595a524346fa5
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-12-27_23:36:28
Comment 12 Buovjaga 2015-01-15 18:31:58 UTC
Can't repro here either. In addition to the tabitems debug message, I get a lot of these (after the dirty message):
warn:svl.items:5154:4:svl/source/items/itemset.cxx:1416: can't store invalid items

Also these, although I don't know, if they appeared after I canceled adding movie, but I could not reproduce the messages:

warn:legacy.osl:5154:4:sal/rtl/string.cxx:198: OSL_ASSERT: pTarget != NULL && (pSource != NULL || nLength == 0) && nLength >= 0 && (nLength == 0 || rtl_isOctetTextEncoding(nEncoding))

warn:legacy.tools:5154:4:editeng/source/items/frmitems.cxx:2226: SvxBoxItem: Gibt es ein neues Fileformat?

Note the German message above!

Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
Build ID: 7201fa0dddd7dd0352f69fd2b2b64efcb361ccad
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-01-11_23:28:55
Comment 13 Jean-Baptiste Faure 2016-02-05 06:07:06 UTC
Not reproducible for me with LO 5.1.1.0.0+ built at home under Ubuntu 15.10 x86-64.

Best regards. JBF
Comment 14 Yousuf Philips (jay) (retired) 2016-02-05 14:36:27 UTC
@Bjoern: Can you test this on ubuntu 12.04 to see if it still happens?
Comment 15 Yousuf Philips (jay) (retired) 2016-11-04 14:58:54 UTC
Closing this as ubuntu 12.04 only has a few months or remaining support on it.