Bug Hunting Session
Bug 83817 - Poor performance in sorting entire sheet
Summary: Poor performance in sorting entire sheet
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks:
 
Reported: 2014-09-13 14:56 UTC by Yousuf Philips (jay) (retired)
Modified: 2015-12-15 11:05 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-09-13 14:56:44 UTC
Steps:
1) Open attachment 103050 [details]
2) Select entire spreadsheet with Ctrl+A and sort by column A from Data > Sort

4.1.6 - 0:18 
4.3.3 - 1:42 (with high probability of a crashing after completing - bug 81501)

Tested on Linux. It will crash 10 or 20 seconds into the sort on Windows.

Version: 4.3.3.0.0+
Build ID: f3cdb7804a26c5cf0623d9b83130594f83372768
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:libreoffice-4-3, Time: 2014-09-12_04:11:44
Comment 1 m.a.riosv 2014-09-13 22:45:40 UTC
Reproducible.
Win7x64
4.2.6.3
4.3.1.2

But only with all sheet selected.

Going to A1 and Menu/Data/Sort, works fine for me.

So I can't considerer it's fine as high and major.
Comment 2 Kohei Yoshida 2014-10-13 12:34:43 UTC
Making this an enhancement.  Sort code has been re-written, so the concept of regression doesn't apply.  A brand-new solution is needed.
Comment 3 Yousuf Philips (jay) (retired) 2015-08-21 02:30:47 UTC
@Qubit, @Joel: Kohei set this to enhancement as the sort code was rewritten but not having this set as a bug means that it wont get the attention it needs. What you guys think?
Comment 4 Joel Madero 2015-08-21 03:28:34 UTC
I think Kohei knows best and it's an enhancement request. "Attention it needs" is hardly an unbiased opinion (considering you reported the bug). Kohei knows the code, he knows what it was designed to do, and he knows that whatever request you made is an enhancement. Setting it to blocker (exaggerated) isn't going to make it go any faster.
Comment 5 Joel Madero 2015-08-21 03:31:10 UTC
BTW - even if I were to agree that it's a bug I would say at most it's minor - medium (slows down work but does not prevent it). So I don't know if it a minor bug is going to get more attention than it being an enhancement.

I would suggest doing the work from QA side to move it forward (bibisect + valgrind/calgrind - whatever one is appropriate) and then tagging it correctly. 

The crash in Windows is a separate issue and should be reported separately and likely set to Major or even Critical (if the crash still exists) as a crash is obviously a different beast than what this bug title (and first half of comment) suggests.
Comment 6 Yousuf Philips (jay) (retired) 2015-08-21 04:16:00 UTC
(In reply to Joel Madero from comment #4)
> I think Kohei knows best and it's an enhancement request. "Attention it
> needs" is hardly an unbiased opinion (considering you reported the bug).
> Kohei knows the code, he knows what it was designed to do, and he knows that
> whatever request you made is an enhancement. Setting it to blocker
> (exaggerated) isn't going to make it go any faster.

Well i want to be consistent because though Miklos rewrote the RTF import and export filters, i still report bugs that affect the new filters as regressions to the old filters.

(In reply to Joel Madero from comment #5)
> BTW - even if I were to agree that it's a bug I would say at most it's minor
> - medium (slows down work but does not prevent it). So I don't know if it a
> minor bug is going to get more attention than it being an enhancement.

Well this was a simple spreadsheet and you never know how bad it can get if it was a more complex one.

> I would suggest doing the work from QA side to move it forward (bibisect +
> valgrind/calgrind - whatever one is appropriate) and then tagging it
> correctly. 

Well i guess i should have verified it before disturbing you as, it seems to be fixed now in 4.3.7, 4.4.6 and master.

Version: 5.1.0.0.alpha1+
Build ID: 5d6ef74eea5d73b8cd17f313ad87138d56dc76ce
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-08-18_01:28:44
Locale: en-US (en_US.UTF-8)
Comment 7 Robinson Tryon (qubit) 2015-12-15 11:05:12 UTC
Migrating Whiteboard tags to Keywords: (perf)
[NinjaEdit]