Bug 83846 - "Bad allocation" on Windows 7 x64 when working with master document
Summary: "Bad allocation" on Windows 7 x64 when working with master document
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3 Daily
Hardware: x86-64 (AMD64) Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-14 14:09 UTC by Daniel Grigoras
Modified: 2015-11-09 12:51 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Grigoras 2014-09-14 14:09:16 UTC
Hi 

I work with a master document and I found out that I have to run LibreOffice on Ubuntu x64, as on Windows 7 x64 LibreOffice returned "Bad allocation" and crashed each time I inserted many or all of the subdocuments, which amount to 2000 pages. On Ubuntu it runs great, but on Windows 7 x64 poorly. I have to add that I also have OpenOffice installed, but I understand that there shouldn't be any conflicts by having both installed.

Also, at the subdocument level, and this again on Windows 7 x64, LibreOffice would just not show some of the larger pictures contained by a 40 MB subdocument.
Comment 1 Jean-Baptiste Faure 2014-09-14 20:19:53 UTC
Not sure if the bug is in LibreOffice ;-)

What amount of RAM do you have under W7 ?
Did you play with graphic cache parameter : menu Tools > Options > LibreOffice > Memory ?

Set status to NEEDINFO. Please set it back to UNCONFIRMED once you have provided requested informations. Thank you for your understanding.

Best regards. JBF
Comment 2 Julien Nabet 2014-09-15 19:57:26 UTC
Another thing to have in mind, LO is build on 32 bits only on Windows so even if you're on Win7 64 bits, you might have some limitations.

What's the physical size of your whole doc (master and subdocuments)?

Now there are still memory leaks fixed on LibreOffice. For the test, you may give a try to daily master sources, see http://dev-builds.libreoffice.org/daily/master/Win-x86@51-TDF/current/
Comment 3 Daniel Grigoras 2014-09-16 09:06:51 UTC
My system is equipped with a Core i7-4770, 256GB SSD, 8GB of RAM and runs Windows 7 x64.
The total size of the subdocuments is 114 MB, and growing.

I have set the memory setting for LibreOffice to the maximum allowed and I still receive "Bad allocation" in just a few seconds after inserting the subdocuments into the master document.

As mentioned before, this is not an issue on Ubuntu. I can only work on Ubuntu because of this.
Comment 4 Julien Nabet 2014-10-13 18:43:03 UTC
Following your last comment I put it back to UNCONFIRMED.
Comment 5 Daniel Grigoras 2014-10-14 06:53:06 UTC
(In reply to Julien Nabet from comment #4)
> Following your last comment I put it back to UNCONFIRMED.

Why would you do that? This is a real issue.
Comment 6 Daniel Grigoras 2014-10-14 07:00:33 UTC
I remember creating a sample master doc a while ago, which you can download from here:
https://www.dropbox.com/s/vz43d9x0v1t3fxr/master_for_support.zip?dl=0
Comment 7 Jean-Baptiste Faure 2014-10-14 10:39:53 UTC
(In reply to Darius Daniel Grigoras from comment #5)
> (In reply to Julien Nabet from comment #4)
> > Following your last comment I put it back to UNCONFIRMED.
> 
> Why would you do that? This is a real issue.

Perhaps but you can't confirm your onw bug reports. Each bug report must be confirmed independently.

Best regards. JBF
Comment 8 Joel Madero 2014-10-23 01:37:48 UTC
Also not a blocker - blockers are reserved for truly cases where the vast majority of users would be affected, as we as of now have a single unconfirmed case....not meeting this criteria. Setting to Major - High. 

What are the exact steps to reproduce? Just download the document and watch a memory leak?
Comment 9 Buovjaga 2014-11-15 12:12:04 UTC
Opens fine here on a system about half as powerful as the reporter's.

Win 7 64-bit Version: 4.4.0.0.alpha2+
Build ID: b021b5983c62e266b82d9f0c5c6d8d8900553827
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-12_01:10:08
Comment 10 Robinson Tryon (qubit) 2015-01-17 10:16:07 UTC
(In reply to Joel Madero from comment #8)
> What are the exact steps to reproduce? Just download the document and watch
> a memory leak?

Darius:

1) Can you still reproduce the problem with 4.4.x and/or 4.5.x builds?

2) As Joel asked, could you be a bit clearer about what steps are required to reproduce the problem?

Status -> NEEDINFO

(Please change status back to UNCONFIRMED after you test with 4.4.x and/or 4.5.x, and provided simple steps for reproduction. Thanks!)
Comment 11 Julien Nabet 2015-01-17 13:12:28 UTC
Darius: for the test, could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#Windows) and give it a new try?
Comment 12 QA Administrators 2015-07-18 17:36:43 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

This NEEDINFO message was generated on: 2015-07-18
Comment 13 Daniel Grigoras 2015-07-20 12:49:19 UTC
(In reply to Julien Nabet from comment #11)
> Darius: for the test, could you rename your LO directory profile (see
> https://wiki.documentfoundation.org/UserProfile#Windows) and give it a new
> try?

Ok, I just did that and LibreOffice crashed while pulling together the subdocuments into the master document. This always happens on Windows, but fortunately never on Ubuntu.
I would prefer having this working on Windows also.
Comment 14 Julien Nabet 2015-08-01 06:51:20 UTC
Thank you Darius for your feedback.
I'll put this one back to UNCONFIRMED.
Comment 15 Daniel Grigoras 2015-11-09 12:28:41 UTC
This issue seems to have been fixed in LibreOffice 5.0.3.2. I've tried before v5.0.2 and LibreOffice crashed after inserting 20 subdocuments in the master document, which was an improvement, as before LibreOffice 5.0.2, LibreOffice crashed immediately upon insertion of subdocuments in the master document. I could only work with subdocuments in the master document on Linux.

Now, with LibreOffice 5.0.3.2 I am able to work on Windows 7 with a masterdocument containing 46 subdocuments totaling 2200 pages.
Comment 16 Buovjaga 2015-11-09 12:51:25 UTC
Thanks, let's set to WFM.