Bug Hunting Session
Bug 83970 - EDITING: When you edit the shape and movement error
Summary: EDITING: When you edit the shape and movement error
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: Other Windows (All)
: medium normal
Assignee: leesanghoon
URL:
Whiteboard: BSA
Keywords:
: 84026 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-09-17 08:22 UTC by leesanghoon
Modified: 2016-04-18 09:47 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Shapes work screen (137.10 KB, image/png)
2014-09-17 08:22 UTC, leesanghoon
Details
sample document (44.92 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-10-01 08:52 UTC, leesanghoon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description leesanghoon 2014-09-17 08:22:08 UTC
Created attachment 106416 [details]
Shapes work screen

Problem description: 
The program is terminated when editing shapes and movement problems.


Steps to reproduce:
1. Create a shape. 
2. Copy and Paste to paste the shape to a lot of UI design work .
3. The program is abnormally terminated when editing shapes . ( Size modify , position fix )



Current behavior:


Expected behavior:

              
Operating System: Windows 8
Version: 4.3.0.4 release
Comment 1 raal 2014-09-25 09:10:00 UTC
Hello,

Thank you for filing the bug. Please send us a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO', so please do change it back to 'UNCONFIRMED' once you have attached a document.
(Please note that the attachment will be public, remove any sensitive information before attaching it. See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I can not reproduce with LO 4.3.1, WIN7
Comment 2 raal 2014-09-27 06:20:36 UTC
*** Bug 84026 has been marked as a duplicate of this bug. ***
Comment 3 leesanghoon 2014-10-01 08:52:47 UTC
Created attachment 107169 [details]
sample document

sample document
Comment 4 raal 2014-10-02 08:50:55 UTC
Thank you for test file. I can not reproduce with LO 4.3.2, WIN7 and LO 4.3.3, Linux. I tried randomly copy, paste, modify, move shapes. Please try newer version, or provide exact steps to reproduce. Thank you.
Comment 5 Buovjaga 2014-11-14 17:55:55 UTC
Did the same as raal and could not get it to terminate.

Win 7 64-bit Version: 4.4.0.0.alpha2+
Build ID: b021b5983c62e266b82d9f0c5c6d8d8900553827
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-12_01:10:08
Comment 6 tommy27 2015-10-04 13:50:49 UTC
@leesanghoon
do you still reproduce it with current LibO 4.4.5.2 or 5.0.0.2 releases?

status NEEDINFO
set it back to UNCONFIRMED if bug is still there or to NEW if bug is gone
Comment 7 mahfiaz 2016-04-18 09:47:36 UTC
I think it is safe to assume it is either fixed or we will never know. I am closing this as worksforme.