Bug 83976 - Form Controls text box missing by saving a file as docx
Summary: Form Controls text box missing by saving a file as docx
Status: RESOLVED DUPLICATE of bug 50097
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-ActiveX-Legacy
  Show dependency treegraph
 
Reported: 2014-09-17 10:08 UTC by Orwel
Modified: 2021-06-16 11:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
original odt file with text box (19.53 KB, application/zip)
2014-09-17 10:08 UTC, Orwel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Orwel 2014-09-17 10:08:25 UTC
Created attachment 106422 [details]
original odt file with text box

Text box created in LO (4.3.0.4) not saved if the file is saved as docx file.
Steps:
1. open the attached original file in LO.
2. save it as docx and reopen it. The text box disappeared (as in LO so in MS Word 2013).
Comment 1 Buovjaga 2014-11-09 19:14:38 UTC
Reproduced.

Win 7 64-bit Version: 4.4.0.0.alpha2+
Build ID: 9229170920ab770624415c4330da57af5b1b5398
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-09_03:16:43
Comment 2 Buovjaga 2015-01-08 18:39:12 UTC
Lowered version number after reproducing with:

Ubuntu 14.10 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 3 A (Andy) 2015-12-27 19:29:35 UTC
Reproducible with LO 5.1.0.1, Win 8.1
Comment 4 Peter Roelofsen 2016-09-05 16:09:23 UTC
Reproduced in 5.2.0.4 32 bits on Windows 10.
Comment 5 Telesto 2016-11-25 18:29:10 UTC
Confirming with:
Version: 5.3.0.0.beta1
Build ID: 690f553ecb3efd19143acbf01f3af4e289e94536
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 6 QA Administrators 2017-12-10 16:40:07 UTC Comment hidden (obsolete)
Comment 7 Peter Roelofsen 2017-12-10 20:01:16 UTC
Saving the original file as docx and reopening in 6.0 works for me. The original docx shipped in the zip still misses the text box. Version 5.4 still doesn't display the textbox.

fail: Version: 5.4.1.2
Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
CPU threads: 2; OS: Windows 6.2; UI render: default; 

success: Version: 6.0.0.0.beta1 (x64)
Build ID: 97471ab4eb4db4c487195658631696bb3238656c
CPU threads: 2; OS: Windows 10.0; UI render: GL;
Comment 8 Timur 2021-06-16 11:50:23 UTC

*** This bug has been marked as a duplicate of bug 50097 ***