Bug Hunting Session
Bug 84046 - PRINTING: Linux Libertine G displays on-screen correctly but printing / print preview is wrong (ligatures followed by space)
Summary: PRINTING: Linux Libertine G displays on-screen correctly but printing / print...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-18 14:41 UTC by Peter Gervai
Modified: 2016-10-10 11:43 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Correct display on the left, buggy printing preview on the right of the same text. (246.88 KB, image/png)
2014-09-18 14:41 UTC, Peter Gervai
Details
ZIP containing test ODT and PDF output under LO v3.3-4.3 (115.19 KB, application/zip)
2014-09-28 08:09 UTC, Owen Genat (retired)
Details
PDF containing the same erratic ligature behaviour (13.82 KB, application/pdf)
2014-10-01 12:02 UTC, Peter Gervai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Gervai 2014-09-18 14:41:05 UTC
Created attachment 106503 [details]
Correct display on the left, buggy printing preview on the right of the same text.

Problem description: 
Linux Libertine G (Graphite) displays text w/ ligatures correctly on screen but printing is messed up: ligatures are followed by a very visible interglyph space.

Steps to reproduce:
1. Write anything using Linux Libertine G using ligatures (ff, fi, fj, ...)
2. Display looks okay, print preview as well.
3. CTRL+P, see preview or the actual printing, which is faulty.

Operating System: Debian
Version: 4.3.1.2 release
Comment 1 Peter Gervai 2014-09-18 14:45:33 UTC
This problem exists back to at least 4.1.xx, possibly even further away.
Comment 2 Owen Genat (retired) 2014-09-28 08:09:25 UTC
Created attachment 106990 [details]
ZIP containing test ODT and PDF output under LO v3.3-4.3

Unable to reproduce the issue, as the attached PDFs indicate. Tested under GNU/Linux using:

- v3.3.4.1 OOO330m19 Build: 401
- v3.4.6.2 OOO340m1 Build: 602
- v3.5.7.2 Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b
- v3.6.7.2 Build ID: e183d5b
- v4.0.6.2 Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24
- v4.1.6.2 Build ID: 40ff705089295be5be0aae9b15123f687c05b0a
- v4.2.6.3 Build ID: 3fd416d4c6db7d3204c17ce57a1d70f6e531ee21
- v4.3.2.2 Build ID: edfb5295ba211bd31ad47d0bad0118690f76407d

In all case the text is output as expected.
Comment 3 Owen Genat (retired) 2014-09-28 08:19:43 UTC
Additionally, both File > Page preview and the preview shown under File > Print... show the same behaviour as indicated in the attached PDFs for the versions indicated i.e., expected rendering. Tested using cups-pdf v2.6.1-6 and with a HP LaserJet 4050TN accessed via CUPS / IPP over a network.

It appears this may be a problem related to the particular configuration or printer setup being used. Please provide greater detail about the configuration in use and printer setup. Status set to NEEDINFO. Please set status back to UNCONFIRMED once the request information is provided.
Comment 4 Peter Gervai 2014-10-01 12:01:07 UTC
First I thought it may have been the printer driver (Epson Stylus D78 - CUPS+Gutenprint v5.2.10) but then the output was the same with PDF printing (Generic CUPS-PDF Printer). This is CUPS v1.7.3/Debian/sid.

I attach my PDF which is the same as the print output.

(Libertine O does not possess the problem.)

Please point me to the information you need and I'll gather it. This may be a cups or gutenprint problem but I observe it for quite a while now.
Comment 5 Peter Gervai 2014-10-01 12:02:03 UTC
Created attachment 107185 [details]
PDF containing the same erratic ligature behaviour
Comment 6 Owen Genat (retired) 2014-10-01 16:20:21 UTC
(In reply to comment #4)
> First I thought it may have been the printer driver (Epson Stylus D78 -
> CUPS+Gutenprint v5.2.10) but then the output was the same with PDF printing
> (Generic CUPS-PDF Printer). This is CUPS v1.7.3/Debian/sid.

Peter, I tested using Debian 7 stable (CUPS v1.5.3 with Gutenprint v5.2.9-1). There have been CUPS-related issues in the past and this may be another, but it will require a developer to determine this.
Comment 7 Peter Gervai 2014-10-01 16:40:59 UTC
Thank you very much for the thorough preprocessing! If anyone needs deeper input I'll try to provide them if they specify what's needed.
Comment 8 Peter Gervai 2014-12-08 13:07:05 UTC
Bug is still present in 4.3.3.2 (build 430m0(2)).
Comment 9 tommy27 2015-10-04 13:36:37 UTC
I do not reproduce this under Win8.1 x64 using LibO 4.4.5.2 and an HP PhotoSmart B109a-m printer

did you upgrade to latest LibO 4.4.5.2 or 5.0.2.2 to see if the bug is still present?

which is the exact version number of your current Linux distro?
which is your printer model?

status NEEDINFO

P.S. set version to 4.1 all version since that field has to indicate earlier release you saw the bug (see comment 1)
Comment 10 Xisco Faulí 2016-09-11 20:00:18 UTC Comment hidden (obsolete)
Comment 11 Xisco Faulí 2016-10-10 11:12:07 UTC Comment hidden (obsolete)
Comment 12 Peter Gervai 2016-10-10 11:38:00 UTC
The bug is not present in 1:5.1.5~rc1-1
Comment 13 tommy27 2016-10-10 11:43:18 UTC
thanks Peter for feedback.
so it's RESOLVED WORKSFORME