Bug Hunting Session
Bug 84288 - Slow scrolling after a suspend
Summary: Slow scrolling after a suspend
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.5.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.4.3
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-24 16:26 UTC by Frederic Parrenin
Modified: 2015-08-13 21:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Parrenin 2014-09-24 16:26:05 UTC
On my debian 7 system with LO 4.3.1.2 after a suspend, scrolling an opened document in writer is very slow.
I found this also with previous versions of LO (4.1, 4.2).
The workaround is to resize the window, after which the speed of scrolling becomes normal again.
Might be related to:
https://bugzilla.freedesktop.org/show_bug.cgi?id=34982
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/794900
Comment 1 Joel Madero 2014-09-25 05:18:54 UTC
Version is oldest version that you see the problem, not latest, updating version field. Not confirming problem
Comment 2 Commit Notification 2015-04-03 09:35:19 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7f80b3eb26769143e18806392164aae8c5ad9763&h=libreoffice-4-4

Follow-up tdf#84288: call SetRectangleAttributes only once

It will be available in 4.4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Alex Thurgood 2015-08-13 09:01:02 UTC
Surely this is fixed now and shouldn't be in UNCONFIRMED state ?
Comment 4 Frederic Parrenin 2015-08-13 20:36:33 UTC
Since the time when I have updated my system to debian 8, with LO 4.3.3.2, I did not experience this issue anymore. So maybe we can mark it as fixed?