Bug 84447 - Calc: cell format: Wrap text automatically incompatible with option vertically stacked
Summary: Calc: cell format: Wrap text automatically incompatible with option verticall...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: x86-64 (AMD64) Linux (All)
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-29 04:47 UTC by guarionex
Modified: 2018-08-13 23:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Explains how to reproduce the bug(?) (1.53 KB, text/plain)
2014-10-08 05:12 UTC, guarionex
Details

Note You need to log in before you can comment on or make changes to this bug.
Description guarionex 2014-09-29 04:47:56 UTC
System Ubuntu 14.04. Software: Libre Calc. Problem in command: Format cell> Alignment... If Vertically stacked is selected, then Text alignment defaults to left (?) and the other choices won't work.
Comment 1 guarionex 2014-09-29 04:54:00 UTC
The actual version I'm using is 4.2.6.3
Comment 2 tommy27 2014-09-29 05:32:34 UTC
please upload a test file and screenshots so it will be easier to understand issue and try to reproduce
Comment 3 guarionex 2014-09-29 07:03:18 UTC
Apparently the file became corrupted somehow because I verified that the 
command does work. I tried it in another spreadsheet. In the spreadsheet 
with the problem, I un-merged one of the cells showing the problem 
(there are two vertical cells merged together in the problem cells) and 
was then able to center the text. The other cells are still merged and 
won't change the text from left aligned.

I'm going to decline sending additional info since I found a 
work-around. And since it only happened to that file, and it being a 
minor nuisance, it is not worth the trouble.

Thx


On 09/29/2014 01:32 AM, bugzilla-daemon@freedesktop.org wrote:
> tommy27 <mailto:barta@quipo.it> changed bug 84447 
> <https://bugs.freedesktop.org/show_bug.cgi?id=84447>
> What 	Removed 	Added
> CC 		barta@quipo.it
> Summary 	Formating fails 	Formatting fails
>
> *Comment # 2 <https://bugs.freedesktop.org/show_bug.cgi?id=84447#c2> 
> on bug 84447 <https://bugs.freedesktop.org/show_bug.cgi?id=84447> from 
> tommy27 <mailto:barta@quipo.it> *
> please upload a test file and screenshots so it will be easier to understand
> issue and try to reproduce
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 4 tommy27 2014-09-29 11:39:15 UTC
ok, let's close this as RESOLVED WORKSFORME

feel free to revert status if you find reproducible way to make the bug appear again.
Comment 5 guarionex 2014-10-08 05:12:09 UTC
Created attachment 107533 [details]
Explains how to reproduce the bug(?)
Comment 6 guarionex 2014-10-10 10:10:19 UTC
Here is an explanation of a reproducible problem encountered when trying to align text in a cell: 

Type a short phrase, select format cell... Set the now visible dialog box with the following settings:

1. horizontal alignment  “left” 
2. Vertically stacked box selected
3. Wrap text automatically box selected

Hit  ok in the dialog box … text aligns left

Select format cell.. Set the now visible dialog box with the following settings:

1. horizontal alignment  “Center”  (changed)
2. Vertically stacked box selected (no change)
3. Wrap text automatically box selected (no change)

Hit  ok in the dialog box … nothing happens. The text doesn't get centered... or so it  appears.

Select format cell again.
Unselect “wrap text automatically,” hit ok...
Text becomes centered.

My view of the problem:
When “vertically stacked”, “horizontally centered”  and “wrap test”automatically” are selected, the software is making the best choice it knows under those conditions. So it stack everything to the left.

I propose the following solution: when the user selects (1) “horizontally centered” and (2) “vertically stacked”, the “automatically wrap text” box should become disabled. It should be re-enabled if the user changes choices. If this is not possible to do within the dialog box, then upon closing the dialog under these conditions, the “automatically wrap text” should return “false”. 

I suspect that the  “Wrap text automatically” box should be dissabled if “Vertically stacked” box is selected, i.e., they are mutually exclusive.
Comment 7 guarionex 2014-10-13 15:10:37 UTC
Select the "alignment" tab after selecting format cell.
Comment 8 Buovjaga 2014-11-15 12:20:06 UTC
Reproduced -> NEW enhancement.

Win 7 64-bit Version: 4.4.0.0.alpha2+
Build ID: b021b5983c62e266b82d9f0c5c6d8d8900553827
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-12_01:10:08
Comment 9 Gerhard Weydt 2018-08-13 23:43:47 UTC
The title of this bug ("Formatting fails") is so general that surely no developper will look at it. The first commenters should have noticed that, instead of only commenting.
So I'll change the title to a more precise description of the problem.
Here's  an actual description of the problem: Setting "Text alignment" to other than left and Text Orientaition = "vertically stacked" works well as long as Properties -> Wrap texts automatically is off. If it's on, then alignment at least doesn't work.