Download it now!
Bug 84666 - Application window behind windows explorer
Summary: Application window behind windows explorer
Status: RESOLVED DUPLICATE of bug 48300
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-04 16:59 UTC by Robert Gonzalez MX
Modified: 2015-05-24 02:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Escreenshots and descriptions (1.09 MB, application/vnd.oasis.opendocument.text)
2014-10-04 17:02 UTC, Robert Gonzalez MX
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Gonzalez MX 2014-10-04 16:59:13 UTC
Problem description: 
In the windows explorer, double click in any of the libreoffice files to open it.

The program (writer or any) opens the file, but the window stays behind the windows file explorer window. 

If you double click on a password protected file to open it
then the “Enter password” window opens for a fraction of a second and goes behind the current window.

If you type the password correctly and press enter, the file opens, even if the password window is not present and when typing nothing is visible. 

If you click on the icon of writer (or any other libreoffice application) in the windows task bar  it doesn't bring the window application to become active, click it in again, retains the window behind, as if it were in the front.

Once opened a LibreOffice file, if you open another one, the behavior is like this.

Clicking on other application icon to maximize and minimize, then double click on the libreoffice file, will open it correctly.

Clicking on LibreOffice application icon to maximize and minimize, then double click on the LibreOffice file, will open it behind the active windows explorer, reproducing this bug.

Current behavior:
Opens the file and send the application window behind the windows explorer.

Expected behavior:
It should bring the window application to the front and active for editing.

It seems to be two related bugs 48300 and 49134
I have tested this in win xp and works fine, in win 7 home premium also works fine, only on win 8 and 8.1 in present.
Comment 1 Robert Gonzalez MX 2014-10-04 17:02:36 UTC
Created attachment 107330 [details]
Escreenshots and descriptions
Comment 2 Adolfo Jayme 2014-10-04 17:23:31 UTC
> I have tested this in win xp and works fine, in win 7 home premium also works
>fine, only on win 8 and 8.1 in present.

I’m inclined to close this as NOTOUTBUG then… If you upgrade to 4.3.2 is the behavior different?
Comment 3 Robert Gonzalez MX 2014-10-04 17:57:54 UTC
I have updated to LO 4.3.2.2 when it was released last week, and made the tests since then in different machines that i work with. 3 Win Xp, 1 Win 7, and 2 Win 8.1.

Only in Win 8.1 the problem is present.

I noticed this problem since Lo 4.2.0. Don't know if it was present in earlier version. My laptop had Win 8 and the problem was present almost a year, then updated to 8.1 a month ago and the problem still is present. Due to other bug reports that I have made, I have refreshed user profiles and testing those, this problem was present.


So i think that this case should be revised and not closed.
Comment 4 Adolfo Jayme 2014-10-04 21:05:24 UTC
Thanks! I can indeed reproduce the problem in Windows 8.1 in 4.4. Marking this “NEW”.
Comment 5 Robert Gonzalez MX 2015-05-24 02:20:20 UTC

*** This bug has been marked as a duplicate of bug 48300 ***