Download it now!
Bug 84680 - FILEOPEN: paragraph spacing below ignored in tables in DOCX
Summary: FILEOPEN: paragraph spacing below ignored in tables in DOCX
Status: RESOLVED DUPLICATE of bug 117297
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2014-10-05 08:24 UTC by Luke
Modified: 2018-07-20 05:01 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Simple DOCX showing problem with line spacing below in tables (11.73 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-10-05 08:25 UTC, Luke
Details
Comparision of Word vs Writer (110.97 KB, image/png)
2014-10-05 08:29 UTC, Luke
Details
More advanced example with the line missing from paragraph style (11.83 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-10-05 08:40 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2014-10-05 08:24:19 UTC
Steps to reproduce:
1. Create a table in Word with spacing below
2. Save
3. Open with Writer

Expected results:
Writer import a table with spacing below the text

Actual results:
Writer imports table with Paragraph->Indent&Spacing->Spacing->Below Paragraph:0
Comment 1 Luke 2014-10-05 08:25:14 UTC
Created attachment 107348 [details]
Simple DOCX showing problem with line spacing below in tables
Comment 2 Luke 2014-10-05 08:29:32 UTC
Created attachment 107349 [details]
Comparision of Word vs Writer
Comment 3 Luke 2014-10-05 08:40:51 UTC
Created attachment 107350 [details]
More advanced example with the line missing from paragraph style

The line is missing whether the spacing comes directly or via a style
Comment 4 tommy27 2014-10-07 20:28:05 UTC
I see same issue in OOo 3.3.0, LibO 4.3.2 and 4.4master and AOO 4.1.0
status NEW. bug inherited from OOo
Comment 5 Luke 2014-10-10 17:42:13 UTC
Added Miklos as he's a rockstar and just fixed a RTF variant of this bug, Bug 84679.
Comment 6 QA Administrators 2015-10-14 19:57:35 UTC Comment hidden (obsolete)
Comment 7 Luke 2015-10-14 20:42:04 UTC
Version: 5.1.0.0.alpha1+
Build ID: f830600ece806ec365a4839e79afabe183c5e36d

Is still ignoring the Below Paragraph attribute, always resetting it to 0.
Comment 8 Robinson Tryon (qubit) 2015-12-09 18:45:01 UTC Comment hidden (no-value, obsolete)
Comment 9 QA Administrators 2017-12-08 08:07:16 UTC Comment hidden (obsolete)
Comment 10 Luke 2017-12-08 16:44:23 UTC
Still repo on Version: 6.1.0.0.alpha0+ (x64)
Build ID: eff70347190a6642fd62a9e0b20e4366c39fbc7a
Comment 11 Luke 2018-07-17 20:40:15 UTC
The basic direct formatting issue was resolved between:
Version: 6.1.0.0.alpha1+ (x64)
Build ID: 23c5125148a8110d88385b29570bf0b7d4400458


Version: 6.2.0.0.alpha0+
Build ID: 4bb893596abfcb55fb607445a64456e054944c73

The example using styles was filed as a new issue, Bug 118812
Comment 12 Luke 2018-07-20 05:01:48 UTC
The direct formatting issue was fixed by: https://cgit.freedesktop.org/libreoffice/core/commit/?id=5e4d89f59614cec08376e1e77625f8610a1490e5

tdf#117297 sw unotbl XCell: apply char/para style props to text


Thanks Justin!

*** This bug has been marked as a duplicate of bug 117297 ***