Download it now!
Bug 84681 - line across page is below cursor, should be above, and is generated twice
Summary: line across page is below cursor, should be above, and is generated twice
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.6.3 release
Hardware: Other All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2014-10-05 08:44 UTC by Toby
Modified: 2015-12-15 11:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot showing current behaviour (54.50 KB, image/jpg)
2014-10-05 08:44 UTC, Toby
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toby 2014-10-05 08:44:05 UTC
Created attachment 107351 [details]
screenshot showing current behaviour

Problem description: 
If I create a line across the page then press return, the line is repeated and is below the text, not above it

Steps to reproduce:
1. Start a new writer document
2. Type "line1" + return
3. Type "---" + return
4. Type "line2" + return

Current behavior:
Two lines are drawn under "line2"

Expected behavior:
One line is drawn above "line2"
Comment 1 Tim Lloyd 2014-10-06 04:44:43 UTC
confirmed 4.3.2.2 Fedora 21

Pressing ENTER anywhere on "line2" causes the line underneath to be duplicated.
Comment 2 ign_christian 2014-10-06 05:08:56 UTC
Also reproduced with LO 4.2.6.3 portable - Win7 x86

Not reproduced with LO 4.1.6.2 portable, 4.0.6.2
Comment 3 Matthew Francis 2014-12-17 07:05:15 UTC
Bibisect results from 43all:

4f705a8cfb1998b09f2062510b207d35a33647d8 is the first bad commit
commit 4f705a8cfb1998b09f2062510b207d35a33647d8
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Sun May 11 23:40:18 2014 +0000

    source-hash-1eeb20f3958666ec6ba6e0fcf52e92e5eb447a14
    
    commit 1eeb20f3958666ec6ba6e0fcf52e92e5eb447a14
    Author:     Caolán McNamara <caolanm@redhat.com>
    AuthorDate: Thu Mar 13 10:02:45 2014 +0000
    Commit:     Caolán McNamara <caolanm@redhat.com>
    CommitDate: Thu Mar 13 11:18:37 2014 +0000
    
        CurrencyFields cannot be loaded from .src anymore
    
        Change-Id: I3ccdb71e39a13dc8c697d3a52dc693cff10c614d

# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [752769ad0d2179e17ea0a08cc9004df7b890305b] source-hash-60c64b437c6678dd1d3fa3a6fc2b7da0480890d4
git bisect start 'latest' 'last42onmaster'
# good: [4fcd68ce4979f85fda4568f4b419a4b41d07345f] source-hash-2c4621c87ed3a7b19de195c21494c9a381e72b2e
git bisect good 4fcd68ce4979f85fda4568f4b419a4b41d07345f
# skip: [422186458e0b4db00c7e26b54d5b631f83bcad2a] source-hash-6948bf58ce181b17f60ef81f10205ef4dac50cc6
git bisect skip 422186458e0b4db00c7e26b54d5b631f83bcad2a
# bad: [a0b33bffff9c787dce71a13b344f06ae1453026b] source-hash-02e0be069e57e724c51f23e2e31b77657a6a1d3d
git bisect bad a0b33bffff9c787dce71a13b344f06ae1453026b
# bad: [db29eee512d03b1dc0139b3752bbe7931b165377] source-hash-77b6c1602aaa0bd059077765e7fabb53d9e6ddeb
git bisect bad db29eee512d03b1dc0139b3752bbe7931b165377
# good: [0b79394752f7ecbab6ab4ecedbfab8551c6e9fbd] source-hash-381613916d42a1e18e2824b5d41028dcfe19659a
git bisect good 0b79394752f7ecbab6ab4ecedbfab8551c6e9fbd
# bad: [4f705a8cfb1998b09f2062510b207d35a33647d8] source-hash-1eeb20f3958666ec6ba6e0fcf52e92e5eb447a14
git bisect bad 4f705a8cfb1998b09f2062510b207d35a33647d8
# good: [3dda83fc3a43afc6af7f5c0ffd029e610ec1b9a3] source-hash-c59b3d6c5c8096486730007d9b9b053793b90b1e
git bisect good 3dda83fc3a43afc6af7f5c0ffd029e610ec1b9a3
# good: [6d436a9d8ec82d3192b51a63551bc4640634402d] source-hash-50d20866aa90150680e6d39998081fc148638c73
git bisect good 6d436a9d8ec82d3192b51a63551bc4640634402d
# first bad commit: [4f705a8cfb1998b09f2062510b207d35a33647d8] source-hash-1eeb20f3958666ec6ba6e0fcf52e92e5eb447a14
Comment 4 Matthew Francis 2014-12-27 12:27:11 UTC
This behaviour seems to have changed at the below commit.
(Note: bug 87400 may prevent reproduction in dbgutil builds)

Adding Cc: vmiklos@collabora.co.uk. Could you possibly have a look at this? Thanks


commit f9b62506b22c3eb885ffd5a4ec8025c33df7b2d4
Author: Miklos Vajna <vmiklos@collabora.co.uk>
Date:   Wed Mar 12 17:28:10 2014 +0100

    fdo#75110 SwEditShell::DeleteSel fix start of selection when bSelAll == true
    
    Change-Id: I3e8ce585b29619061b18ab1ab8f0cf6c7d421074
Comment 5 Gordo 2015-05-03 13:21:34 UTC
Could not reproduce.

Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16

Still reproducible in 4.3.6.2.

Changed to RESOLVED WORKSFORME.
Comment 6 Robinson Tryon (qubit) 2015-12-15 11:03:18 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]