Bug 84696 - Wrong alignment of cell content
Summary: Wrong alignment of cell content
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-05 20:08 UTC by ds2
Modified: 2017-10-20 22:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Textalignment 4.2 vs. 4.3 (35.31 KB, image/png)
2014-10-05 20:08 UTC, ds2
Details
Testdocument to show content alignment (8.42 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-10-06 10:29 UTC, ds2
Details
bottom edge of text is cut off in edit mode (13.17 KB, image/png)
2014-10-26 17:52 UTC, jaimes
Details
bottom edge NOT cut off in edit mode (13.17 KB, image/png)
2014-10-26 17:54 UTC, jaimes
Details
text cut off when NOT in edit mode (11.87 KB, image/png)
2014-10-26 17:56 UTC, jaimes
Details
Rendering in 6.0.0.0 alpha (15.97 KB, image/png)
2017-10-20 22:00 UTC, eisa01
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ds2 2014-10-05 20:08:04 UTC
Created attachment 107379 [details]
Textalignment 4.2 vs. 4.3

Cell content is aligned lower than in 4.2 versions, see screenshots.
Comment 1 m.a.riosv 2014-10-05 23:25:40 UTC Comment hidden (obsolete)
Comment 2 ds2 2014-10-06 10:28:57 UTC
I've added a document as requested. I've noticed, the the alignment depends on the zoom-factor: the more you zoom in, the higher gets the content.
Comment 3 ds2 2014-10-06 10:29:56 UTC
Created attachment 107416 [details]
Testdocument to show content alignment
Comment 4 Alex Thurgood 2014-10-06 11:45:23 UTC
I see no noticeable difference with test document, even at 400% zoom, between LO 4242, 4332 and LO 440 alpha master build on OSX 10.9.5
Comment 5 m.a.riosv 2014-10-06 19:14:11 UTC
I can confirm Alex comment with Win7.
Maybe screen resolution has some influence.
Comment 6 ds2 2014-10-08 15:15:22 UTC
@Alex: please try a lower zoom (100%) - using 140% and more changes the alignment!

@m.a.riosv: This problem occurs on 2 Macs with different resolutions: Mac mini, OS X 10.9.5 with 1920x1080 and a MacBook Air, OS X 10.10 (beta 5), 1440x something...

I've made a screenshot to ensure, that the changed alignment is visible.
Comment 7 Alex Thurgood 2014-10-17 14:17:47 UTC
(In reply to ds2 from comment #6)
> @Alex: please try a lower zoom (100%) - using 140% and more changes the
> alignment!
> 
> @m.a.riosv: This problem occurs on 2 Macs with different resolutions: Mac
> mini, OS X 10.9.5 with 1920x1080 and a MacBook Air, OS X 10.10 (beta 5),
> 1440x something...
> 
> I've made a screenshot to ensure, that the changed alignment is visible.

What I implied is that I tested this at all degrees of zoom and saw no noticeable difference, I started at 100% and moved up to 400%, the moved back down to where I couldn't even read the text anymore.
Comment 8 ds2 2014-10-19 12:55:29 UTC
Anything I can do to proof the problem?
Comment 9 oscar valenzuela 2014-10-26 17:28:25 UTC
Confirmed in LibreOfficeDev 4.4.0.0 alpha1 for MacOS 10.10 (Yosemite) x86-64
Comment 10 jaimes 2014-10-26 17:52:43 UTC
Created attachment 108463 [details]
bottom edge of text is cut off in edit mode
Comment 11 jaimes 2014-10-26 17:54:47 UTC
Created attachment 108464 [details]
bottom edge NOT cut off in edit mode
Comment 12 jaimes 2014-10-26 17:56:06 UTC
Created attachment 108465 [details]
text cut off when NOT in edit mode
Comment 13 QA Administrators 2015-12-20 16:18:46 UTC Comment hidden (obsolete)
Comment 14 QA Administrators 2017-01-03 19:50:15 UTC Comment hidden (obsolete)
Comment 15 eisa01 2017-10-20 22:00:54 UTC
Created attachment 137170 [details]
Rendering in 6.0.0.0 alpha
Comment 16 eisa01 2017-10-20 22:01:58 UTC
This seems fine to me in 6.0.0.0 alpha. I added a picture with fffff in the next cell