Bug Hunting Session
Bug 84705 - FILEOPEN: loading a LibO Writer document with OLE objects also opens PhotoShop
Summary: FILEOPEN: loading a LibO Writer document with OLE objects also opens PhotoShop
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.5.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-06 08:02 UTC by Iker
Modified: 2015-10-14 19:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Photoshop test file (137.54 KB, image/vnd.adobe.photoshop)
2014-10-07 12:25 UTC, Iker
Details
test file with Photoshop ole object (170.87 KB, application/vnd.oasis.opendocument.text)
2014-10-07 12:30 UTC, Iker
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Iker 2014-10-06 08:02:20 UTC
Problem description: 

Open writer document with ole object (photoshop cs v8)automatically opened photoshop.  

Steps to reproduce:
1. Open writer
2. insert ole object (adobe phostoshop version 8) 
3. save and close document
4. When the document is opened so does photoshop

This does not happen with other Libreoffice applications (calc, impress)
              
Operating System: Windows XP
Version: 4.1.5.3 release
Comment 1 tommy27 2014-10-06 18:09:32 UTC
have you tried upgrading to LibO 4.2.6.2?
the 4.1.5 release you are using is END-OF-LIFE and is no longer supported.
please upgrade and retest.
Comment 2 Iker 2014-10-07 09:33:04 UTC
(In reply to tommy27 from comment #1)
> have you tried upgrading to LibO 4.2.6.2?
> the 4.1.5 release you are using is END-OF-LIFE and is no longer supported.
> please upgrade and retest.

Thanks, 
I have the same problem in a lot of versions of openoffice and libreOffice , inclusive  4.3.2 version .

But following your recommendations I installed the version 4.2.6.3 with the same results
Comment 3 tommy27 2014-10-07 10:03:47 UTC
ok, so please upload a test file with an adobe phostoshop version 8 OLE object.
Comment 4 Iker 2014-10-07 12:25:34 UTC
Created attachment 107487 [details]
Photoshop test file
Comment 5 Iker 2014-10-07 12:30:32 UTC
Created attachment 107488 [details]
test file with Photoshop ole object
Comment 6 jaimes 2014-10-28 19:06:03 UTC
(In reply to Iker from comment #0)
> Problem description: 
> 
> Open writer document with ole object (photoshop cs v8)automatically opened
> photoshop.  
> 
> Steps to reproduce:
> 1. Open writer
 Opened attached sample file
> 4. When the document is opened so does photoshop

Operating System: Windows 7

Photoshop opened when opening the file in LO Writer *as well* as when attempting to open with file with Microsoft Word. Digging in to Adobe settings to see if that is the cause. Sorry to be brief - on a borrowed machine. I will update as soon as I have more information.
Comment 7 tommy27 2015-03-07 09:22:20 UTC
so basically this seems PhotoShop's fault since the same issue is reported when loading the file with MS Word

@jaimes
do you have more info about this?
is still happening with recent LibO 4.4.1.2?

I set status to NEEDINFO waiting for feedback
Comment 8 QA Administrators 2015-09-04 02:55:38 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

This NEEDINFO message was generated on: 2015-09-03
Comment 9 QA Administrators 2015-10-14 19:48:33 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and a lack of information which is needed in order to accurately reproduce and confirm the problem. We encourage you to retest your bug against the latest release. If the issue is still present in the latest stable release, we need the following information (please ignore any that you've already provided):

a) Provide details of your system including your operating system and the latest version of LibreOffice that you have confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED and we will attempt to reproduce the issue. 
Please do not:
a) respond via email 
b) update the version field in the bug or any of the other details on the top section of FDO

Message generated on: 2015-10-14