Bug 84733 - FILEOPEN: ODT - Opening file returns 'Read-Error. Error reading file.' dialog
Summary: FILEOPEN: ODT - Opening file returns 'Read-Error. Error reading file.' dialog
Status: RESOLVED DUPLICATE of bug 84692
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: odf
Keywords: bibisected, filter:odt, regression
Depends on:
Blocks:
 
Reported: 2014-10-07 03:13 UTC by Yousuf Philips (jay) (retired)
Modified: 2015-12-17 05:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-10-07 03:13:23 UTC
This is confirmation of bug 77855 comment 6, that opening attachment 98036 [details] in master causes a 'Read-Error. Error reading file.' dialog to appear.

Version: 4.4.0.0.alpha0+
Build ID: ced24ffba2fa1754c466b7944b0ee06d21292706
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-10-04_21:36:54

The file opens fine in 4.3 daily.

Version: 4.3.3.0.0+
Build ID: 18b9cb260a5ec358f6a7b73362bbc306af0417b1
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:libreoffice-4-3, Time: 2014-10-04_04:41:44
Comment 1 Terrence Enger 2014-10-08 18:32:56 UTC
Within the daily dbgutil bibisect repo, I see:
from `git bisect skip`:

    There are only 'skip'ped commits left to test.
    The first bad commit could be any of:
    aa277ae886d6e38dad4a356ebd6a1d6c96f5f084
    eb37477c7906b4c4b7eb11433c7566f669a040d1
    ee4cabf0a220e5a25fa856372775e2e3217382d5
    8c3f4fcfdbbd570efea0a46c219eab24fd5db44c
    8c6b7757633a62914d5e6ae6d85ea88eed689c77
    329f284cf0438c52859ca4facd4f4950594352e1
    a5750a3c0c5d3b975a787f844d7ba60db53a765e
    b195929c45dca218e941073bcb5bcaa92d21d7f7
    cbed87a20815ddd7af3afb31aa2fc7a29383ce89
    479f8e7126777715c2ce39bb89483b88696f747e
    d435a3233c58183c13ccf8efee43e48039a235cf
    0202d213f4018a42c883fa125456b39400ae1161
    14df9828a18e82c76c275e74351d6fca8f015c55
    1dac241a2ef32bee2621f7c6010cc321b39d897f
    3c19bff344aa6109cdd40e5ab4986a95ecdd7542
    b7ea5ebd0e0fee42d8971dd75b8efbc6e0e47739
    bca75fd8eecde09d2d2cf960b64a056c42b1ac51
    5ca6ec5035fe8ea076f0e64de7346c6037e573e2
    We cannot bisect more!

and from `git bisect log`:

    # bad: [ad81c51cf7146ff34cb5a964236160022425b540] 2014-10-08
    # good: [b3130c846de5cf1b4be48b48dfc780bb369549fa] 2014-05-21
    git bisect start 'origin/master' 'oldest'
    # bad: [c32292e81bddf91ec4c0996f547c010a86231b7f] 2014-07-30
    git bisect bad c32292e81bddf91ec4c0996f547c010a86231b7f
    # good: [402ad27d59e542f8ff5fc88c4ffa74613a3cadfc] 2014-06-24
    git bisect good 402ad27d59e542f8ff5fc88c4ffa74613a3cadfc
    # skip: [eb37477c7906b4c4b7eb11433c7566f669a040d1] 2014-07-11
    git bisect skip eb37477c7906b4c4b7eb11433c7566f669a040d1
    # skip: [8c3f4fcfdbbd570efea0a46c219eab24fd5db44c] 2014-07-12
    git bisect skip 8c3f4fcfdbbd570efea0a46c219eab24fd5db44c
    # good: [3d23bb692193efbb9acc47d7d1c12361b78fb164] 2014-06-25
    git bisect good 3d23bb692193efbb9acc47d7d1c12361b78fb164
    # skip: [b195929c45dca218e941073bcb5bcaa92d21d7f7] 2014-07-06
    git bisect skip b195929c45dca218e941073bcb5bcaa92d21d7f7
    # good: [0f33e70e503bddcb7eb9c462407c9cda6d3e3a14] 2014-06-27
    git bisect good 0f33e70e503bddcb7eb9c462407c9cda6d3e3a14
    # skip: [a5750a3c0c5d3b975a787f844d7ba60db53a765e] 2014-07-13
    git bisect skip a5750a3c0c5d3b975a787f844d7ba60db53a765e
    # skip: [8c6b7757633a62914d5e6ae6d85ea88eed689c77] 2014-07-08
    git bisect skip 8c6b7757633a62914d5e6ae6d85ea88eed689c77
    # bad: [e5e8ff133f210925dc4dedb018fd216b70aaaaaf] 2014-07-27
    git bisect bad e5e8ff133f210925dc4dedb018fd216b70aaaaaf
    # skip: [0202d213f4018a42c883fa125456b39400ae1161] 2014-07-16
    git bisect skip 0202d213f4018a42c883fa125456b39400ae1161
    # bad: [78882e6831ce98a1b061c9656b4fc3565cfa2e04] 2014-07-24
    git bisect bad 78882e6831ce98a1b061c9656b4fc3565cfa2e04
    # skip: [aa277ae886d6e38dad4a356ebd6a1d6c96f5f084] 2014-07-10
    git bisect skip aa277ae886d6e38dad4a356ebd6a1d6c96f5f084
    # bad: [2b0304ea2fa4675aecc3d9c617dc1daa774cdff8] 2014-07-20
    git bisect bad 2b0304ea2fa4675aecc3d9c617dc1daa774cdff8
    # skip: [329f284cf0438c52859ca4facd4f4950594352e1] 2014-07-07
    git bisect skip 329f284cf0438c52859ca4facd4f4950594352e1
    # skip: [1dac241a2ef32bee2621f7c6010cc321b39d897f] 2014-07-17
    git bisect skip 1dac241a2ef32bee2621f7c6010cc321b39d897f
    # skip: [ee4cabf0a220e5a25fa856372775e2e3217382d5] 2014-07-09
    git bisect skip ee4cabf0a220e5a25fa856372775e2e3217382d5
    # good: [51d0b5cdc80ce7b0a3e0694e91547d3e7942f19f] 2014-07-01
    git bisect good 51d0b5cdc80ce7b0a3e0694e91547d3e7942f19f
    # skip: [14df9828a18e82c76c275e74351d6fca8f015c55] 2014-07-04
    git bisect skip 14df9828a18e82c76c275e74351d6fca8f015c55
    # skip: [cbed87a20815ddd7af3afb31aa2fc7a29383ce89] 2014-07-14
    git bisect skip cbed87a20815ddd7af3afb31aa2fc7a29383ce89
    # skip: [bca75fd8eecde09d2d2cf960b64a056c42b1ac51] 2014-07-18
    git bisect skip bca75fd8eecde09d2d2cf960b64a056c42b1ac51
    # skip: [d435a3233c58183c13ccf8efee43e48039a235cf] 2014-07-15
    git bisect skip d435a3233c58183c13ccf8efee43e48039a235cf
    # skip: [3c19bff344aa6109cdd40e5ab4986a95ecdd7542] 2014-07-03
    git bisect skip 3c19bff344aa6109cdd40e5ab4986a95ecdd7542
    # skip: [479f8e7126777715c2ce39bb89483b88696f747e] 2014-07-05
    git bisect skip 479f8e7126777715c2ce39bb89483b88696f747e
    # bad: [5ca6ec5035fe8ea076f0e64de7346c6037e573e2] 2014-07-19
    git bisect bad 5ca6ec5035fe8ea076f0e64de7346c6037e573e2
    # skip: [b7ea5ebd0e0fee42d8971dd75b8efbc6e0e47739] 2014-07-02
    git bisect skip b7ea5ebd0e0fee42d8971dd75b8efbc6e0e47739
    # only skipped commits left to test
    # possible first bad commit: [5ca6ec5035fe8ea076f0e64de7346c6037e573e2] 2014-07-19
    # possible first bad commit: [bca75fd8eecde09d2d2cf960b64a056c42b1ac51] 2014-07-18
    # possible first bad commit: [1dac241a2ef32bee2621f7c6010cc321b39d897f] 2014-07-17
    # possible first bad commit: [0202d213f4018a42c883fa125456b39400ae1161] 2014-07-16
    # possible first bad commit: [d435a3233c58183c13ccf8efee43e48039a235cf] 2014-07-15
    # possible first bad commit: [cbed87a20815ddd7af3afb31aa2fc7a29383ce89] 2014-07-14
    # possible first bad commit: [a5750a3c0c5d3b975a787f844d7ba60db53a765e] 2014-07-13
    # possible first bad commit: [8c3f4fcfdbbd570efea0a46c219eab24fd5db44c] 2014-07-12
    # possible first bad commit: [eb37477c7906b4c4b7eb11433c7566f669a040d1] 2014-07-11
    # possible first bad commit: [aa277ae886d6e38dad4a356ebd6a1d6c96f5f084] 2014-07-10
    # possible first bad commit: [ee4cabf0a220e5a25fa856372775e2e3217382d5] 2014-07-09
    # possible first bad commit: [8c6b7757633a62914d5e6ae6d85ea88eed689c77] 2014-07-08
    # possible first bad commit: [329f284cf0438c52859ca4facd4f4950594352e1] 2014-07-07
    # possible first bad commit: [b195929c45dca218e941073bcb5bcaa92d21d7f7] 2014-07-06
    # possible first bad commit: [479f8e7126777715c2ce39bb89483b88696f747e] 2014-07-05
    # possible first bad commit: [14df9828a18e82c76c275e74351d6fca8f015c55] 2014-07-04
    # possible first bad commit: [3c19bff344aa6109cdd40e5ab4986a95ecdd7542] 2014-07-03
    # possible first bad commit: [b7ea5ebd0e0fee42d8971dd75b8efbc6e0e47739] 2014-07-02


I do not know if this helps, but the terminal output from daily
dbgutil version 2014-10-08, after I opened the file from the command
line, is:

    tester@debian-wheezy:/nb/downloads_libreoffice64/lo-daily_20141008$ opt/program/soffice --norestore ~/lo_hacking/notes/bug_08xxxx/bug_084733/How_to_license_the_operating_system_Windows_8_new\ \[odt\].odt 
    \Gtk-Message: Failed to load module "canberra-gtk-module"
    Gtk-Message: Failed to load module "canberra-gtk-module"
    warn:legacy.osl:6598:1:xmloff/source/core/xmlerror.cxx:180: An error or a warning has occurred during XML import/export!
    Error-Id: 0x10020002
        Flags: 1 WARNING
        Class: 2 FORMAT
        Number: 2
    Parameters:
        0: style:wrap
        1: biggest
    Exception-Message: 
    Position:
        Public Identifier: 
        System Identifier: 
        Row, Column: 319,3

    warn:legacy.osl:6598:1:sw/source/filter/xml/swxml.cxx:268: uno exception caught while importing:
    Unknown property: TabStopDistance

Terry.
Comment 2 Björn Michaelsen 2014-10-14 01:04:16 UTC
Hmm, does the dbgutil repo not have any source-code hashes as tags? that would be really helpful ...
Comment 3 Terrence Enger 2014-10-14 02:37:17 UTC
Each version in the dbgutil repository has a file build-info.txt,
which looks like the output from `git log -10` in the source
repository.  Taking the first commit id in that file as the source
hash, I get:

    test  version     commit   source-hash
    ----  ----------  -------  -----------
    good  2014-07-01  51d0b5c  88bd199 
    skip  2014-07-02  b7ea5eb  4f90623
    ...
    skip  2014-07-18  bca75fd  4011b74
    bad   2014-07-19  5ca6ec5  4aa9b04


The terminal message in the "skip" versions is (line break added):

    terminate called after throwing an instance of
        'com::sun::star::beans::UnknownPropertyException'
Comment 4 Michael Stahl (CIB) 2014-11-10 21:33:39 UTC
was fixed by commit 6cee94ba6b224399e5a4a2511df39d3118454c83

*** This bug has been marked as a duplicate of bug 84692 ***
Comment 5 Robinson Tryon (qubit) 2015-12-17 05:56:46 UTC
Migrating Whiteboard tags to Keywords: (bibisected, filter:odt)
[NinjaEdit]