Download it now!
Bug 84742 - Basic runtime error '51' Internal error
Summary: Basic runtime error '51' Internal error
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2014-10-07 09:54 UTC by marco.morandini
Modified: 2019-01-11 08:22 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
The file triggering the bug (85.50 KB, application/vnd.ms-excel)
2014-10-07 09:54 UTC, marco.morandini
Details
console bt (16.45 KB, text/plain)
2014-10-07 21:10 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description marco.morandini 2014-10-07 09:54:50 UTC
Created attachment 107465 [details]
The file triggering the bug

Steps to reproduce:
1. Open the document, allow macros

Current behavior:
Internal error

Expected behavior:
A working macro, or a different error
Comment 1 Julien Nabet 2014-10-07 21:09:34 UTC
On pc Debian x86-64 with LO 4.3.2.2.0+ Debian package, I could reproduce this.
Comment 2 Julien Nabet 2014-10-07 21:10:30 UTC
Created attachment 107526 [details]
console bt

On pc Debian x86-64 with master sources updated today, I even had a crash (might be related since with 4.3 sources updated yesterday, I had also a crash, however didn't check if it was the same bt).
Comment 3 Julien Nabet 2014-10-07 21:11:22 UTC
Noel: one for you? (bt shows vbahelper part)
Comment 4 Julien Nabet 2015-11-08 22:01:08 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.

After some investigation, the problem seems here:
#0  0x00002aaacfb50fe8 in ScDataPilotTablesObj::hasByName(rtl::OUString const&) (this=0x361de90, aName="Tabella_pivot")
    at /home/julien/compile-libreoffice/libreoffice/sc/source/ui/unoobj/dapiuno.cxx:568
#1  0x00002aaacfb4fc85 in ScDataPilotTablesObj::GetObjectByName_Impl(rtl::OUString const&) (this=0x361de90, rName="Tabella_pivot")
    at /home/julien/compile-libreoffice/libreoffice/sc/source/ui/unoobj/dapiuno.cxx:342
#2  0x00002aaacfb50c01 in ScDataPilotTablesObj::getByName(rtl::OUString const&) (this=0x361de90, aName="Tabella_pivot")
    at /home/julien/compile-libreoffice/libreoffice/sc/source/ui/unoobj/dapiuno.cxx:513
#3  0x00002aaadb752ca0 in ScVbaCollectionBase<cppu::WeakImplHelper<ooo::vba::excel::XPivotTables> >::getItemByStringIndex(rtl::OUString const&) (this=0x35f2800, sIndex="Tabella_pivot") at /home/julien/compile-libreoffice/libreoffice/include/vbahelper/vbacollectionimpl.hxx:253
#4  0x00002aaadb7531dc in ScVbaCollectionBase<cppu::WeakImplHelper<ooo::vba::excel::XPivotTables> >::Item(com::sun::star::uno::Any const&, com::sun::star::uno::Any const&) (this=0x35f2800, Index1=uno::Any "Tabella_pivot") at /home/julien/compile-libreoffice/libreoffice/include/vbahelper/vbacollectionimpl.hxx:301
#5  0x00002aaadb7c76f0 in ScVbaWorksheet::PivotTables(com::sun::star::uno::Any const&) (this=0x2f7f980, Index=uno::Any "Tabella_pivot")
    at /home/julien/compile-libreoffice/libreoffice/sc/source/ui/vba/vbaworksheet.cxx:762

pColl is empty, so ScDataPilotTablesObj::hasByName returns false
ScDataPilotTablesObj::GetObjectByName_Impl returns 0
ScDataPilotTablesObj::getByName throws NoSuchElementException()
Comment 5 QA Administrators 2017-01-03 19:35:00 UTC Comment hidden (obsolete)
Comment 6 marco.morandini 2017-01-09 09:24:56 UTC
I confirn that the bug is still present, same behavior. 

OpenSuse Leap 42.2

LibreOffice Version: 5.2.3.3
Build ID: d54a8868f08a7b39642414cf2c8ef2f228f780cf
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: CL
Comment 7 Julien Nabet 2017-01-09 09:45:11 UTC
Thank you Marco for your feedback.
(Version must correspond to the earliest one, so I reverted back version).
Comment 8 QA Administrators 2018-01-10 03:32:10 UTC Comment hidden (obsolete)
Comment 9 marco.morandini 2018-01-10 08:54:40 UTC
I confirm that the bug is still present.

Version: 5.4.4.2
Build ID: 2524958677847fb3bb44820e40380acbe820f960
CPU threads: 8; OS: Linux 4.4; UI render: default; VCL: kde4; 
Locale: en-US (en_US.UTF-8); Calc: CL
Comment 10 QA Administrators 2019-01-11 03:54:39 UTC Comment hidden (obsolete)
Comment 11 Julien Nabet 2019-01-11 08:22:56 UTC
Marco: I suppose it works now with a recent LO version.
Since there's no specific fix, let's put this one to WFM then.