Bug Hunting Session
Bug 84857 - Enhancement: Export to PDF toolbar print button, or its dialog, should offer the same support as print output dialogs from the components, e.g. Impress multi-slide Handouts
Summary: Enhancement: Export to PDF toolbar print button, or its dialog, should offer ...
Status: RESOLVED DUPLICATE of bug 45498
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: Other All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-10 06:05 UTC by Ljiljan
Modified: 2015-07-30 21:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ljiljan 2014-10-10 06:05:07 UTC
Enhancment description: 

Current export options allow only exporting 1 slide per page. Most often, when sharing files with others in PDF, I export two slides per page. This option is only available through Generic PDF printer.  

My suggestion:

Add button to standard toolbar which will allow "export directly to PDF" with following options "2 slides per page", "3 slides per page", "4 slides per page". 

In export dialog such option should be available as well.              
Operating System: All
Version: 4.3.2.2 release
Comment 1 V Stuart Foote 2014-10-10 15:26:30 UTC
This is trivially done already with the print dialog selecting slide Handouts and sending to a PDF generator, i.e. Adobe Distiller, or a GS based work alike (I prefer GS driven CutePDF), or even as direct GhostScript print output.

The "Export Directly as PDF" button on the Standard toolbar runs the PDF export with its default settings. As noted the general purpose "Export as PDF" options dialog is generic. It does not provide special handling of features unique to a particular module--Impress in this case. 

IMHO the work required to refactor the PDF export to handle features from components simply can not be justified.

Especially as the LibreOffice print routines, not the PDF export routines, already provide robust handling of features found in the components.

Setting as a NEW enhancement, but suggest this should be closed WONTFIX.
Comment 2 Ljiljan 2014-10-10 17:42:33 UTC
As I mentioned in my post, this can be done with Printing dialog... but this is really slow process. Consider the following:

- Each time I decided to export something, I need to change all settings (since Print dialog does not remember that I selected Hangouts or any other option)
- In case I use "Generic PDF Printer" in Ubuntu 14.04, there is need to change Printer Properties (Printer Language Type to be set up as PDF, not PS). I didn't manage to change this option for the system in general. 
- "Print to File" option should be selected.

There are so many steps in order to print hangouts. 

In any case, this option is something that most people will find useful... much more that some other toolbar buttons.
Comment 3 V Stuart Foote 2014-10-10 19:13:58 UTC
Setting component to UX-advise--from Printing and PDF export--can be moved back after discussion.

Realistically, PDF Export does need attention to handle other issues. But the major refactoring needed to bring the Export to PDF to parity with Print filters would need concerted development effort, perhaps as a LibreOffice 5.0.0 target.

Absent agreement to do that, I would move to set WONTFIX.
Comment 4 Cor Nouws 2015-07-30 21:42:25 UTC
Hi Ljiljan

This is also reported in https://bugs.documentfoundation.org/show_bug.cgi?id=45498

*** This bug has been marked as a duplicate of bug 45498 ***