Download it now!
Bug 84882 - EDITING: Report-Builder: Chart with date doesn't differ date-values
Summary: EDITING: Report-Builder: Chart with date doesn't differ date-values
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.0.5.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-10 20:11 UTC by Robert Großkopf
Modified: 2016-03-05 17:04 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Open the report - should show two charts with date as x-axis, but doesn't (62.59 KB, application/vnd.oasis.opendocument.base)
2014-10-10 20:11 UTC, Robert Großkopf
Details
Right chart shown in LO 3.3 (23.65 KB, application/pdf)
2014-10-10 20:12 UTC, Robert Großkopf
Details
No x/y-chart recognized by LO 3.4 (24.40 KB, application/pdf)
2014-10-10 20:13 UTC, Robert Großkopf
Details
Date in x-axis doesn't show different values since LO 4.0.5 (21.97 KB, application/pdf)
2014-10-10 20:14 UTC, Robert Großkopf
Details
No date recognized any more. x-axis differs to former versions. (since LO 4.2) (11.75 KB, application/pdf)
2014-10-10 20:17 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2014-10-10 20:11:02 UTC
Created attachment 107676 [details]
Open the report - should show two charts with date as x-axis, but doesn't

There are some pdf-files of the same report in Base, all attached to this bug-report. 
With LO 3.3 the output of the Report-Builder is right: chart is shown with date-values as x-axis, currency-values as y-axis.
With LO 3.4 the report-builder doesn't recognize there is an x/y-chart.
Versions LO 3.5 up to the first 4.0 doesn't open any report with a chart.
Since LO 4.0.5 the chart is shown again - no difference in the x-axis, all values at the same point. Looks like the date-format had been recognized, but begins with totally wrong date-values (could be year 1899??)
Since LO 4.2 it looks nearly the same as since LO 4.0.5 - but now the date-format is also ignored. Don't know what format it should be ...
The same as with LO 4.2 is with LO 4.3 and LO 4.4 alpha. No possibility to show a right chart with date-values in the Report-Builder.

Could be it is the same reason as Bug68781.

My System: OpenSUSE 12.3 64bit rpm Linux, different LO-Versions for testing.
Comment 1 Robert Großkopf 2014-10-10 20:12:30 UTC
Created attachment 107677 [details]
Right chart shown in LO 3.3
Comment 2 Robert Großkopf 2014-10-10 20:13:15 UTC
Created attachment 107678 [details]
No x/y-chart recognized by LO 3.4
Comment 3 Robert Großkopf 2014-10-10 20:14:50 UTC
Created attachment 107679 [details]
Date in x-axis doesn't show different values since LO 4.0.5
Comment 4 Robert Großkopf 2014-10-10 20:17:44 UTC
Created attachment 107680 [details]
No date recognized any more. x-axis differs to former versions. (since LO 4.2)

Since LO 4.2 the x-axis is shown with an unknown format. Isn't a date-format. The graph shows the same results as before (since LO 4.0.5)
Comment 5 Julien Nabet 2014-10-11 20:15:31 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.

I noticed on console lots of messages, eg:
warn:legacy.osl:15622:1:sw/source/core/layout/atrfrm.cxx:3271: getSdrAllFillAttributesHelper() call only valid for RES_FLYFRMFMT and RES_FRMFMT (!)
warn:chart2:15622:1:chart2/source/view/main/PropertyMapper.cxx:117: Exception caught. Type: N3com3sun4star3uno9ExceptionE, Message:
warn:legacy.osl:15622:1:sw/source/core/unocore/unochart.cxx:1042: XLabeledDataSequence in data source contains 0 entries
AVERTISSEMENT: Unknown tag <urn:oasis:names:tc:opendocument:xmlns:table:1.0:calculation-settings>: Start to ignore this element and all of its childs.  [Location: Line=2 Column=5602] 
oct. 11, 2014 10:04:12 PM org.pentaho.reporting.libraries.xmlns.parser.AbstractXmlReadHandler startElement
AVERTISSEMENT: Unknown tag <urn:oasis:names:tc:opendocument:xmlns:drawing:1.0:g>: Start to ignore this element and all of its childs.  [Location: Line=2 Column=7690] 
oct. 11, 2014 10:04:12 PM org.pentaho.reporting.libraries.xmlns.parser.AbstractXmlReadHandler startElement
AVERTISSEMENT: Unknown tag <urn:oasis:names:tc:opendocument:xmlns:drawing:1.0:g>: Start to ignore this element and all of its childs.  [Location: Line=2 Column=7718] 
warn:dbaccess:15622:1:dbaccess/source/core/api/RowSetBase.cxx:211: ORowSetBase::getValue: Illegal call here (we're before first or after last)!
warn:dbaccess:15622:1:dbaccess/source/core/api/RowSetBase.cxx:1192: firePropertyChange: Exception on column 0
warn:dbaccess:15622:1:dbaccess/source/core/api/RowSetBase.cxx:211: ORowSetBase::getValue: Illegal call here (we're before first or after last)!
warn:dbaccess:15622:1:dbaccess/source/core/api/RowSetBase.cxx:1192: firePropertyChange: Exception on column 1
warn:dbaccess:15622:1:dbaccess/source/core/api/RowSetBase.cxx:211: ORowSetBase::getValue: Illegal call here (we're before first or after last)!
warn:dbaccess:15622:1:dbaccess/source/core/api/RowSetBase.cxx:1192: firePropertyChange: Exception on column 2

Markus/Lionel: thought you might be interested in this one
Comment 6 Julien Nabet 2014-10-12 11:30:04 UTC
I noticed when testing fdo#84930, that when editing report (instead of opening it), the graphic seemed correct.
Comment 7 Alex Thurgood 2015-01-03 17:38:56 UTC
Adding self to CC if not already on
Comment 8 Robert Großkopf 2016-03-05 17:04:34 UTC
Couldn't reproduce this bug any more. There aren't shown any values in the chart now, if date or time are one axis of an x/y-chart. And this is already bug 87012. So I set this bug as "Resolved" and "Worksforme". Could also be set as duplicate ...