Download it now!
Bug 85067 - a chaos in menu list of opened files
Summary: a chaos in menu list of opened files
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-15 15:32 UTC by Anton
Modified: 2016-05-07 20:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
menu (80.43 KB, image/jpeg)
2014-10-22 00:02 UTC, Anton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anton 2014-10-15 15:32:28 UTC
Problem description: 

There is a chaos in menu list of opened files. 
If more than one opened file then they are listed randomly in the "window" menu list. Some shown but some hidden. Every time is different. 

I have to click several times the "window" menu and chose some files in the list and only then a required opened doc may be listed. 

Expected behavior:
All opened files are shown in the list.
Comment 1 Jean-Baptiste Faure 2014-10-15 17:30:43 UTC
Please do not confirm your own bug reports.

Set status back to unconfirmed. Screencopies could help to understand what you mean.

Best regards. JBF
Comment 2 tommy27 2014-10-21 19:59:47 UTC
please post screenshots like suggested in previous comment.
moreover you are strongly encouraged to upgrade to LibO 4.3.2.2
I set status to NEEDINFO waiting for feedback
Comment 3 Anton 2014-10-22 00:01:53 UTC
The update channel hasn't offered any update yet. 

I cannot make a screenshot of menu! It's hiding when it loses focus. 
Here is a photo.
Comment 4 Anton 2014-10-22 00:02:45 UTC
Created attachment 108216 [details]
menu
Comment 5 tommy27 2014-10-22 02:37:17 UTC
(In reply to listerbox from comment #3)
> The update channel hasn't offered any update yet. 

that's because of bug 84441.
LO 4.3.2.2 is already available. download link here:
http://www.libreoffice.org/download/libreoffice-fresh/#change

please upgrade manually and retest.
Comment 6 Jean-Baptiste Faure 2014-10-22 04:57:06 UTC
If I open several files in LO 4.4.0.0.apha1+ under Ubuntu 14.04 x86-64 (Unity window manager) I see that the global menu has difficulties to update when I add a new file and when I switch from one to another using the window menu.
A workaround is to move the mouse to the left next menu and come back to the window menu, then the window menu is correctly updated.

Do you confirm that I describe the same problem as you ?

Best regards. JBF
Comment 7 Anton 2014-10-22 17:55:14 UTC
(In reply to tommy27 from comment #5)
> LO 4.3.2.2 is already available. download link here:
> http://www.libreoffice.org/download/libreoffice-fresh/#change
> 
> please upgrade manually and retest.

Just updated to 4.3.2.2. The problem still persists.
Comment 8 Anton 2014-10-22 17:56:00 UTC
(In reply to Jean-Baptiste Faure from comment #6)
> If I open several files in LO 4.4.0.0.apha1+ under Ubuntu 14.04 x86-64
> (Unity window manager) I see that the global menu has difficulties to update
> when I add a new file and when I switch from one to another using the window
> menu.
> A workaround is to move the mouse to the left next menu and come back to the
> window menu, then the window menu is correctly updated.
> 
> Do you confirm that I describe the same problem as you ?
> 
> Best regards. JBF

Yes, I confirm. Seems to be a similar problem
This description looks close to mine. 

Just updated to 4.3.2.2. The problem still persists.
Comment 9 Jean-Baptiste Faure 2014-10-22 18:54:30 UTC
Ok, so set status to NEW.

Best regards. JBF
Comment 10 Anton 2015-02-21 14:21:49 UTC
Version: 4.4.0.3

The problem still persists.
Comment 11 tommy27 2016-04-16 07:23:05 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.5 or 5.1.2 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-04-16
Comment 12 Jean-Baptiste Faure 2016-05-07 20:35:27 UTC
The recent files list is updated in the reverse order of the closing order (the last closed first). It is the order in the dropdown list attached to the Open button and in the StartCenter. For me there is no chaos in this list anymore.
So I close this bug as WorksForMe. Please, feel free to reopen if you disagree.

Best regards. JBF