Bug 85172 - Hidden rows turn visible again after saving as XLS and re-opening
Summary: Hidden rows turn visible again after saving as XLS and re-opening
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-18 12:43 UTC by Jan Colaris
Modified: 2015-06-08 14:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
example as required (20.50 KB, application/vnd.ms-excel)
2014-10-20 08:19 UTC, Jan Colaris
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Colaris 2014-10-18 12:43:47 UTC
If one is hiding some rows/lines and saves the spreadsheet as XLS - after opening it again the contents of the cells in these rows is hidden, the lines/rows show as empty lines/rows but are returning !!
Comment 1 Cor Nouws 2014-10-18 20:19:30 UTC
Hi Jan

Thanks for reporting here. Can you pls give a test file?
Cheers,
Cor
Comment 2 Jan Colaris 2014-10-20 08:19:32 UTC
Created attachment 108089 [details]
example as required

An example of the problem.
Lines 3 to 50 were hidden several times and saved/opened again – the lines with content are hidden normally – the empty lines are returning after saving and opening again.
 
Hierbij een voorbeeld: de regels 3 t/m 50 (deel zonder tekst) werden diverse malen verborgen na openen en toen weer opgeslagen – bij opnieuw openen blijven de regels met inhoud keurig verborgen, terwijl de lege regels bij opnieuw openen steeds terugkeren !
 
Met vriendelijke groet,

Jan J.E.S. Colaris
Comment 3 Jan Colaris 2014-10-20 08:29:35 UTC
Also tested this in OpenOffice - there the lines stay hidden after opening again
Comment 4 Cor Nouws 2014-10-20 08:31:43 UTC
Hi Jan,

Thanks for the example.
I cannot reproduce it in version 4.3.3.1 on Ubuntu.
What version and OS do you use?

vr. groeten,
Cor
Comment 5 Jan Colaris 2014-10-20 13:55:24 UTC
I'm using LibreOffice 4.3.3.2 (latest version to my opinion) with Windows 8.1
Comment 6 Yousuf Philips (jay) (retired) 2014-10-20 16:45:02 UTC
Tested hiding lines 2 to 60 in attachment 108089 [details] and saving it to xls and didnt have any problem with

Version: 4.3.2.2
Build ID: edfb5295ba211bd31ad47d0bad0118690f76407d

or

Version: 4.3.3.0.0+
Build ID: 50eac342603ca08d808f53dc9a32bb9d1dfba372
TinderBox: Win-x86@42, Branch:libreoffice-4-3, Time: 2014-09-30_14:34:56

@Jan: Can you give some exact instructions that are reproducible every time.
Comment 7 QA Administrators 2015-05-06 14:14:08 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 8 QA Administrators 2015-06-08 14:26:36 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

-- The LibreOffice QA Team 

This INVALID Message was generated on: 2015-05-06

Warm Regards,
QA Team