Download it now!
Bug 85191 - Starting only by filename through cmd.exe crashes on startup
Summary: Starting only by filename through cmd.exe crashes on startup
Status: RESOLVED DUPLICATE of bug 82968
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-19 10:01 UTC by tonic+fdlobugzilla
Modified: 2015-07-13 16:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tonic+fdlobugzilla 2014-10-19 10:01:12 UTC
Problem description: 

LibreOffice crashes when you open a doc from command line with the plain filename (like "C:\temp>test.odt"). However, for some reason it will correctly work when using with the cmd start command: "C:\temp>start test.odt".

Steps to reproduce:
1. Make sure Windows has mapped e.g. .odt files to be run with LibreOffice Writer.
2. Open cmd.exe and find your way to a folder with a document, e.g. "test.odt" in C:\temp
3. Run "test.odt" while you're in that folder, meaning to open the doc in LibreOffice. The LibreOffice will crash a bit after opening a blank window (without UI components shown).
4. NOTE: Compare to using command "start test.odt" which works!

Current behavior:

Crash

Expected behavior:

Opens document as it would have been opened with the Windows Explorer GUI or using start-command in cmd.
Comment 1 Steve Flitman 2014-10-23 05:18:01 UTC
Confirmed on 4.3.2.2 latest build on 64-bit Windows 7.
Very reproducible, always happens on opening a file in .doc format when
invoked from the command line or the big-icon file browser, but not when
using File Open menu command strangely.

Problem Event Name:	APPCRASH
  Application Name:	soffice.bin
  Application Version:	4.3.2.2
  Application Timestamp:	541af548
  Fault Module Name:	MSVCR110.dll
  Fault Module Version:	11.0.51106.1
  Fault Module Timestamp:	5098858e
  Exception Code:	40000015
  Exception Offset:	000a327c
  OS Version:	6.1.7601.2.1.0.768.3
  Locale ID:	1033
  Additional Information 1:	2d7a
  Additional Information 2:	2d7a74aace553f152cb5664d57813d88
  Additional Information 3:	531a
  Additional Information 4:	531a42f6208a0a86194a3348f07931f9

I changed status to NEW as this is definitely confirmed.
Thanks,
SSF
Comment 2 Björn Michaelsen 2014-11-28 09:42:15 UTC
(This is an automated message.)

LibreOffice development currently prioritizes bugs with the so called MAB (most annoying bugs) -- as this bug has not run through that process (including writing a short rationale for this bug being a candidate and other who are watching the tracker bug silently approving that rationale etc.) its priority is set to high. Note this is effectively no change in the urgency assigned to this bug, as we are currently not making a difference between high and highest and severity is untouched.

You can find out more about MABs and how the process works by contacting libreoffice qa on irc:

 http://webchat.freenode.net/?channels=libreoffice-qa

The QA wiki page also gives you hints on how to get in contact with the team (if IRC fails you, your next best choice is the mailing list):

 https://wiki.documentfoundation.org/QA
Comment 3 Gordo 2015-07-10 15:51:46 UTC
Could not reproduce.

Windows Vista 64
Version: 4.4.4.3
Build ID: 2c39ebcf046445232b798108aa8a7e7d89552ea8

Could reproduce with portable 4.4.3.2 by using LibreOfficeWriterPortable.exe or swriter.exe and the path name.

Changed to RESOLVED WORKSFORME.
Comment 4 Maxim Monastirsky 2015-07-13 16:15:24 UTC

*** This bug has been marked as a duplicate of bug 82968 ***