Bug Hunting Session
Bug 85213 - Crash when changing default detailed calculation options
Summary: Crash when changing default detailed calculation options
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-20 04:14 UTC by Jean-Baptiste Faure
Modified: 2015-12-05 14:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2014-10-20 04:14:44 UTC
Steps to reproduce:
1/ open a new spreadsheet
2/ menu Tools > Options > LibreOffice Calc > Formula
3/ select "Custom" under Detailed Calculation
4/ click the "Details..."

==> Crash

Tested with Version: 4.4.0.0.alpha0+
Build ID: 68a18a6249dc9d8842a72413f3cd6f39ecf416e3 built at home under Ubuntu 14.04 x86-64

Best regards. JBF
Comment 1 Cor Nouws 2014-10-20 06:48:08 UTC
Can confirm this on Linux
Comment 2 Jean-Baptiste Faure 2014-10-20 10:50:20 UTC
No crash at build ID 51b215902d8e1f415b5fef49fc50c7167f0c7787 (2014-10-17)

Best regards. JBF
Comment 3 Julien Nabet 2014-10-21 06:02:39 UTC
I gave a try and it seems it's the root cause is already fixed by this:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=9bdca0019bd3781f15e542becca5537fac2e0a9d

Don't hesitate to reopen this tracker if you can still reproduce this with a build including the quoted commit.
Comment 4 Jean-Baptiste Faure 2014-10-22 04:44:00 UTC
Indeed it does not crash in my build from this night.

Best regards. JBF
Comment 5 Julien Nabet 2015-12-05 14:44:55 UTC
cleanup keywords