Bug 85335 - Glue points window/dialog contains two title bars
Summary: Glue points window/dialog contains two title bars
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-22 15:44 UTC by Gabriel Diosan
Modified: 2014-10-24 15:10 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot showing two close buttons on the Glue Points window/dialog (136.12 KB, image/png)
2014-10-22 15:44 UTC, Gabriel Diosan
Details
Screenshot of Glue Points Window/Dialog on Ubuntu Gnome 14.10 (100.81 KB, image/png)
2014-10-23 11:21 UTC, Gabriel Diosan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriel Diosan 2014-10-22 15:44:46 UTC
Created attachment 108242 [details]
Screenshot showing two close buttons on the Glue Points window/dialog

The glue points window/dialog contains 2 title bars, including 2 close buttons.

Steps to reproduce:

1. Open Libreoffice Draw.
2. Go to the bottom toolbar and click on the 'Glue Points' button.
3. The Glue Points window/dialog will open.

Current Behaviour:

The Glue Points window/dialog has two title bars and close buttons. One of the close buttons does not work when clicked.

Expected Behaviour:

The Glue Points window/dialog should only have one title bar and close button which is functional.

Problem is not present in Libreoffice 4.2.6 and is a regression. It is likely this has come up as part of the work on bringing the UI to the new .ui files.

Tested on Lubuntu 14.04.1 64 Bit (VM)

Libreoffice Build:

Version: 4.4.0.0.alpha1+
Build ID: e3ac30fe6287b4cd0c9ef103d011a109a359a0be
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-10-22_08:01:29
Comment 1 Urmas 2014-10-22 16:44:30 UTC
Can you reproduce it with a normal WM?
Comment 2 Gabriel Diosan 2014-10-23 11:21:45 UTC
Created attachment 108294 [details]
Screenshot of Glue Points Window/Dialog on Ubuntu Gnome 14.10
Comment 3 Gabriel Diosan 2014-10-23 11:23:17 UTC
I have tested this on Ubuntu Gnome 14.10 and the problem is not present. I have attached another screenshot as well.

Libreoffice Build:

Version: 4.4.0.0.alpha1+
Build ID: 72f368f6bfedb680ffcbd1c7fe28e8fc6d19ad2b
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-10-22_22:23:11
Comment 4 Adolfo Jayme Barrientos 2014-10-23 14:05:32 UTC
You can work around the problem by installing a compositor in Lubuntu, such as Compton.
Comment 5 Urmas 2014-10-24 15:10:41 UTC
Take it to OpenBox.