Bug 85356 - Hindi script improperly rendered in LibreOffice (in some cases)
Summary: Hindi script improperly rendered in LibreOffice (in some cases)
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-23 06:25 UTC by Jeff R
Modified: 2015-05-13 09:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
This document contains Hindi script that reproduces the problem. (27.54 KB, application/vnd.oasis.opendocument.text)
2014-10-23 06:25 UTC, Jeff R
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff R 2014-10-23 06:25:02 UTC
Created attachment 108280 [details]
This document contains Hindi script that reproduces the problem.

LibreOffice Writer and Calc (probably others) are not properly rendering "half letters" in Hindi in one particular case. In most cases, the rendering is working properly.

An attached file shows the problem. The problem combination is when you use the Windows 8 Hindi keyboard to type द्व. In this combination, the second letter should appear beneath the first letter. The current rendering is technically correct, but is not ideal.

This seems to be a problem with the component that renders glyphs, because the same issue occurs in Calc, Impress, etc.
Comment 1 Adolfo Jayme Barrientos 2014-10-24 04:22:25 UTC
Do you realize the comparison with Notepad is useless since it isn’t comparing the same font as your LibreOffice document? An image comparing LibreOffice with another office suite’s font rendering would be much more useful.
Comment 2 QA Administrators 2015-05-06 14:15:12 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 3 Jeff R 2015-05-07 12:41:34 UTC
Using another font properly renders the script. My assumption is that this means it is not an issue with the LibreOffice product. Please close this bug if that is the case.
Comment 4 Buovjaga 2015-05-13 09:35:37 UTC
Jeff: thanks for checking back, I'll close as INVALID then.