Bug Hunting Session
Bug 85360 - LibreOffice crashes and crashes desktop too on inserting 4th slide
Summary: LibreOffice crashes and crashes desktop too on inserting 4th slide
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: x86 (IA32) Linux (All)
: high blocker
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-23 07:39 UTC by Steve Roberts
Modified: 2018-08-18 07:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Roberts 2014-10-23 07:39:11 UTC
I am using OpenSuse 13.1
Yesterday I started having problems with libreoffice 4.3.1 where it would crash and also crash the desktop back to the login prompt when inserting the 4th slide in a presentation.  Then libreoffice wouldnt start at all.  Starting from the command prompt - it just sits there - no output and no error messages.

Tried reinstalling LibreOffice 4.3.1 via Yast - wouldn't start.

Ended up installing apache openoffice which also wouldnt start.

Then uninstalled 4.3.1 and openoffice and installed libreoffice 4.3.2 via rpms as re-installation of 4.3.1 wouldnt run (at least using Yast)

I now have 4.3.2 running now but the problem of it crashing and crashing the desktop on inserting the 4th slide is still there. I thought it might be a problem with my presentation but exactly the same happens on a blank presentation.  4th slide crashes it and the desktop so definitely severe and unusable.  Spreadsheet seems fine - havent tried other apps
Comment 1 Steve Roberts 2014-10-23 07:42:22 UTC
Not directly related to this but changes to the system yesterday :

- Tried installing import.io which needed oxygen-theme (this was a tar not an rpm). Installed gtk3-oxygen-theme via yast - didnt get import.io working so removed it using Yast
Comment 2 Julien Nabet 2014-10-23 20:42:35 UTC
Could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#GNU.2FLinux) and give it a new try?
Comment 3 Joel Madero 2014-10-24 03:36:34 UTC
This is probably environment specific. Suggestions:

1. Try resetting profile as suggested;
2. Get a trace on the crash: https://wiki.documentfoundation.org/Development/How_to_debug#Debugging_with_gdb

If resetting the profile doesn't help, please try to get a crash report using the above instructions and set the bug to UNCONFIRMED. Thanks
Comment 4 Julien Nabet 2014-10-26 11:36:02 UTC
On pc Debian x86-64 with Virtualbox and Linux Mint 17 32 bits Cinnamon, I don't reproduce this with master sources updated today.
I just used "Insert slide" 4 times.
(I built with enable-dbgutil)
Comment 5 Steve Roberts 2014-10-26 17:08:10 UTC
Replacing the user profile did not solve.

I have found a temporary workaround - the presentation file didnt have an odp extension.  I renamed it - editting this only crashes if I insert the 4th slide after the 3rd. If I insert a slide at the beginning and then can insert slides anywhere without it crashing.

I could not figure out how to do a gdb trace as when libreoffice crashes it takes out the desktop and therefore kills gdb too
Comment 6 Steve Roberts 2014-10-26 17:09:21 UTC
The above environment for reproducing was debian.  I am running OpenSuse 13.1 (64bit)
Comment 7 Julien Nabet 2014-11-01 21:12:58 UTC
Just to be sure of the process, 
1) you launch Impress
2) Menu Insert, select Slide
Repeat Step 2) 3 other times and it crashes?

I'm asking because I tested this on Ubuntu 14.10 32 bits, I still don't reproduce this.
Comment 8 Steve Roberts 2014-11-17 08:15:20 UTC
I've managed to test which conditions cause this. If I insert 4 slides in succession (ie 1,2,3,4) it crashes taking the desktop with it.  If I insert 2 slides then insert 2 slides between 1 and 2 it doesnt crash and then I can add additional slides with no problems (ie 1,3,4,2)
Comment 9 Steve Roberts 2014-11-17 08:16:47 UTC
I removed the profile as suggested as problem still exists.
I couldnt get the trace thing to work in my environment.
Comment 10 Julien Nabet 2014-11-17 19:07:49 UTC
For the test, could you give a try to brand new 4.3.4 (see http://linuxg.net/how-to-install-libreoffice-4-3-4-on-fedora-centos-opensuse-mageia-openmandriva-and-derivative-systems/)
Comment 11 Andreas Mantke 2015-03-22 19:42:43 UTC
I'm using openSuSE 13.2-x64 with LibreOffice 4.3.6.2 from the project-website and I could add as much slides as I want. Maybe the issue is with the rpm-package from the openSuSE repository.
If the package is from the project website (or the mirror network) please provide the details from the help-menue, info about LibreOffice.
Comment 12 Julien Nabet 2015-09-06 21:08:30 UTC
No feedback since more than 6 months, let's put this one WFM.

Steve: if you can reproduce the crash with a recent LO version (4.4.5 or 5.0.1), please don't hesitate to reopen this tracker.
Comment 13 Julien Nabet 2015-12-05 14:45:14 UTC
cleanup keywords
Comment 14 Commit Notification 2018-08-18 07:46:43 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=991ff3d6205d8b594701c9df537cf8f0a629a92d

uitest Impress-rename,new slide ; tdf#85360

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.