Download it now!
Bug 85455 - Unable to save record into Postgres using a default table and wizard
Summary: Unable to save record into Postgres using a default table and wizard
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-25 20:31 UTC by pnathan
Modified: 2015-09-04 03:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Postgres error on insert (89.07 KB, image/png)
2014-10-25 20:31 UTC, pnathan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pnathan 2014-10-25 20:31:30 UTC
Created attachment 108417 [details]
Postgres error on insert

Hi,

I am working through a 'default' setup (I'm trying to understand how to get forms set up) of the postgres connector, using the Library default record & setting up a form via the wizard.

So I tried to jam some data in and insert a record, - here's the screenshot!

For resolution, I would like to see either (1) a pointer to what data type goes where or (2) pre-insertion validation.

Please let me know if I can provide further information.

version: 4.2.3.3

build id 882f8a0a489bc99a9e60c7905a60226254cb6ff0
Comment 1 Terrence Enger 2014-10-26 15:09:35 UTC
Thank you for taking the time to help improve LibreOffice.

Can you please give us the DDL for table Library?  If you are willing
to share your .odb file (remember that it will be available to the
whole world), please attach it, too.  And when you answered, please
set bug status back to UNCONFIRMED.

Thanks,
Terry.
Comment 2 Robert Großkopf 2014-10-27 20:25:48 UTC
Which version and sytem you are using?
I read 4.3.2.2 as version above and in the report I see 4.2.3.3

I have tested with OpenSUSE 12.3 64bit and some 4.2 and 4.3-versions of LO: direct connection to PostgreSQL works as expected. Could input values trough the form without any problem.

Could you attach the SQL-code for creating the table needed for the the form together with the *.odb-file?
Comment 3 Alex Thurgood 2015-01-03 17:39:50 UTC
Adding self to CC if not already on
Comment 4 QA Administrators 2015-07-18 17:35:01 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

This NEEDINFO message was generated on: 2015-07-18
Comment 5 QA Administrators 2015-09-04 03:00:20 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and a lack of information which is needed in order to accurately reproduce and confirm the problem. We encourage you to retest your bug against the latest release. If the issue is still present in the latest stable release, we need the following information (please ignore any that you've already provided):

a) Provide details of your system including your operating system and the latest version of LibreOffice that you have confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED and we will attempt to reproduce the issue. 
Please do not:
a) respond via email 
b) update the version field in the bug or any of the other details on the top section of FDO
Message generated on: 2015-09-03