Bug Hunting Session
Bug 85509 - word in "table of contents" stays as grammically false, when changing the language of a word
Summary: word in "table of contents" stays as grammically false, when changing the lan...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-27 10:36 UTC by Markus Grob
Modified: 2015-10-05 12:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot which shows the problem (8.83 KB, image/png)
2014-10-27 10:41 UTC, Markus Grob
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Grob 2014-10-27 10:36:25 UTC
The "table of contents" or "directory" or "index" of a document (which is the right word in this case?) shows gramatical misspelled words also with an underline as the word in the text.
This behavior semms to be wrong for me, because this word is only a reference to the original word and it's the source of the described error.

I'm writing a document in german, but some words are english. Because of this, I change the language of this words to english. The problem is, that the index of the document isn't actualised and can't be changed. Because of this, the word stays there as misspelled.

I add an attachement to show the problem.

Sincerely, Markus
Comment 1 Markus Grob 2014-10-27 10:41:02 UTC
Created attachment 108502 [details]
screenshot which shows the problem

As you can see, the words are right in the text (changed from german to english), but are shown as misspelled in the index of the document.
Comment 2 sophie 2014-10-27 14:18:38 UTC
Hi, when you create a Table of Contents, styles are applied: Table of content level1, table of content level2, etc. What you need to do in your case it to create an additional style where the font is set to English (table of content level1 English for example) and apply it to the corresponding level in the Table of content. Does it work for you like that?
(What I would like is to have the language of the document style retained by the Table of content :) Sophie
Comment 3 Markus Grob 2014-10-31 16:34:45 UTC
Hello Sophie

your solution isn't working, because I have two languages in one title and can't edit the table of content, because it is generated by LibreOffice, but you have given me a hint.
LibreOffice uses editable "system stylesheets" for the zable of content an I now have changed them to "no language".

But I think, it is an error, because the entry is generated by the document itself and shouldn't be prooved by the grammar speller, because it only shows an error, but it is not possible to change it, because the original is corrected and only "the copy" still has the error inside, because there is no possibility to change the language of a word inside the table of content.

Very long sentence, but I hope, it's understandable.

Markus
Comment 4 tommy27 2015-10-04 13:07:11 UTC
@Markus
LibO 4.4.5 and 5.0.2 are out.
has situation improved from your original report?
Comment 5 Markus Grob 2015-10-05 12:30:08 UTC
Thank you. Tested in 4.4.5.2 and works. Index is not tested anymore.
Comment 6 tommy27 2015-10-05 12:44:31 UTC
nice to hear that. however correct status is RESOLVED WORKSFORME since we don't know which committ fixed it