Bug 85601 - Writer crashed when opening rtf file generated by third program
Summary: Writer crashed when opening rtf file generated by third program
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected)
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
Keywords: haveBacktrace
Depends on:
Reported: 2014-10-29 14:05 UTC by Bart Hengeveld
Modified: 2014-11-05 21:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:

backtrace (8.46 KB, text/plain)
2014-10-29 14:05 UTC, Bart Hengeveld
rtf template from GensDataPro (44.38 KB, application/rtf)
2014-10-29 14:07 UTC, Bart Hengeveld
Backtrace with LO (8.39 KB, text/plain)
2014-10-30 11:02 UTC, Bart Hengeveld

Note You need to log in before you can comment on or make changes to this bug.
Description Bart Hengeveld 2014-10-29 14:05:49 UTC
Created attachment 108627 [details]

Problem description: GensDataPro, a genealogy program (http://gensdatapro.ngv.nl/), can generate a socalled personal chart with the help of a template. The template calls various items of a person that is at that moment selected.

Steps to reproduce:
1. In GensDataPro start: uitvoer>Persoonskaart>Naar Slabloon
2. ....
3. ....

Current behavior:Writer crashes when the reuslting rtf file calls writer to start or if already started to show the result.

Expected behavior: Show the resulting rtf file

I can submit a backtrace and a copy of the template: perskaart.rtf

Open Office produces the output more or less correctly however without including the photo.
Comment 1 Bart Hengeveld 2014-10-29 14:07:54 UTC
Created attachment 108628 [details]
rtf template from GensDataPro
Comment 2 Julien Nabet 2014-10-29 15:32:59 UTC
What's your LO version? If not 4.3.2, could you test with this one since it's the last stable LO version?
Comment 3 Urmas 2014-10-29 16:11:20 UTC
You need to recreate a sample with some dummy data, which actually does cause the crash.
Comment 4 Julien Nabet 2014-10-29 22:02:10 UTC
On pc Debian x86-64 with LO Debian package, I don't reproduce this.

For the test, could you give a try to the prerelease 4.3.3 RC2, see http://www.libreoffice.org/download/libreoffice-fresh/?version=4.3.3 ?
Comment 5 Bart Hengeveld 2014-10-30 11:02:23 UTC
Created attachment 108683 [details]
Backtrace with LO

I did install LO This makes no difference in behaviour. When I run GensDataPro and do "uitvoer>persoonskaart>Naar Sjabloon" LO is started and susequently an error is displayed: "Algemene fout, Algemene invoer/uitvoer fout" That is: general error. general import/export error.
I prepared a new backtrace with the LO version now installed (
Please note that I cannot supply a sample document as this is generated by GensDataPro from a template (perskaart.rtf) that I already supplied.
I you need to repeat the process yourself please go to http://gensdatapro.ngv.nl/ and download the demo version. This comes with a genealogical data file that will allow you to repeat the process.
Please also note that this can not be done on  a linux machine as GensDataPro is only available as a windows version.
Comment 6 Bart Hengeveld 2014-10-30 14:47:44 UTC
Solved, I now put perskaart-metgfotos.rtf in the relevant output line and the thing worked as intended, tjhough without including the photo. That however is something for the GensDataPro programmer to solve I think.
Strange remains that with perskaart.rtf LO produces an error.
Comment 7 Urmas 2014-10-31 14:41:46 UTC
Once again, the file you have attached is not 'med fotos', it is COMPLETELY EMPTY except the placeholder. You need to generate a REAL file, with PHOTO and names so the crash could be reproduced.
The file will probably be found in the temporary directory in the RTF format. You can use Sysinternals' Process Explorer to find out the command line of soffice.bin file GensDataPro invokes, it contains the exact filename.
Comment 8 Bart Hengeveld 2014-10-31 14:58:51 UTC
The point is that there is no file produced. I approached now also the programmer of GensDataPro. As I already let you know another template called perskaart-metgfotos.rtf actually did produce a persoonkaart however without attaching the photo. It may very well be that the source of the problem is not so much LO but rather the template perskaart.rtf.
I do not have any further information available.
If you want to try to reproduce the iisue plaese download the demoversion of GensDataPro and run this as I explained before.
Comment 9 Julien Nabet 2014-11-05 21:12:13 UTC
Let's put this one to NOTOURBUG.
If it's not the case, don't hesitate to reopen this tracker.