Bug 85735 - Changes in table cell border colour are not reflected in their document
Summary: Changes in table cell border colour are not reflected in their document
Status: RESOLVED DUPLICATE of bug 64498
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2014-11-01 14:55 UTC by Oli Boorman
Modified: 2015-12-15 11:03 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample document (14.92 KB, application/vnd.oasis.opendocument.graphics)
2014-11-01 14:55 UTC, Oli Boorman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oli Boorman 2014-11-01 14:55:19 UTC
Created attachment 108762 [details]
Sample document

Problem description: 
If the user changes the border colour of cells within a table, the view on-screen is not automatically updated. User has to save and reopen the file for the changes in border colour to be shown. Resizing the table also triggers a refresh.

Steps to reproduce:
1. Open the attached file (with table that has no fill and black solid borders)
2. Select 4 segments in the centre of the table and select White border colour from the Table toolbar

Current behavior:
Nothing (visible) changes. 

Expected behavior:
The selected cells are updated to have a white border
Comment 1 Buovjaga 2014-11-15 13:25:52 UTC
Reproduced, but is this because style overrides other formatting?

Win 7 64-bit Version: 4.4.0.0.alpha2+
Build ID: b021b5983c62e266b82d9f0c5c6d8d8900553827
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-12_01:10:08
Comment 2 sophie 2014-11-27 15:11:37 UTC
Hi, in fact the border is applied, but there is a refresh bug in the display. If once you have applied the border, you extend or minimize the table using the handle at the top for example, you'll see the color applied to the table cells.
Reproduced with Version: 4.3.2.1
Build ID: f9b3ad49d92181b0a1fe7e76f785a2c2cd0847d3 Ubuntu 14.10 x64 
@Beluga: usually, direct formatting override style formatting.
Set as New - Sophie
Comment 3 Robinson Tryon (qubit) 2014-12-23 22:07:49 UTC
Whiteboard: Remove 'needQAAdvice' once bug is NEW/RESOLVED.
Comment 4 Buovjaga 2015-01-12 16:27:04 UTC
On Linux, the problem is present in 4.5 alpha, but not in 3.5.0.

Repro steps: Right click selection - Table - Borders: color.

When opening in 3.5.0, the table looked a bit weird, with some sections having a thicker border.

Adding bibisectRequest anyway.

Ubuntu 14.10 64-bit
LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735

Version: 4.5.0.0.alpha0+
Build ID: 0748a5f8298e2ea817e131234f5e99300ed7f9f7
TinderBox: Win-x86@39, Branch:master, Time: 2015-01-08_08:03:53
Comment 5 Rostislav 'R.Yu.' Okulov 2015-01-13 06:34:51 UTC
There are only 'skip'ped commits left to test.
The first bad commit could be any of: 524032d94d92022e87e0add99aea74683da8f368 f832455cd2cc194ff04197ef174cb1e658336d18 1b831d02ff29aa5763cf33ae75131f98d882201f
We cannot bisect more!


git bisect start
# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
git bisect bad 423a84c4f7068853974887d98442bc2a2d0cc91b
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect good 65fd30f5cb4cdd37995a33420ed8273c0a29bf00
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect good 4850941efe43ae800be5c76e1102ab80ac2c085d
# good: [a900e72b6357882284c5955bdf939bf14269f5fb] source-hash-dd1050b182260a26a1d0ba6d0ef3a6fecc3f4e07
git bisect good a900e72b6357882284c5955bdf939bf14269f5fb
# skip: [e80660c5a1d812cd04586dae1f22767fc3778c4a] source-hash-07c60c8ee2d1465544a6a39e57bc06b3690b8dfb
git bisect skip e80660c5a1d812cd04586dae1f22767fc3778c4a
# bad: [df9bcaed2faa2a8d11b19f877cdff3a12a887278] source-hash-6ba9692d8bbe3e3c245aca9a7c928e81178d05f1
git bisect bad df9bcaed2faa2a8d11b19f877cdff3a12a887278
# bad: [9d57c189d74551d2b3770cc81139ea10a62e672f] source-hash-5b5e62650354788e50b44f32c22b687b2018aba9
git bisect bad 9d57c189d74551d2b3770cc81139ea10a62e672f
# good: [ce81582766413e76a63c047bfd6227ab12fcd866] source-hash-3d1b1eea83703919c43620f9adef05e5b24c4bed
git bisect good ce81582766413e76a63c047bfd6227ab12fcd866
# good: [87bfccc81c2d8028642492b80505217d7b42a5a8] source-hash-5b4b6b2aad548cdc27ba2aa7d87ff584ec7e97dd
git bisect good 87bfccc81c2d8028642492b80505217d7b42a5a8
# bad: [1b831d02ff29aa5763cf33ae75131f98d882201f] source-hash-b7c3e851465638d4416ca8837937946353561088
git bisect bad 1b831d02ff29aa5763cf33ae75131f98d882201f
# skip: [524032d94d92022e87e0add99aea74683da8f368] source-hash-c7363cb6d1d31f2a7d40a76e62b5934629a1a8a1
git bisect skip 524032d94d92022e87e0add99aea74683da8f368
# skip: [f832455cd2cc194ff04197ef174cb1e658336d18] source-hash-a79afdaa11a1af26c9404441dcf27ef197e972b2
git bisect skip f832455cd2cc194ff04197ef174cb1e658336d18
# only skipped commits left to test
# possible first bad commit: [1b831d02ff29aa5763cf33ae75131f98d882201f] source-hash-b7c3e851465638d4416ca8837937946353561088
# possible first bad commit: [f832455cd2cc194ff04197ef174cb1e658336d18] source-hash-a79afdaa11a1af26c9404441dcf27ef197e972b2
# possible first bad commit: [524032d94d92022e87e0add99aea74683da8f368] source-hash-c7363cb6d1d31f2a7d40a76e62b5934629a1a8a1
Comment 6 Matthew Francis 2015-01-13 15:23:08 UTC
The behaviour seems to have changed at the below commit.

Adding a Cc: to l.lunak@collabora.com; Could you possibly take a look at this? Thanks

commit 26b06662ebc3e5d664400bc95c39d6220de03136
Author: Luboš Luňák <l.lunak@collabora.com>
Date:   Tue Mar 25 11:27:51 2014 +0100

    avoid repeated table layouting (fdo#75622)
    
    With the document from fdo#75622, this saves 3775 calls and leaves only 13.
    e586fe4585dc07e6f6dd061d09f6a7fb0b22948c removed avoiding the call
    to LayoutTable(), which made loading slow. I checked that the doc from that
    bugreport still works, so if very original code was correct in avoiding
    the call sometimes, this should be ok too.
    
    Change-Id: Ia80f974d4497e5cb04612331527eb87b579ddb76
Comment 7 Matthew Francis 2015-01-14 13:16:47 UTC
In fact there is a much older duplicate of this, so moving the investigation results there

*** This bug has been marked as a duplicate of bug 64498 ***
Comment 8 Robinson Tryon (qubit) 2015-12-15 11:03:24 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]