Download it now!
Bug 85748 - .eps files included in Writer documents “disappear” on printing
Summary: .eps files included in Writer documents “disappear” on printing
Status: RESOLVED DUPLICATE of bug 67465
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: All Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-02 02:42 UTC by felipe
Modified: 2015-03-11 04:37 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
The file that gets mangled. (176.25 KB, application/vnd.oasis.opendocument.text)
2014-11-02 02:42 UTC, felipe
Details
Screenshot that shows the mangling of the .eps image. (601.21 KB, image/png)
2014-11-02 02:43 UTC, felipe
Details
The .eps file that gets corrupted. (51.27 KB, application/postscript)
2014-11-02 02:45 UTC, felipe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description felipe 2014-11-02 02:42:37 UTC
Created attachment 108779 [details]
The file that gets mangled.

Problem description: 

An attached .eps file appears to corrupt itself in certain contexts, e.g., printing or PDF generation.

I’m seeing it itermittently. Usually it goes away when I restart LibreOffice, but this particular case seems to be persistent.

Steps to reproduce:
1. … not sure what I did except to attach a .eps file to the document.

Current behavior:

See the screenshot.

Expected behavior:

The graphic should stay as I put it.
Comment 1 felipe 2014-11-02 02:43:30 UTC
Created attachment 108780 [details]
Screenshot that shows the mangling of the .eps image.

(Unfortunately, I seem not to be able to find the .eps image itself …)
Comment 2 felipe 2014-11-02 02:45:59 UTC
Created attachment 108781 [details]
The .eps file that gets corrupted.
Comment 3 Alex Thurgood 2014-11-03 14:30:37 UTC
Confirming

Tested on LO 440 dev alpha, on OSX 10.10
Comment 4 Alex Thurgood 2015-02-05 08:54:56 UTC
*** Bug 89073 has been marked as a duplicate of this bug. ***
Comment 5 Steve Edmonds 2015-03-11 00:05:42 UTC
I just noticed this too after updating to 4.3. All my datasheets have EPS images and now they don't print as postscript.
Went back to 4.1 = OK, 
4.2 = broke, 4.3=broke, 4.4.1.2=broke.

The problem is that LO is ouputing the thumbnail and not the EPS.
Comment 6 Steve Edmonds 2015-03-11 00:27:39 UTC
AOO 4.1.1 treats EPS correctly.
Comment 7 V Stuart Foote 2015-03-11 04:37:25 UTC
Not printing to postscript is different than missing preview generated from pstoedit or imagemagick convert.  Back to OSX only and setting as duplicate of bug 67465

*** This bug has been marked as a duplicate of bug 67465 ***