Bug Hunting Session
Bug 85777 - Crash on file open with LO 4.3 on command line ONLY
Summary: Crash on file open with LO 4.3 on command line ONLY
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard: (target:4.4.4)
Keywords:
: 90775 91621 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-11-02 21:45 UTC by c read
Modified: 2015-06-13 20:54 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
A sanitized spreadsheet that causes the crash (links are broken due to redacted content) (40.74 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-11-02 21:45 UTC, c read
Details

Note You need to log in before you can comment on or make changes to this bug.
Description c read 2014-11-02 21:45:55 UTC
Created attachment 108814 [details]
A sanitized spreadsheet that causes the crash (links are broken due to redacted content)

Problem description: 
scalc crashed when opening a particular .ods file.  See attached.

Steps to reproduce:
"C:\Program Files (x86)\LibreOffice 4\program\scalc" D:\Budget.ods

Current behavior:
crash prompt

Expected behavior:
open file ready to edit

The attached file should cause the crash.

I have tried the following versions 
4.2.4 works
4.3.0 CRASH
4.3.1 CRASH
4.3.3 CRASH

In all cases double clicking on the file works fine.  The crash is only on the command line.  I am using the "cmd" command line, Windows 7 64bit pro.
Comment 1 Tim Lloyd 2014-11-03 01:31:27 UTC
No problem on either XP LO4.2.0.4 or Fedora 21 4.3.2.2

same result either command line or double clicking
Comment 2 c read 2014-11-06 02:03:04 UTC
(In reply to Tim Lloyd from comment #1)
> No problem on either XP LO4.2.0.4 or Fedora 21 4.3.2.2
> 
> same result either command line or double clicking

The results are consistent with problem.  Windows and version 4.3 and above.  The command line in Linux are very different than windows.
Comment 3 raal 2014-11-07 18:59:11 UTC
I can confirm with LO 4.3.3, win7. The crash is only on the command line.
Comment 4 Julien Nabet 2014-11-11 11:04:55 UTC
Could someone retrieve a backtrace by using this link:
https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Windows:_How_to_get_a_backtrace
?
Comment 5 raal 2014-11-11 18:39:12 UTC
(In reply to Julien Nabet from comment #4)
> Could someone retrieve a backtrace by using this link:
> https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Windows:
> _How_to_get_a_backtrace
> ?

Hello,
when I attach windbg to running soffice process, then I can open file without crash. So I don't know how to debug...
Comment 6 Julien Nabet 2014-11-17 20:24:02 UTC
raal: just for the test, could you give a try to brand new 4.3.4?
Comment 7 raal 2014-11-18 16:33:21 UTC
(In reply to Julien Nabet from comment #6)
> raal: just for the test, could you give a try to brand new 4.3.4?

With LO 4.4.1 still crash.
Comment 8 raal 2014-11-18 16:38:04 UTC
(In reply to raal from comment #7)
> (In reply to Julien Nabet from comment #6)
> > raal: just for the test, could you give a try to brand new 4.3.4?
> 
> With LO 4.4.1 still crash.

LO  4.3.4.1
Comment 9 Miroslav Fitz 2014-12-03 17:09:47 UTC
I can confirm the problem with opening documents from commandline.
It started from 4.3.x version.
It is probbaly not connected to any particular document type but to startup of LibreOffice.
Workaround for me is to have quickstarter running before using commandline.
Probbably duplicate of bug 82968.
Comment 10 Miroslav Fitz 2014-12-03 17:16:45 UTC
another workaround:
start "office" "C:\Program Files (x86)\LibreOffice 4\program\scalc" D:\Budget.ods
Comment 11 c read 2014-12-04 04:43:17 UTC
(In reply to Miroslav Fitz from comment #10)
> another workaround:
> start "office" "C:\Program Files (x86)\LibreOffice 4\program\scalc"
> D:\Budget.ods

The issue with this and the quick start option is that these commands detach from the command line and allow the scrip to continue.  I use the script to mount and (when done) dismount.  If the the batch continues before exiting the spreadsheet then the files cannot be saved.
Comment 12 c read 2015-03-20 00:24:05 UTC
This issue is still present in 4.4.1.2:
Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	soffice.bin
  Application Version:	4.4.1.2
  Application Timestamp:	54e83ec7
  Fault Module Name:	MSVCR110.dll
  Fault Module Version:	11.0.51106.1
  Fault Module Timestamp:	5098858e
  Exception Code:	40000015
  Exception Offset:	000a327c
  OS Version:	6.1.7601.2.1.0.256.48
  Locale ID:	1033
  Additional Information 1:	8d08
  Additional Information 2:	8d08716810a864b8f14c82b0b07f122a
  Additional Information 3:	ffb8
  Additional Information 4:	ffb8635f81aae4c438fee7b8010e38da
Comment 13 Joe Nahmias 2015-04-22 02:57:41 UTC

*** This bug has been marked as a duplicate of bug 82968 ***
Comment 14 raal 2015-04-22 06:24:03 UTC
*** Bug 90775 has been marked as a duplicate of this bug. ***
Comment 15 muso 2015-05-25 18:57:36 UTC
I have the same problem with LO 4.4.3.2. This affects not only calc, also
swriter -o file
soffice -o file
crashes.

In general command line support is totally broken, because any command line option crashes LO.

In my opinion LO 5 should not be released if the command line is not working.
Comment 16 muso 2015-05-25 18:59:22 UTC
A crash bug is by definition critical.
Comment 17 raal 2015-05-25 18:59:49 UTC
*** Bug 91621 has been marked as a duplicate of this bug. ***
Comment 18 raal 2015-05-25 19:03:12 UTC
Affect not only Calc
Comment 19 c read 2015-06-13 19:21:01 UTC
Version 4.4.4.1.0 appears to work now:
Version: 4.4.4.1.0+
Build ID: 24c5f9979e61fde7b098af60756a4890e5713390
Comment 21 Julien Nabet 2015-06-13 20:54:43 UTC
Thank you c Read for your feedback, let's put this one to WFM.