Bug Hunting Session
Bug 85792 - Strange hyperlink
Summary: Strange hyperlink
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-03 09:38 UTC by Nick222
Modified: 2015-05-26 06:37 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
01 file (10.35 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-11-03 09:38 UTC, Nick222
Details
02 file (11.36 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-11-03 09:39 UTC, Nick222
Details
Log file from fiolder with my Calc files (162.39 KB, text/plain)
2014-11-03 16:29 UTC, Nick222
Details
Demo.zip (25.73 KB, application/zip)
2015-05-26 06:37 UTC, Yogesh Bharate
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nick222 2014-11-03 09:38:47 UTC
Created attachment 108826 [details]
01 file

Calc
LibreOffice 4.3.3.2 ID: 430m0(Build:2)
Xubuntu 14.10

Two files - see attachment

In 01 file create two lists - 01 and 02
In 02 file create in A1 hyperlink on 01 file list 01 text 1
In 02 file create in A2 hyperlink on 01 file list 02 text 2

When in 02 file Ctrl-Click on A1 - open 01 file list 01
When in 02 file Ctrl-Click on A2 - open 01 file list 01 too - instead list 02...!?!
Comment 1 Nick222 2014-11-03 09:39:21 UTC
Created attachment 108827 [details]
02 file
Comment 2 Nick222 2014-11-03 09:40:08 UTC
Excuse me - both 01 and 02 files are Calc files
Comment 3 Terrence Enger 2014-11-03 15:09:31 UTC
Nick,

Thank you for taking the time to help us improve LibreOffice.

I do see the behaviour your complain about.  However, I wonder if you
*should* be able to reference a sheet name as the "Target in
Document".  Has this ever worked?  For comparison, a hyperlink to a
named range sieems to go directly where I want it to go.

When you respond, please set the bug status back to UNCONFIRMED.

Thanks,
Terry.
Comment 4 Nick222 2014-11-03 16:28:36 UTC
Now in my own files everything is OK

May be it was Java error - I find error log in my folder (see attachment)
Comment 5 Nick222 2014-11-03 16:29:23 UTC
Created attachment 108850 [details]
Log file from fiolder with my Calc files
Comment 6 Terrence Enger 2014-11-03 17:46:09 UTC
(In reply to Nick222 from comment #4)
> Now in my own files everything is OK

Bah.  I hate those.

I have been playing around with creating hyperlinks to worksheets in
another file.  Sometimes the links work, sometimes they go to the
first sheet; I do not see a pattern.

So, leaving the bug UNCONFIRMED.
Comment 7 Robinson Tryon (qubit) 2015-01-25 10:58:34 UTC
(In reply to Terrence Enger from comment #3)
> I do see the behaviour your complain about.  However, I wonder if you
> *should* be able to reference a sheet name as the "Target in
> Document".

Hmm... that's a good question.

> Has this ever worked?

Let me ask a Calc dev about this particular situation.
Comment 8 Yogesh Bharate 2015-05-26 06:37:33 UTC
This is NOT a bug.
- I have create the three file ods files containing 1.ods, 2.ods and 3.ods and link A1 to 1.ods (in 3.ods), A2 to 2.ods and A3 to 3.ods respectively.
(Find demo.zip for more details.)
- Its seem that, it shows proper links to particular documents.
- Check this on LibreOffice Ubuntu build.
Build ID:
Version: 5.1.0.0.alpha1+
Build ID: 86782d5dfc0163159369677b0ac172ed2125b221
Locale: en-IN (en_IN)
Comment 9 Yogesh Bharate 2015-05-26 06:37:52 UTC
Created attachment 116035 [details]
Demo.zip