Bug Hunting Session
Bug 85795 - Calc UI hangs when switching between worksheets (conflict with the input method called "fcitx")
Summary: Calc UI hangs when switching between worksheets (conflict with the input meth...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CJK
  Show dependency treegraph
 
Reported: 2014-11-03 10:37 UTC by m.jackie.plus
Modified: 2019-10-02 15:04 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description m.jackie.plus 2014-11-03 10:37:52 UTC
Hi,

LO calc UI hangs when using [window->freeze] in one of worksheets.

to reproduce:
1. open new calc document
2. open 2 worksheets
3. inside one of worksheets, select any cell (>=b>=2).
4. select [freeze] from [window] menu.
5. now switch to the other worksheet, press ctrl_f to open the [Find...] dialog
6. press esc to cancel the dialog
7. now UI freeze (with high cpu usage)

this also happens in my debian 7.7.0 amd64 gnome3 desktop. (but not windows)
Comment 1 Julien Nabet 2014-11-03 18:39:22 UTC
On pc Debian x86-64 with LO Debian (testing) package 4.3.3, I don't reproduce this.
(I selected B2 in worksheet1)

Did you install any LO specific extensions?
For the test, could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#GNU.2FLinux) and give it a new try?
Comment 2 m.jackie.plus 2014-11-05 07:35:44 UTC
Today I tried many fresh installs of debian and ubuntu with different locales plus fresh installation of lo in virtualbox vms, finally I figured out it was because of the input method called "fcitx" which was installed by default in debian chinese specific version conflicts with lo. I tried closed it off in my freebsd workstation, then the hang problem gone.  In ubuntu the default input method for chinese users is ibus, it runs peacefully with lo. So I'm not sure if this conflicts should be resolved by lo developers...
Comment 3 Robinson Tryon (qubit) 2014-12-21 19:29:10 UTC
(In reply to m.jackie.plus from comment #2)
> Today I tried many fresh installs of debian and ubuntu with different
> locales plus fresh installation of lo in virtualbox vms, finally I figured
> out it was because of the input method called "fcitx" which was installed by
> default in debian chinese specific version conflicts with lo.

Thanks for tracking this down!

> I tried closed
> it off in my freebsd workstation, then the hang problem gone.  In ubuntu the
> default input method for chinese users is ibus, it runs peacefully with lo.
> So I'm not sure if this conflicts should be resolved by lo developers...

It sounds like this is something for Debian to address, but I'll ask the expert :-)

Rene: Suggestions on whether this issue should be handled in Debian or in LO?
Comment 4 Rene Engelhard 2014-12-21 19:53:56 UTC
That doesn't make sense.

That obscure "Debian chinese version" installs that software.  (It's also installed when you choose chinese desktop) And? It's some software other distros might also ship.

-> not a Debian bug but a fcitx bug. (Or a LO one where it is badly interacting with it, afaicr there were some things like this with other input methods in the past, too).

Not everything which happens because some distro installs package Y is a distro bug.
Comment 5 Robinson Tryon (qubit) 2014-12-21 20:03:46 UTC
(In reply to Rene Engelhard from comment #4)
> That obscure "Debian chinese version" installs that software.  (It's also
> installed when you choose chinese desktop) And? It's some software other
> distros might also ship.
> 
> -> not a Debian bug but a fcitx bug. (Or a LO one where it is badly
> interacting with it, afaicr there were some things like this with other
> input methods in the past, too).

Looks like the first step is to repro this. Step two is to ask a LibreOffice dev to decide if it's ours or if it should go to fcitx.

Julien/Rene: Can either one of you reproduce the bug after installing the Chinese Desktop in Debian?

Thanks!
Comment 6 Julien Nabet 2014-12-21 20:13:39 UTC
(In reply to Robinson Tryon (qubit) from comment #5)
>...
> Julien/Rene: Can either one of you reproduce the bug after installing the
> Chinese Desktop in Debian?
Which one?
task-chinese-s-desktop - Simplified Chinese desktop
task-chinese-t-desktop - Traditional Chinese desktop

Then should I just give a try to the initial description to reproduce the bug or must I change a parameter in my env first?
Comment 7 Joel Madero 2015-10-16 03:36:19 UTC
This is not a critical bug, lowering to major. Reason - clearly not affecting a lot of users (note there are no dupes, no comments outside of QA and a developer).

Lastly, moving to NEEDINFO - we need clearer guidelines as to how to reproduce this (assume we're running an English locale, we'll need guides as to how to install that keyboard layout, links/pictures showing what steps to take would be nice (or a video), etc...) Once you provide the necessary stuff we'll try to move it forward.

Thanks for your patience and understanding.
Comment 8 Peter Nowee 2016-05-31 12:03:21 UTC
I can consistently reproduce this issue using the steps described in 
the original bug report.

I'm running LibreOffice 5.1.3 on Debian 8 Jessie (stable-backports 
package libreoffice 1:5.1.3-1~bpo8+1), together with fcitx 1:4.2.8.5-2. 
All x86_64/amd64.

The system and user locales have always been US English (en_US.UTF-8). 
I do not have any of the chinese-desktop packages installed, just some 
specific packages for Chinese support, such as fcitx.

It does not matter which input method is selected in fcitx. The problem 
even occurs when there is no Chinese input method configured (i.e. only 
a US English input method configured).

In LO, I tried changing the following settings in Options -> Language 
Settings -> Languages:

- Locale setting
- Checking or unchecking Default Languages for Documents -> Asian
- Selecting different languages in the dropdown next to 
  Default Languages for Documents -> Asian
- Checking or unchecking 
  Enhanced Language Support -> Ignore system input language.

It all doesn't make a difference.

For the bug to occur, fcitx needs to be running before or at step 6 of 
the steps described in the original bug report. It does not matter if 
it is running or not in the earlier steps.

The only way I can prevent LO from hanging is by not having fcitx 
running at step 6.

Answering the NEEDINFO:

Try installing fcitx without any (Chinese) input methods first. 
Considering the above, that might already be enough to reproduce the 
issue:

    $ sudo apt-get install fcitx
    $ im-config

(In im-config, select fcitx.)

Perhaps logout and login again. If the fcitx tray icon does not appear, 
start it manually:

    $ fcitx

Then follow the steps described in the original bug report to reproduce 
the bug.

If this is not enough for reproducing, let me know, so I can provide a 
full list of installed packages.

Changing from NEEDINFO to NEW.
Comment 9 QA Administrators 2017-09-01 11:16:09 UTC Comment hidden (obsolete)
Comment 10 Peter Nowee 2017-09-04 08:34:03 UTC
I can still reproduce this on LO 5.4.0.3. Different PC, running Debian Stretch 9.1 (upgraded from Debian Jessie 8) with fcitx.

With regard to step 4 of the steps to reproduce, note that Freeze Cells has moved in the menu structure. Step 4 should now read:

4. View -> Freeze Cells -> Freeze Rows and Columns

I tried with both GTK+ 2 and GTK+ 3. Application hangs with both.
Comment 11 Kevin Suo 2017-10-12 01:46:51 UTC
I also reproduce this issue.
I reported a similar bug 112998 (currently in UNCONFIRMED status) which is also related to hang when Fcitx enabled. Maybe You guys can try to reproduce that one.
Comment 12 QA Administrators 2018-10-13 03:14:34 UTC Comment hidden (obsolete)
Comment 13 Peter Nowee 2018-12-15 12:56:19 UTC
I can still reproduce this bug in LO 6.1.3.2.

Version: 6.1.3.2
Build ID: 1:6.1.3-1~bpo9+2
CPU threads: 2; OS: Linux 4.18; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group threaded
Comment 14 Peter Nowee 2019-10-02 14:50:31 UTC
I currently cannot reproduce both fcitx-related issues (bug 85795 and
bug 112998) either with gtk2 or gtk3 anymore.

Version: 6.3.2.2
Build ID: 1:6.3.2-1~bpo10+1
CPU threads: 2; OS: Linux 4.19; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Version: 6.3.2.2
Build ID: 1:6.3.2-1~bpo10+1
CPU threads: 2; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

However, since the last time I could still reproduce at least one of
the bugs, I upgraded LibreOffice, fcitx and many other components on my
system:

LO           6.1.3.2 (*)  -> 6.3.2.2
fcitx        4.2.9.1-6    -> 4.2.9.6-5
libgtk2.0-0  2.24.31-2    -> 2.24.32-3
libgtk-3-0   3.22.11-1    -> 3.24.5-1
Debian       9            -> 10

* Bug 112998 last tested and reproduced with 5.4.2.2.0+. Bug 85795 with
  LO 6.1.3.2.

So, while something seems to have been fixed somewhere to make the bug
disappear for me, there may still be a problem with LO that let the bug
show up before and maybe let it show up again in the future under
certain circumstances. For example, if a bug was fixed in fcitx to make
this disappear now, LO still should not have hung even if fcitx had a
bug, right?

Of course, there is no need in keeping a report open for a bug that has
become unreproducible, but I cannot assume that just based on my own
report.

Maybe others can confirm that this has become unreproducible for them
as well or someone can point to a specific fix that was made in LO, and
then close this bug.

I will post this in both bugs 85795 and 112998, as they seem very
related. Not sure enough to mark one of them as duplicate, though.
Again, maybe someone else can confirm before doing that.
Comment 15 Buovjaga 2019-10-02 14:55:23 UTC
Thanks, let's close
Comment 16 Peter Nowee 2019-10-02 15:04:57 UTC
Alright then :) Thanks.